ruby-hpricot_0.8.6-6+b4_amd64.deb


Advertisement

Description

ruby-hpricot - fast, enjoyable HTML parser

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-hpricot
Package version 0.8.6
Package release 6+b4
Package architecture amd64
Package type deb
Installed size 247 B
Download size 65.17 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-hpricot_0.8.6-6+b4_i386.deb 0.8.6 i386 Debian Main
ruby-hpricot - - -

Requires

Name Value
libc6 >= 2.14
libgmp10 -
libruby2.5 >= 2.5.0~preview1
ruby << 1:2.6~
ruby >= 1:2.5~0
ruby-fast-xs -

Download

Type URL
Binary Package ruby-hpricot_0.8.6-6+b4_amd64.deb
Source Package ruby-hpricot

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-hpricot deb package:
    # sudo apt-get install ruby-hpricot

Files

Path
/usr/lib/ruby/vendor_ruby/hpricot.rb
/usr/lib/ruby/vendor_ruby/hpricot/blankslate.rb
/usr/lib/ruby/vendor_ruby/hpricot/builder.rb
/usr/lib/ruby/vendor_ruby/hpricot/elements.rb
/usr/lib/ruby/vendor_ruby/hpricot/htmlinfo.rb
/usr/lib/ruby/vendor_ruby/hpricot/inspect.rb
/usr/lib/ruby/vendor_ruby/hpricot/modules.rb
/usr/lib/ruby/vendor_ruby/hpricot/parse.rb
/usr/lib/ruby/vendor_ruby/hpricot/tag.rb
/usr/lib/ruby/vendor_ruby/hpricot/tags.rb
/usr/lib/ruby/vendor_ruby/hpricot/traverse.rb
/usr/lib/ruby/vendor_ruby/hpricot/xchar.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/hpricot_scan.so
/usr/share/doc/ruby-hpricot/NEWS.Debian.gz
/usr/share/doc/ruby-hpricot/README.md.gz
/usr/share/doc/ruby-hpricot/changelog.Debian.amd64.gz
/usr/share/doc/ruby-hpricot/changelog.Debian.gz
/usr/share/doc/ruby-hpricot/changelog.gz
/usr/share/doc/ruby-hpricot/copyright
/usr/share/rubygems-integration/2.5.0/specifications/hpricot-0.8.6.gemspec

Changelog

2016-01-12 - Antonio Terceiro <terceiro@debian.org>
ruby-hpricot (0.8.6-6) unstable; urgency=medium
* Team upload.
* Always remove unnecessary binary extension (Closes: #806191)
- move its removal from debian/ruby-tests.rb, what is utterly wrong, from
override_dh_auto_install in debian/fules
2014-01-15 - Christian Hofstaedtler <zeha@debian.org>
ruby-hpricot (0.8.6-5) unstable; urgency=medium
* Team upload.
* Disable tests that fail on armel, armhf, mipsel
2013-12-31 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-hpricot (0.8.6-4) unstable; urgency=low
* Team upload.
[ Cédric Boutillier ]
* debian/control:
- remove obsolete DM-Upload-Allowed flag
- use canonical URI in Vcs-* fields
* debian/copyright: use DEP5 copyright-format/1.0 official URL
for Format field
[ Christian Hofstaedtler ]
* Remove transitional packages
* Bump Standards-Version to 3.9.5 (no changes)
* Update Build-Depends for ruby2.0, drop ruby1.8
[ Jonas Genannt ]
* d/ruby-hpricot.NEWS added NEWS file about hpricot EOL
* d/ruby-tests.rb: force encoding to UTF-8, to make tests work
2012-06-30 - Tollef Fog Heen <tfheen@debian.org>
ruby-hpricot (0.8.6-3) unstable; urgency=low
* Stop shipping fast_xs and depend on it instead.  Closes: 679606
2012-06-26 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-hpricot (0.8.6-2) unstable; urgency=low
* Bump build dependency on gem2deb to >= 0.3.0~
2012-01-25 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-hpricot (0.8.6-1) unstable; urgency=low
* New upstream version
* Ignore test results on ia64 for now. See #653582.
2011-11-30 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-hpricot (0.8.5-1) unstable; urgency=low
* New upstream version
* Priority of transitional packages set to extra
* Override lintian warnings about duplicate description of transitional
packages
2011-08-19 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-hpricot (0.8.4-1) unstable; urgency=low
* New upstream release
* Migrated to gem2deb packaging
+ rename binary and source packages
* Add myself to uploaders
2010-01-29 - Ryan Niebur <ryan@debian.org>
libhpricot-ruby (0.8.2-1) unstable; urgency=low
* New upstream release
* switch to ruby 1.9.1 (Closes: #565837)
* update email address
2009-08-19 - Micah Anderson <micah@debian.org>
libhpricot-ruby (0.8.1-1) unstable; urgency=low
* New upstream release
* Bump Standards-Version (no changes)
* Add myself to uploaders

See Also

Package Description
ruby-html-pipeline_2.8.4-1_all.deb GitHub HTML processing filters and utilities
ruby-html2haml_2.2.0-1_all.deb Converts HTML into Haml
ruby-html2text_0.2.0-1_all.deb convert HTML into plain text
ruby-htmlentities_4.3.3-1_all.deb Ruby library for handling HTML entities
ruby-htree_0.8+dfsg-3_all.deb HTML/XML tree library for Ruby
ruby-http-accept-language_2.1.1-2_all.deb Ruby library that finds out which locale the user prefers
ruby-http-connection_1.4.4-1_all.deb HTTP helper library for Ruby
ruby-http-cookie_1.0.2-1_all.deb Ruby library to handle HTTP Cookies based on RFC 6265
ruby-http-form-data_1.0.1+gemwatch-1_all.deb utility-belt to build form data request bodies
ruby-http-parser.rb-doc_0.6.0-4_all.deb Simple callback-based HTTP request/response parser (documentation)
ruby-http-parser.rb_0.6.0-4+b3_amd64.deb Simple callback-based HTTP request/response parser
ruby-http_2.2.2-1_all.deb easy-to-use client library for making http requests from Ruby
ruby-httparty_0.16.2+dfsg1-1_all.deb quick web service consumption from any Ruby class
ruby-httpauth_0.2.1+gh-1_all.deb Ruby library for the HTTP authentication protocol (RFC 2617)
ruby-httpclient_2.8.3-1_all.deb HTTP client library for ruby
Advertisement
Advertisement