ruby-highline_1.7.8-1_all.deb


Advertisement

Description

ruby-highline - high-level interactive IO Ruby library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-highline
Package version 1.7.8
Package release 1
Package architecture all
Package type deb
Installed size 173 B
Download size 46.29 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-highline_1.7.8-1_all.deb 1.7.8 all Debian Main
ruby-highline - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-highline_1.7.8-1_all.deb
Source Package ruby-highline

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-highline deb package:
    # sudo apt-get install ruby-highline

Files

Path
/usr/lib/ruby/vendor_ruby/highline.rb
/usr/lib/ruby/vendor_ruby/highline/color_scheme.rb
/usr/lib/ruby/vendor_ruby/highline/compatibility.rb
/usr/lib/ruby/vendor_ruby/highline/import.rb
/usr/lib/ruby/vendor_ruby/highline/menu.rb
/usr/lib/ruby/vendor_ruby/highline/question.rb
/usr/lib/ruby/vendor_ruby/highline/simulate.rb
/usr/lib/ruby/vendor_ruby/highline/string_extensions.rb
/usr/lib/ruby/vendor_ruby/highline/style.rb
/usr/lib/ruby/vendor_ruby/highline/system_extensions.rb
/usr/lib/ruby/vendor_ruby/highline/version.rb
/usr/share/doc/ruby-highline/README.rdoc
/usr/share/doc/ruby-highline/changelog.Debian.gz
/usr/share/doc/ruby-highline/changelog.gz
/usr/share/doc/ruby-highline/copyright
/usr/share/doc/ruby-highline/examples/ansi_colors.rb
/usr/share/doc/ruby-highline/examples/asking_for_arrays.rb
/usr/share/doc/ruby-highline/examples/basic_usage.rb
/usr/share/doc/ruby-highline/examples/color_scheme.rb
/usr/share/doc/ruby-highline/examples/get_character.rb
/usr/share/doc/ruby-highline/examples/limit.rb
/usr/share/doc/ruby-highline/examples/menus.rb
/usr/share/doc/ruby-highline/examples/overwrite.rb
/usr/share/doc/ruby-highline/examples/page_and_wrap.rb
/usr/share/doc/ruby-highline/examples/password.rb
/usr/share/doc/ruby-highline/examples/repeat_entry.rb
/usr/share/doc/ruby-highline/examples/trapping_eof.rb
/usr/share/doc/ruby-highline/examples/using_readline.rb
/usr/share/rubygems-integration/all/specifications/highline-1.7.8.gemspec

Changelog

2016-05-05 - Christian Hofstaedtler <zeha@debian.org>
ruby-highline (1.7.8-1) unstable; urgency=medium
* Team upload.
[ Cédric Boutillier ]
* Bump debhelper compatibility level to 9
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Christian Hofstaedtler ]
* New upstream version, refreshed local patches.
2015-06-20 - Antonio Terceiro <terceiro@debian.org>
ruby-highline (1.7.2-1) unstable; urgency=medium
* Team upload
* New upstream release
* disable_test_terminal_size.patch: refresh
* Update packaging with a new dh-make-ruby run
2014-05-07 - Cédric Boutillier <boutil@debian.org>
ruby-highline (1.6.21-1) unstable; urgency=medium
* Imported Upstream version 1.6.21
* Build with newer gem2deb; installing rubygems metadata in a Ruby version
independent directory.
2014-01-10 - Cédric Boutillier <boutil@debian.org>
ruby-highline (1.6.20-1) unstable; urgency=medium
* Imported Upstream version 1.6.20
* Bump Standards-Version to 3.9.5 (no changes needed)
* Refresh disable_test_terminal_size.patch
2013-06-28 - Cédric Boutillier <boutil@debian.org>
ruby-highline (1.6.19-1) unstable; urgency=low
[ Prach Pongpanich ]
* Imported Upstream version 1.6.19
* Bump Standards-Version to 3.9.4 (no changes needed)
* Drop transitional binary packages
[ Cédric Boutillier ]
* debian/control:
+ remove obsolete DM-Upload-Allowed flag
+ use canonical URI in Vcs-* fields
+ improve description
+ update my email address
* set external encoding when needed for tests
* update my email address and years in debian/copyright
* remove lintian-overrides, about transitional packages
* add disable_test_terminal_size.patch: disable a failing test with
pbuilder/sbuild.
2012-06-26 - Per Andersson <avtobiff@gmail.com>
ruby-highline (1.6.13-2) unstable; urgency=low
* Added myself to uploaders.
* Build depend on gem2deb >= 0.3.0.
* debian/copyright: change reference from common-licenses symlink LPGL to
LGPL-2.1.
- Fix lintian warning.
2012-06-21 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-highline (1.6.13-1) unstable; urgency=low
* New upstream version
* Drop patches (merged upstream)
2012-05-16 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-highline (1.6.12-1) unstable; urgency=low
* New upstream version
* Add myself to Uploaders:
* Bump Standards-Version: to 3.9.3 (no changes needed)
* Use Breaks instead of Conflicts for transitional packages
* Set Priority of transitional packages to extra
* Convert copyright file to DEP-5
* Override lintian warning about duplicate description for transitional
packages
* debian/patches:
+ update remove-shebangs.patch to include new files
+ add change-shebangs-in-examples.patch fixing shebangs in examples
2011-06-05 - Lucas Nussbaum <lucas@debian.org>
ruby-highline (1.6.2-1) unstable; urgency=low
* New upstream version.
* Switch to gem2deb-based packaging.
2010-02-14 - Paul van Tilburg <paulvt@debian.org>
libhighline-ruby (1.5.2-1) unstable; urgency=low
[ Ryan Niebur ]
* set myself as Maintainer
[ Paul van Tilburg ]
* New upstream release. 
* Added support for Ruby 1.9.1.
* debian/control:
- Bumped standards version to 3.8.4.
- Bumped debhelper build-depend to >= 5.
- Added a libhighline-ruby1.9.1 package entry.
- Added a build depend on ruby1.9.1.

See Also

Package Description
ruby-hike_1.2.1-3_all.deb Ruby library to find files in a set of paths
ruby-hikidoc_0.1.0-2_all.deb text-to-HTML conversion tool for web writers
ruby-hipchat_1.5.2-3_all.deb Ruby library to interact with HipChat
ruby-hiredis_0.6.1-2_amd64.deb Redis driver for Ruby using Hiredis
ruby-hitimes_1.2.1-3+b5_amd64.deb fast, high resolution timer for recording performance metrics
ruby-hivex_1.3.15-1+b3_amd64.deb Ruby bindings for hivex
ruby-hmac_0.4.0-5_all.deb Ruby interface for HMAC algorithm
ruby-hocon_1.2.5-1_all.deb Ruby port of the Typesafe Config library
ruby-hoe_3.16.0-1_all.deb rake/rubygems helper for project Rakefiles
ruby-hpricot_0.8.6-6+b4_amd64.deb fast, enjoyable HTML parser
ruby-html-pipeline_2.8.4-1_all.deb GitHub HTML processing filters and utilities
ruby-html2haml_2.2.0-1_all.deb Converts HTML into Haml
ruby-html2text_0.2.0-1_all.deb convert HTML into plain text
ruby-htmlentities_4.3.3-1_all.deb Ruby library for handling HTML entities
ruby-htree_0.8+dfsg-3_all.deb HTML/XML tree library for Ruby
Advertisement
Advertisement