ruby-haml_4.0.7-1_all.deb


Advertisement

Description

ruby-haml - Elegant, structured XHTML/XML templating engine

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-haml
Package version 4.0.7
Package release 1
Package architecture all
Package type deb
Installed size 878 B
Download size 120.58 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-haml_4.0.7-1_all.deb 4.0.7 all Debian Main
ruby-haml - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-tilt -

Download

Type URL
Binary Package ruby-haml_4.0.7-1_all.deb
Source Package ruby-haml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-haml deb package:
    # sudo apt-get install ruby-haml

Files

Path
/usr/bin/haml
/usr/lib/ruby/vendor_ruby/haml.rb
/usr/lib/ruby/vendor_ruby/haml/buffer.rb
/usr/lib/ruby/vendor_ruby/haml/compiler.rb
/usr/lib/ruby/vendor_ruby/haml/engine.rb
/usr/lib/ruby/vendor_ruby/haml/error.rb
/usr/lib/ruby/vendor_ruby/haml/exec.rb
/usr/lib/ruby/vendor_ruby/haml/filters.rb
/usr/lib/ruby/vendor_ruby/haml/helpers.rb
/usr/lib/ruby/vendor_ruby/haml/options.rb
/usr/lib/ruby/vendor_ruby/haml/parser.rb
/usr/lib/ruby/vendor_ruby/haml/railtie.rb
/usr/lib/ruby/vendor_ruby/haml/sass_rails_filter.rb
/usr/lib/ruby/vendor_ruby/haml/template.rb
/usr/lib/ruby/vendor_ruby/haml/util.rb
/usr/lib/ruby/vendor_ruby/haml/version.rb
/usr/lib/ruby/vendor_ruby/haml/helpers/action_view_extensions.rb
/usr/lib/ruby/vendor_ruby/haml/helpers/action_view_mods.rb
/usr/lib/ruby/vendor_ruby/haml/helpers/action_view_xss_mods.rb
/usr/lib/ruby/vendor_ruby/haml/helpers/safe_erubis_template.rb
/usr/lib/ruby/vendor_ruby/haml/helpers/xss_mods.rb
/usr/lib/ruby/vendor_ruby/haml/template/options.rb
/usr/lib/ruby/vendor_ruby/haml/template/plugin.rb
/usr/share/doc-base/ruby-haml-doc
/usr/share/doc/ruby-haml/TODO.Debian
/usr/share/doc/ruby-haml/changelog.Debian.gz
/usr/share/doc/ruby-haml/changelog.gz
/usr/share/doc/ruby-haml/copyright
/usr/share/doc/ruby-haml/yardoc/ActionView.html
/usr/share/doc/ruby-haml/yardoc/Haml.html
/usr/share/doc/ruby-haml/yardoc/_index.html
/usr/share/doc/ruby-haml/yardoc/class_list.html
/usr/share/doc/ruby-haml/yardoc/css
/usr/share/doc/ruby-haml/yardoc/file.CHANGELOG.html
/usr/share/doc/ruby-haml/yardoc/file.FAQ.html
/usr/share/doc/ruby-haml/yardoc/file.MIT-LICENSE.html
/usr/share/doc/ruby-haml/yardoc/file.README.html
/usr/share/doc/ruby-haml/yardoc/file.REFERENCE.html
/usr/share/doc/ruby-haml/yardoc/file_list.html
/usr/share/doc/ruby-haml/yardoc/frames.html
/usr/share/doc/ruby-haml/yardoc/index.html
/usr/share/doc/ruby-haml/yardoc/js
/usr/share/doc/ruby-haml/yardoc/method_list.html
/usr/share/doc/ruby-haml/yardoc/top-level-namespace.html
/usr/share/doc/ruby-haml/yardoc/ActionView/Helpers.html
/usr/share/doc/ruby-haml/yardoc/ActionView/Helpers/CaptureHelper.html
/usr/share/doc/ruby-haml/yardoc/ActionView/Helpers/FormHelper.html
/usr/share/doc/ruby-haml/yardoc/ActionView/Helpers/FormTagHelper.html
/usr/share/doc/ruby-haml/yardoc/ActionView/Helpers/TextHelper.html
/usr/share/doc/ruby-haml/yardoc/Haml/Buffer.html
/usr/share/doc/ruby-haml/yardoc/Haml/Compiler.html
/usr/share/doc/ruby-haml/yardoc/Haml/Engine.html
/usr/share/doc/ruby-haml/yardoc/Haml/Error.html
/usr/share/doc/ruby-haml/yardoc/Haml/ErubisTemplateHandler.html
/usr/share/doc/ruby-haml/yardoc/Haml/Exec.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters.html
/usr/share/doc/ruby-haml/yardoc/Haml/Helpers.html
/usr/share/doc/ruby-haml/yardoc/Haml/Options.html
/usr/share/doc/ruby-haml/yardoc/Haml/Parser.html
/usr/share/doc/ruby-haml/yardoc/Haml/SafeErubisTemplate.html
/usr/share/doc/ruby-haml/yardoc/Haml/SyntaxError.html
/usr/share/doc/ruby-haml/yardoc/Haml/Template.html
/usr/share/doc/ruby-haml/yardoc/Haml/Util.html
/usr/share/doc/ruby-haml/yardoc/Haml/Exec/Generic.html
/usr/share/doc/ruby-haml/yardoc/Haml/Exec/Haml.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Base.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Cdata.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Coffee.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Css.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Erb.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Escaped.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Javascript.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Less.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Markdown.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Plain.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Preserve.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Ruby.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Sass.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/SassRailsTemplate.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/Scss.html
/usr/share/doc/ruby-haml/yardoc/Haml/Filters/ScssRailsTemplate.html
/usr/share/doc/ruby-haml/yardoc/Haml/Helpers/ActionViewExtensions.html
/usr/share/doc/ruby-haml/yardoc/Haml/Helpers/ErrorReturn.html
/usr/share/doc/ruby-haml/yardoc/Haml/Util/StaticConditionalContext.html
/usr/share/man/man1/haml.1.gz
/usr/share/rubygems-integration/all/specifications/haml-4.0.7.gemspec

Changelog

2015-10-30 - Pirate Praveen <praveen@debian.org>
ruby-haml (4.0.7-1) unstable; urgency=low
[ Nitesh A Jain ]
* Team upload
* New upstream release
* Change upstream homepage link
2015-08-29 - Pirate Praveen <praveen@debian.org>
ruby-haml (4.0.6-1) unstable; urgency=medium
* Team upload.
* New upstream release
* Remove patch fix_tests_form_opener_rails4.patch (not required)
* Bump standards version to 3.9.6 (no changes)
2014-09-12 - Cédric Boutillier <boutil@debian.org>
ruby-haml (4.0.5-2) unstable; urgency=medium
* Team upload.
* Change rails3 to rails in dependencies (Closes: #760914)
* debian/copyright:
+ drop File paragraph about vendor/fssm (not present)
+ rename MIT to Expat
+ update source URL
* Fix relative path for the symlink to yard css/js
* Add link to avoid duplicate files in the HTML doc
* Add fix_tests_form_opener_rails4.patch to fix tests with Rails 4+
* Add privacy_breach.patch to remove links to remote images in the HTML
documentation
2014-01-31 - Gunnar Wolf <gwolf@debian.org>
ruby-haml (4.0.5-1) unstable; urgency=low
* Team upload.
* New upstream version
* Standards-version 3.9.4→3.9.5 (no changes needed)
* Upstream requires Rails >= 3.2, reflecting it in the dependencies
2013-08-20 - Cédric Boutillier <boutil@debian.org>
ruby-haml (4.0.3-3) unstable; urgency=low
* Team upload.
* Explicitly build-depend and depend on ruby-tilt. (Closes: #713161)
* Remove lintian overrides, about dropped transitional packages.
2013-06-05 - Jérémy Bobbio <lunar@debian.org>
ruby-haml (4.0.3-2) unstable; urgency=low
* Team upload.
* Fix Build-Depends to match the test suite needs.
* Add a patch to avoid using rubygems in tests.
* Bump Standards-Version to 3.9.4, no changes required.
* Drop transitional packages now that Wheezy is stable.
* Add git-buildpackage configuration.
2013-05-23 - Gunnar Wolf <gwolf@debian.org>
ruby-haml (4.0.3-1) unstable; urgency=low
* New major upstream release
* Upstream has split the 'html2haml' functionality into a different gem;
adding it as 'Recommends' (ITP filed). This change makes ruby-haml not
to have to depend on ruby-hpricot (Closes: #696834)
* No longer supports Rails <= 3; b-d-i and suggests updated from the
'rails' (2.x) to the 'rails3' packages.
* Added recommends: and b-d-i: on ruby-erubis
* Drop both the 003fix-root-path and remove_require_rubygems patches, as
they are no longer needed
* Added suggests: on yard, in order to skip including duplicated
Javascript files found there (and added by it during the build)
2012-06-24 - Paul van Tilburg <paulvt@debian.org>
ruby-haml (3.1.6-1) unstable; urgency=low
* New upstream release.
* debian/control:
- Bumped the build-depend on ruby-haml to 0.3.0.
- Bumped the standars-version to 3.9.3.
* debian/copyright: use the Debian copyright format version 1.0.
* debian/patches:
- Added remove_require_rubygems.patch.
* debian/ruby-haml.doc-base: added.
* debian/rules, debian/ruby-test*: use the upstream Rakefile to run
the tests and supply a symlink to rails to make them runable.
* debian/source/lintian-overrides: added overrides for the descriptions
of the transitional packages.
2012-01-06 - Gunnar Wolf <gwolf@debian.org>
ruby-haml (3.1.4-2) unstable; urgency=low
* Stop building and providing/conflicting/replacing the (empty) haml-
elisp package, as it has become an independent package of its own

See Also

Package Description
ruby-hamlit_2.8.8-1_amd64.deb High Performance Haml Implementation
ruby-hamster_3.0.0-2_all.deb Efficient, immutable, thread-safe collection classes for Ruby
ruby-handlebars-assets_0.23.2+dfsg-2_all.deb compile Handlebars templates in the Rails asset pipeline
ruby-hashdiff_0.2.3-1_all.deb library for computing the smallest difference between two hashes
ruby-hashery_2.1.2-1_all.deb facets-bread collection of Hash-like classes
ruby-hashie-forbidden-attributes_0.1.1-1_all.deb strong parameter detection with Hashie and Forbidden Attributes
ruby-hashie_3.5.5-2_all.deb small collection of tools that make hashes more powerful
ruby-hdfeos5_1.2-9_amd64.deb Ruby interface to the HDF-EOS5 library
ruby-health-check_2.6.0-1_all.deb Simple health check of Rails app for uptime monitoring
ruby-highline_1.7.8-1_all.deb high-level interactive IO Ruby library
ruby-hike_1.2.1-3_all.deb Ruby library to find files in a set of paths
ruby-hikidoc_0.1.0-2_all.deb text-to-HTML conversion tool for web writers
ruby-hipchat_1.5.2-3_all.deb Ruby library to interact with HipChat
ruby-hiredis_0.6.1-2_amd64.deb Redis driver for Ruby using Hiredis
ruby-hitimes_1.2.1-3+b5_amd64.deb fast, high resolution timer for recording performance metrics
Advertisement
Advertisement