ruby-grib_0.4.0-2+b2_amd64.deb


Advertisement

Description

ruby-grib - Ruby interface to the ECMWF GRIB API

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-grib
Package version 0.4.0
Package release 2+b2
Package architecture amd64
Package type deb
Installed size 94 B
Download size 18.43 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-grib_0.4.0-2+b2_i386.deb 0.4.0 i386 Debian Main
ruby-grib - - -

Requires

Name Value
libc6 >= 2.4
libeccodes0 -
libgmp10 -
libgrib-api-tools -
libruby2.5 >= 2.5.0~preview1
ruby << 1:2.6~
ruby >= 1:2.5~0

Download

Type URL
Binary Package ruby-grib_0.4.0-2+b2_amd64.deb
Source Package ruby-grib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-grib deb package:
    # sudo apt-get install ruby-grib

Files

Path
/usr/lib/ruby/vendor_ruby/numru/grib.rb
/usr/lib/ruby/vendor_ruby/numru/grib/grib.rb
/usr/lib/ruby/vendor_ruby/numru/grib/setenv.rb
/usr/lib/ruby/vendor_ruby/numru/grib/version.rb
/usr/lib/ruby/vendor_ruby/numru/grib/definitions/grib1/localConcepts/kwbc/name.def
/usr/lib/ruby/vendor_ruby/numru/grib/definitions/grib1/localConcepts/kwbc/paramId.def
/usr/lib/ruby/vendor_ruby/numru/grib/definitions/grib1/localConcepts/kwbc/shortName.def
/usr/lib/ruby/vendor_ruby/numru/grib/definitions/grib1/localConcepts/kwbc/units.def
/usr/lib/ruby/vendor_ruby/numru/grib/definitions/grib2/localConcepts/rjtd/name.def
/usr/lib/ruby/vendor_ruby/numru/grib/definitions/grib2/localConcepts/rjtd/paramId.def
/usr/lib/ruby/vendor_ruby/numru/grib/definitions/grib2/localConcepts/rjtd/shortName.def
/usr/lib/ruby/vendor_ruby/numru/grib/definitions/grib2/localConcepts/rjtd/units.def
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/numru/grib.so
/usr/share/doc/ruby-grib/README.rdoc
/usr/share/doc/ruby-grib/changelog.Debian.amd64.gz
/usr/share/doc/ruby-grib/changelog.Debian.gz
/usr/share/doc/ruby-grib/copyright
/usr/share/rubygems-integration/2.5.0/specifications/rb-grib-0.4.0.gemspec

Changelog

2017-09-25 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-grib (0.4.0-2) unstable; urgency=medium
* Add patch: Use eccodes instead of grib_api
* Use eccodes instead of grib_api (Closes: #868930)
* Bump Standard Version: 4.1.0
* Update debian/changelog
* Add debian/tests for autopkgtest
* Add patch: Remove git ls-files from gemspec
2016-11-07 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-grib (0.4.0-1) unstable; urgency=medium
* New upstream version 0.4.0
* Refresh patch
2016-06-20 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-grib (0.3.0-1) unstable; urgency=medium
[ Cédric Boutillier ]
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Youhei SASAKI ]
* Imported Upstream version 0.3.0
* Refresh patch: Drop obsolete patches (merge upstream)
* Add patch: Search NArray from vendorarchdir
* Bump Standard version: 3.9.8
* Drop -dbg package
2015-07-15 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-grib (0.2.2-4) unstable; urgency=medium
[ Cédric Boutillier ]
* debian/control: remove obsolete DM-Upload-Allowed flag
* use canonical URI in Vcs-* fields
* debian/copyright: use DEP5 copyright-format/1.0 official URL for Format field
[ Youhei SASAKI ]
* Fix incorrect VCS field
* Bump Standard Version: 3.9.6
* Fix for FTBFS(RSpec syntax),
Thanks to Alastair McKinstry (Closes: #791789)
2012-06-30 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-grib (0.2.2-3) unstable; urgency=low
* Bump build dependency on gem2deb to >= 0.3.0~
2012-06-17 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-grib (0.2.2-2) unstable; urgency=low
* Refresh patches: using gbp-pq
- Fix for FTBFS(hardening), Thanks to Lucas, Andreas! (Closes: #676196)
- Fix RSpec LOAD_PATH in order to running RSpec during Build
* Execute RSpec during build
* Add Depends: libgrib-api-tools
2012-03-22 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-grib (0.2.2-1) unstable; urgency=low
* New upstream version: 0.2.2
* Add libgrib-api-tools to Build-Depends
* Bump Standard Version: 3.9.3
2012-01-09 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-grib (0.2.0-1) unstable; urgency=low
* Initial release (Closes: #655538)

See Also

Package Description
ruby-grit-ext_0.8.1-2_all.deb utf-8 support extension for grit
ruby-grit_2.8.2-2_all.deb Ruby Git bindings
ruby-grpc-tools_1.16.0-1_all.deb Development tools for Ruby gRPC
ruby-grpc_1.16.0-1_amd64.deb GRPC system in Ruby
ruby-gruff_0.6.0-1_all.deb Ruby library to create beautiful graphs for one or multiple datasets
ruby-gsl_2.1.0.3+dfsg1-1+b1_amd64.deb Ruby bindings for the GNU Scientific Library (GSL)
ruby-gssapi_1.2.0-1_all.deb FFI wrapper around the system GSSAPI library
ruby-gstreamer_3.3.0-1_amd64.deb GStreamer bindings for the Ruby language
ruby-gtk2_3.3.0-1_amd64.deb GTK+ 2 bindings for the Ruby language
ruby-gtk3_3.3.0-1_amd64.deb GTK+ 3 bindings for the Ruby language
ruby-gtksourceview4_3.3.0-1_all.deb GtkSourceView4 bindings for the Ruby language
ruby-guard-compat_1.2.1-2_all.deb Test helper for testing custom Guard plugins
ruby-guard-shell_0.7.1-2_all.deb Guard plugin for running shell commands
ruby-guard_2.14.2-2_all.deb Commandline to easily handle events on file system modifications
ruby-guestfs_1.38.6-2+b1_amd64.deb guest disk image management system - Ruby bindings
Advertisement
Advertisement