ruby-grape_1.0.3-1_all.deb


Advertisement

Description

ruby-grape - Simple Ruby framework for building REST-like APIs

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-grape
Package version 1.0.3
Package release 1
Package architecture all
Package type deb
Installed size 404 B
Download size 108.36 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-grape_1.0.3-1_all.deb 1.0.3 all Debian Main
ruby-grape - - -

Requires

Name Value
ruby -
ruby-activesupport -
ruby-builder -
ruby-interpreter -
ruby-mustermann-grape >= 1.0~
ruby-rack >= 1.3~
ruby-rack-accept >= 0.4.5-3~
ruby-virtus >= 1.0~

Download

Type URL
Binary Package ruby-grape_1.0.3-1_all.deb
Source Package ruby-grape

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-grape deb package:
    # sudo apt-get install ruby-grape

Files

Path
/usr/lib/ruby/vendor_ruby/grape.rb
/usr/lib/ruby/vendor_ruby/grape/api.rb
/usr/lib/ruby/vendor_ruby/grape/cookies.rb
/usr/lib/ruby/vendor_ruby/grape/endpoint.rb
/usr/lib/ruby/vendor_ruby/grape/error_formatter.rb
/usr/lib/ruby/vendor_ruby/grape/formatter.rb
/usr/lib/ruby/vendor_ruby/grape/namespace.rb
/usr/lib/ruby/vendor_ruby/grape/parser.rb
/usr/lib/ruby/vendor_ruby/grape/path.rb
/usr/lib/ruby/vendor_ruby/grape/request.rb
/usr/lib/ruby/vendor_ruby/grape/router.rb
/usr/lib/ruby/vendor_ruby/grape/validations.rb
/usr/lib/ruby/vendor_ruby/grape/version.rb
/usr/lib/ruby/vendor_ruby/grape/api/helpers.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/api.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/callbacks.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/configuration.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/desc.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/headers.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/helpers.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/inside_route.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/logger.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/middleware.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/parameters.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/request_response.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/routing.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/settings.rb
/usr/lib/ruby/vendor_ruby/grape/dsl/validations.rb
/usr/lib/ruby/vendor_ruby/grape/error_formatter/base.rb
/usr/lib/ruby/vendor_ruby/grape/error_formatter/json.rb
/usr/lib/ruby/vendor_ruby/grape/error_formatter/txt.rb
/usr/lib/ruby/vendor_ruby/grape/error_formatter/xml.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/base.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/incompatible_option_values.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/invalid_accept_header.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/invalid_formatter.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/invalid_message_body.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/invalid_version_header.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/invalid_versioner_option.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/invalid_with_option_for_represent.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/method_not_allowed.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/missing_group_type.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/missing_mime_type.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/missing_option.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/missing_vendor_option.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/unknown_options.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/unknown_parameter.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/unknown_validator.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/unsupported_group_type.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/validation.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/validation_array_errors.rb
/usr/lib/ruby/vendor_ruby/grape/exceptions/validation_errors.rb
/usr/lib/ruby/vendor_ruby/grape/extensions/deep_hash_with_indifferent_access.rb
/usr/lib/ruby/vendor_ruby/grape/extensions/deep_mergeable_hash.rb
/usr/lib/ruby/vendor_ruby/grape/extensions/deep_symbolize_hash.rb
/usr/lib/ruby/vendor_ruby/grape/extensions/hash.rb
/usr/lib/ruby/vendor_ruby/grape/extensions/active_support/hash_with_indifferent_access.rb
/usr/lib/ruby/vendor_ruby/grape/extensions/hashie/mash.rb
/usr/lib/ruby/vendor_ruby/grape/formatter/json.rb
/usr/lib/ruby/vendor_ruby/grape/formatter/serializable_hash.rb
/usr/lib/ruby/vendor_ruby/grape/formatter/txt.rb
/usr/lib/ruby/vendor_ruby/grape/formatter/xml.rb
/usr/lib/ruby/vendor_ruby/grape/http/headers.rb
/usr/lib/ruby/vendor_ruby/grape/locale/en.yml
/usr/lib/ruby/vendor_ruby/grape/middleware/base.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/error.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/filter.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/formatter.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/globals.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/stack.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/versioner.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/auth/base.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/auth/dsl.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/auth/strategies.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/auth/strategy_info.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/versioner/accept_version_header.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/versioner/header.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/versioner/param.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/versioner/parse_media_type_patch.rb
/usr/lib/ruby/vendor_ruby/grape/middleware/versioner/path.rb
/usr/lib/ruby/vendor_ruby/grape/parser/json.rb
/usr/lib/ruby/vendor_ruby/grape/parser/xml.rb
/usr/lib/ruby/vendor_ruby/grape/presenters/presenter.rb
/usr/lib/ruby/vendor_ruby/grape/router/attribute_translator.rb
/usr/lib/ruby/vendor_ruby/grape/router/pattern.rb
/usr/lib/ruby/vendor_ruby/grape/router/route.rb
/usr/lib/ruby/vendor_ruby/grape/serve_file/file_body.rb
/usr/lib/ruby/vendor_ruby/grape/serve_file/file_response.rb
/usr/lib/ruby/vendor_ruby/grape/serve_file/sendfile_response.rb
/usr/lib/ruby/vendor_ruby/grape/util/content_types.rb
/usr/lib/ruby/vendor_ruby/grape/util/env.rb
/usr/lib/ruby/vendor_ruby/grape/util/inheritable_setting.rb
/usr/lib/ruby/vendor_ruby/grape/util/inheritable_values.rb
/usr/lib/ruby/vendor_ruby/grape/util/json.rb
/usr/lib/ruby/vendor_ruby/grape/util/registrable.rb
/usr/lib/ruby/vendor_ruby/grape/util/reverse_stackable_values.rb
/usr/lib/ruby/vendor_ruby/grape/util/stackable_values.rb
/usr/lib/ruby/vendor_ruby/grape/util/strict_hash_configuration.rb
/usr/lib/ruby/vendor_ruby/grape/util/xml.rb
/usr/lib/ruby/vendor_ruby/grape/validations/attributes_iterator.rb
/usr/lib/ruby/vendor_ruby/grape/validations/params_scope.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validator_factory.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types/build_coercer.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types/custom_type_coercer.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types/custom_type_collection_coercer.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types/file.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types/json.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types/multiple_type_coercer.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types/variant_collection_coercer.rb
/usr/lib/ruby/vendor_ruby/grape/validations/types/virtus_collection_patch.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/all_or_none.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/allow_blank.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/as.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/at_least_one_of.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/base.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/coerce.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/default.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/exactly_one_of.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/except_values.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/multiple_params_base.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/mutual_exclusion.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/presence.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/regexp.rb
/usr/lib/ruby/vendor_ruby/grape/validations/validators/values.rb
/usr/share/doc/ruby-grape/README.md.gz
/usr/share/doc/ruby-grape/UPGRADING.md.gz
/usr/share/doc/ruby-grape/changelog.Debian.gz
/usr/share/doc/ruby-grape/changelog.gz
/usr/share/doc/ruby-grape/copyright
/usr/share/rubygems-integration/all/specifications/grape-1.0.3.gemspec

Changelog

2018-06-02 - Lucas Kanashiro <kanashiro@debian.org>
ruby-grape (1.0.3-1) unstable; urgency=medium
* New upstream version 1.0.3
* Update years of upstream copyright
* Declare compliance with Debian Policy 4.1.4
* debian/control: update VCS links to point to salsa
2018-03-19 - Pirate Praveen <praveen@debian.org>
ruby-grape (1.0.2-1) unstable; urgency=medium
[ Hleb Valoshka ]
* Remove myself from uploaders
[ Pirate Praveen ]
* New upstream version 1.0.2
* Update dependencies
2018-02-25 - Balasankar C <balasankarc@debian.org>
ruby-grape (0.19.2-3) unstable; urgency=medium
[ Balasankar C ]
* Team upload.
* Added patches to fix two failing tests and disable others.
* Change insecure URLs to HTTPS
[ Pirate Praveen ]
* Reupload to unstable
* Add myself to uploaders
* Bump debhelper compat to 11 and standards version to 4.1.3
[ Antonio Terceiro ]
* Remove myself from Uploaders
2017-08-24 - Pirate Praveen <praveen@debian.org>
ruby-grape (0.19.2-2) experimental; urgency=medium
* Tighten dependencie on ruby-hashie
2017-07-03 - Pirate Praveen <praveen@debian.org>
ruby-grape (0.19.2-1) experimental; urgency=medium
* New upstream release
* Refresh patches
* Update build dependencies (for new tests)
* Disable some tests (that need dependency not in debian)
* Bump standards version to 4.0.0
2016-07-19 - Pirate Praveen <praveen@debian.org>
ruby-grape (0.16.2-2) unstable; urgency=medium
* Team upload
* Tighten dependency on ruby-rack-accept (for gitlab)
2016-07-07 - Lucas Kanashiro <kanashiro@debian.org>
ruby-grape (0.16.2-1) unstable; urgency=medium
* Imported Upstream version 0.16.2
* Declare compliance with Debian policy 3.9.8
* debian/control: update dependencies
* debian/control: add me as uploader
* debian/contro: add ruby-mustermann19 as a new dependency
2016-03-08 - Lucas Albuquerque Medeiros de Moura <lucas.moura128@gmail.com>
ruby-grape (0.14.0-1) unstable; urgency=medium
* Team upload.
* New upstream release
* Update patch 0002 for new upstream release 
2015-11-26 - Pirate Praveen <praveen@debian.org>
ruby-grape (0.13.0-1) unstable; urgency=medium
* Team upload.
* New upstream release.
2015-07-07 - Hleb Valoshka <375gnu@gmail.com>
ruby-grape (0.12.0-1) unstable; urgency=medium
* Initial release.

See Also

Package Description
ruby-graphql_1.8.4-1_all.deb GraphQL language and runtime for Ruby
ruby-graphviz_1.2.3-1_all.deb Ruby interface to the GraphViz graphing tool
ruby-grib_0.4.0-2+b2_amd64.deb Ruby interface to the ECMWF GRIB API
ruby-grit-ext_0.8.1-2_all.deb utf-8 support extension for grit
ruby-grit_2.8.2-2_all.deb Ruby Git bindings
ruby-grpc-tools_1.16.0-1_all.deb Development tools for Ruby gRPC
ruby-grpc_1.16.0-1_amd64.deb GRPC system in Ruby
ruby-gruff_0.6.0-1_all.deb Ruby library to create beautiful graphs for one or multiple datasets
ruby-gsl_2.1.0.3+dfsg1-1+b1_amd64.deb Ruby bindings for the GNU Scientific Library (GSL)
ruby-gssapi_1.2.0-1_all.deb FFI wrapper around the system GSSAPI library
ruby-gstreamer_3.3.0-1_amd64.deb GStreamer bindings for the Ruby language
ruby-gtk2_3.3.0-1_amd64.deb GTK+ 2 bindings for the Ruby language
ruby-gtk3_3.3.0-1_amd64.deb GTK+ 3 bindings for the Ruby language
ruby-gtksourceview4_3.3.0-1_all.deb GtkSourceView4 bindings for the Ruby language
ruby-guard-compat_1.2.1-2_all.deb Test helper for testing custom Guard plugins
Advertisement
Advertisement