ruby-gpgme_2.0.16-1+b1_amd64.deb


Advertisement

Description

ruby-gpgme - Ruby GPGME binding

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-gpgme
Package version 2.0.16
Package release 1+b1
Package architecture amd64
Package type deb
Installed size 174 B
Download size 36.43 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-gpgme_2.0.16-1+b1_i386.deb 2.0.16 i386 Debian Main
ruby-gpgme - - -

Requires

Name Value
libassuan0 >= 2.0.1
libc6 >= 2.14
libgmp10 -
libgpg-error0 >= 1.14
libgpgme11 >= 1.6.0
libruby2.5 >= 2.5.0~preview1
ruby >= 1:2.5~0
ruby << 1:2.6~

Download

Type URL
Binary Package ruby-gpgme_2.0.16-1+b1_amd64.deb
Source Package ruby-gpgme

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-gpgme deb package:
    # sudo apt-get install ruby-gpgme

Files

Path
/usr/lib/ruby/vendor_ruby/gpgme.rb
/usr/lib/ruby/vendor_ruby/gpgme/compat.rb
/usr/lib/ruby/vendor_ruby/gpgme/constants.rb
/usr/lib/ruby/vendor_ruby/gpgme/crypto.rb
/usr/lib/ruby/vendor_ruby/gpgme/ctx.rb
/usr/lib/ruby/vendor_ruby/gpgme/data.rb
/usr/lib/ruby/vendor_ruby/gpgme/engine.rb
/usr/lib/ruby/vendor_ruby/gpgme/error.rb
/usr/lib/ruby/vendor_ruby/gpgme/io_callbacks.rb
/usr/lib/ruby/vendor_ruby/gpgme/key.rb
/usr/lib/ruby/vendor_ruby/gpgme/key_common.rb
/usr/lib/ruby/vendor_ruby/gpgme/key_sig.rb
/usr/lib/ruby/vendor_ruby/gpgme/misc.rb
/usr/lib/ruby/vendor_ruby/gpgme/signature.rb
/usr/lib/ruby/vendor_ruby/gpgme/sub_key.rb
/usr/lib/ruby/vendor_ruby/gpgme/user_id.rb
/usr/lib/ruby/vendor_ruby/gpgme/version.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/gpgme_n.so
/usr/share/doc/ruby-gpgme/changelog.Debian.amd64.gz
/usr/share/doc/ruby-gpgme/changelog.Debian.gz
/usr/share/doc/ruby-gpgme/copyright
/usr/share/doc/ruby-gpgme/examples/edit.rb
/usr/share/doc/ruby-gpgme/examples/genkey.rb
/usr/share/doc/ruby-gpgme/examples/keylist.rb
/usr/share/doc/ruby-gpgme/examples/roundtrip.rb
/usr/share/doc/ruby-gpgme/examples/sign.rb
/usr/share/doc/ruby-gpgme/examples/verify.rb
/usr/share/rubygems-integration/2.5.0/specifications/gpgme-2.0.16.gemspec

Changelog

2018-02-07 - Georg Faerber <georg@riseup.net>
ruby-gpgme (2.0.16-1) unstable; urgency=medium
* New upstream release.
* debian/changelog: Remove trailing whitespace.
* debian/control:
- Bump Standards-Version to 4.1.3, no changes needed.
- Use salsa.debian.org in Vcs-Browser and Vcs-Git fields, as
anonscm.debian.org is deprecated and accordingly, all repositories were
moved.
- Use debian-ruby@lists.debian.org for Maintainer field.
* debian/copyright: Bump years to include 2018.
* debian/patches: Refresh for release 2.0.16-1.
2017-11-07 - Georg Faerber <georg@riseup.net>
ruby-gpgme (2.0.14-1) unstable; urgency=medium
* New upstream release.
* debian/control: Depend on libgpgme-dev, instead of the obsolete
libgpgme11-dev.
* debian/copyright:
- Bump years and add missing Debian packaging authors.
- Use https in links.
2017-10-23 - Georg Faerber <georg@riseup.net>
ruby-gpgme (2.0.13-1) unstable; urgency=medium
* New upstream release.
* debian/compat: Bump debhelper compat to 10.
* debian/control:
- Bump Standards-Version to 4.1.1, no changes needed.
- Bump required debhelper version.
- Add myself as uploader.
- Use https in homepage link.
* debian/patches: Refresh for release 2.0.13-1.
* debian/watch: Use https in gemwatch link.
2016-03-05 - Christian Hofstaedtler <zeha@debian.org>
ruby-gpgme (2.0.12-1) unstable; urgency=medium
* Team upload.
[ Cédric Boutillier ]
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Christian Hofstaedtler ]
* New upstream version.
* Update packaging using dh-make-ruby -w
2015-08-18 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
ruby-gpgme (2.0.9-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 2.0.9
* Bump debhelper compatibility level to 9
* Declare compliance with Debian policy 3.9.6
2014-04-29 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
ruby-gpgme (2.0.5-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Increased Standards-Version to 3.9.5 (no changes).
* Removed obsolete patch for dynamic build (with gpgme-config) and use
--use-system-libraries option instead.
2013-08-12 - Marc Dequènes (Duck) <Duck@DuckCorp.org>
ruby-gpgme (2.0.2-1) unstable; urgency=low
* Team upload.
[ Gunnar Wolf ]
* Removed the build of transitional packages and obsolete
relations required for Wheezy.
[ Marc Dequènes (Duck) ]
* New upstream release.
* Patched buildsys to link with gpgme dynamically (and not with
embedded libraries).
* Increased Standards-Version to 3.9.4 (no changes).
* Added dpkg-source local option to unapply patches.
2012-06-25 - Per Andersson <avtobiff@gmail.com>
ruby-gpgme (2.0.0-2) unstable; urgency=low
* Added myself as uploader.
* Build depend on gem2deb >= 0.3.0.
* Bump standards version to 3.9.3 (no changes needed).
* Use copyright format 1.0 uri.
* Changed short description.
- Remove lintian warning.
[ Vincent Fourmond ]
* Moved transitional packages to Priority: extra
2011-10-07 - Gunnar Wolf <gwolf@debian.org>
ruby-gpgme (2.0.0-1) unstable; urgency=low
* Repackaged using the Gem2deb infrastructure
2010-03-04 - Gunnar Wolf <gwolf@debian.org>
libgpgme-ruby (1.0.8-3) unstable; urgency=low
* Adopted package (Closes: #572175)
* Dropped depensimple-patchsys from build process (no patches to
apply)
* Standards-version 3.8.1→3.8.4 (no changes needed)

See Also

Package Description
ruby-grack_2.0.2-2_all.deb Git Smart HTTP Server Rack implementation in Ruby/Rack
ruby-graffiti_2.3.1-1_all.deb Relational RDF store for Ruby
ruby-grape-entity_0.7.1-1_all.deb Entity support to API frameworks, such as Grape
ruby-grape-logging_1.7.0-1_all.deb request logging support for Grape
ruby-grape-msgpack_0.2.0-1_all.deb MessagePack formatter for Grape framework
ruby-grape-route-helpers_2.1.0-3_all.deb Route helpers for Grape
ruby-grape_1.0.3-1_all.deb Simple Ruby framework for building REST-like APIs
ruby-graphql_1.8.4-1_all.deb GraphQL language and runtime for Ruby
ruby-graphviz_1.2.3-1_all.deb Ruby interface to the GraphViz graphing tool
ruby-grib_0.4.0-2+b2_amd64.deb Ruby interface to the ECMWF GRIB API
ruby-grit-ext_0.8.1-2_all.deb utf-8 support extension for grit
ruby-grit_2.8.2-2_all.deb Ruby Git bindings
ruby-grpc-tools_1.16.0-1_all.deb Development tools for Ruby gRPC
ruby-grpc_1.16.0-1_amd64.deb GRPC system in Ruby
ruby-gruff_0.6.0-1_all.deb Ruby library to create beautiful graphs for one or multiple datasets
Advertisement
Advertisement