ruby-gli_2.14.0-1_all.deb


Advertisement

Description

ruby-gli - Build command-suite CLI apps without a lot of syntax

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-gli
Package version 2.14.0
Package release 1
Package architecture all
Package type deb
Installed size 175 B
Download size 34.40 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-gli_2.14.0-1_all.deb 2.14.0 all Debian Main
ruby-gli - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-gli_2.14.0-1_all.deb
Source Package ruby-gli

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-gli deb package:
    # sudo apt-get install ruby-gli

Files

Path
/usr/bin/gli
/usr/lib/ruby/vendor_ruby/gli.rb
/usr/lib/ruby/vendor_ruby/gli/app.rb
/usr/lib/ruby/vendor_ruby/gli/app_support.rb
/usr/lib/ruby/vendor_ruby/gli/argument.rb
/usr/lib/ruby/vendor_ruby/gli/command.rb
/usr/lib/ruby/vendor_ruby/gli/command_finder.rb
/usr/lib/ruby/vendor_ruby/gli/command_line_option.rb
/usr/lib/ruby/vendor_ruby/gli/command_line_token.rb
/usr/lib/ruby/vendor_ruby/gli/command_support.rb
/usr/lib/ruby/vendor_ruby/gli/dsl.rb
/usr/lib/ruby/vendor_ruby/gli/exceptions.rb
/usr/lib/ruby/vendor_ruby/gli/flag.rb
/usr/lib/ruby/vendor_ruby/gli/gli_option_block_parser.rb
/usr/lib/ruby/vendor_ruby/gli/gli_option_parser.rb
/usr/lib/ruby/vendor_ruby/gli/option_parser_factory.rb
/usr/lib/ruby/vendor_ruby/gli/option_parsing_result.rb
/usr/lib/ruby/vendor_ruby/gli/options.rb
/usr/lib/ruby/vendor_ruby/gli/switch.rb
/usr/lib/ruby/vendor_ruby/gli/terminal.rb
/usr/lib/ruby/vendor_ruby/gli/version.rb
/usr/lib/ruby/vendor_ruby/gli/commands/compound_command.rb
/usr/lib/ruby/vendor_ruby/gli/commands/doc.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help.rb
/usr/lib/ruby/vendor_ruby/gli/commands/initconfig.rb
/usr/lib/ruby/vendor_ruby/gli/commands/rdoc_document_listener.rb
/usr/lib/ruby/vendor_ruby/gli/commands/scaffold.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/arg_name_formatter.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/command_finder.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/command_help_format.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/compact_synopsis_formatter.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/full_synopsis_formatter.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/global_help_format.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/help_completion_format.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/list_formatter.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/one_line_wrapper.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/options_formatter.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/terminal_synopsis_formatter.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/text_wrapper.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/tty_only_wrapper.rb
/usr/lib/ruby/vendor_ruby/gli/commands/help_modules/verbatim_wrapper.rb
/usr/share/doc/ruby-gli/README.rdoc
/usr/share/doc/ruby-gli/changelog.Debian.gz
/usr/share/doc/ruby-gli/copyright
/usr/share/rubygems-integration/all/specifications/gli-2.14.0.gemspec

Changelog

2016-11-29 - Micah Anderson <micah@debian.org>
ruby-gli (2.14.0-1) unstable; urgency=medium
* Initial release (Closes: #846250)

See Also

Package Description
ruby-glib2_3.3.0-1_amd64.deb GLib 2 bindings for the Ruby language
ruby-globalid_0.3.6-1_all.deb reference models by URI for Ruby on Rails
ruby-gnome2-dev_3.3.0-1_amd64.deb GNOME-related bindings for the Ruby language (development files)
ruby-gnome2_3.3.0-1_all.deb GNOME-related bindings for the Ruby language
ruby-gnuplot_2.6.2-2_all.deb Ruby library to interact with gnuplot
ruby-gobject-introspection_3.3.0-1_amd64.deb GObject Introspection bindings for the Ruby language
ruby-god_0.13.7-3_amd64.deb Fully configurable process monitoring
ruby-gollum-lib_4.2.7.5-3_all.deb simple, Git-powered wiki
ruby-gollum-rugged-adapter_0.4.4.1-2_all.deb Adapter for Gollum to use Rugged (libgit2) at the backend
ruby-gon_6.2.1-1_all.deb Ruby library to send data to JavaScript from a Ruby application
ruby-google-api-client_0.19.8-1_all.deb Client for accessing Google APIs
ruby-google-protobuf_3.6.1-4_amd64.deb Protocol Buffers
ruby-googleapis-common-protos-types_1.0.1-1_all.deb Common protobuf types used in Google APIs
ruby-googleauth_0.5.1-2_all.deb Google Auth Library for Ruby
ruby-gpgme_2.0.16-1+b1_amd64.deb Ruby GPGME binding
Advertisement
Advertisement