ruby-gd_0.8.0-7+b10_amd64.deb


Advertisement

Description

ruby-gd - Extension library to use GD graphics library from Ruby

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-gd
Package version 0.8.0
Package release 7+b10
Package architecture amd64
Package type deb
Installed size 163 B
Download size 47.34 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-gd_0.8.0-7+b10_i386.deb 0.8.0 i386 Debian Main
ruby-gd - - -

Requires

Name Value
libc6 >= 2.4
libfreetype6 >= 2.2.1
libgd3 >= 2.1.0~alpha~
libgmp10 -
libjpeg62-turbo >= 1.3.1
libpng16-16 >= 1.6.2-1
libruby2.5 >= 2.5.0~preview1
libx11-6 -
libxpm4 -
ruby >= 1:2.5~0
ruby << 1:2.6~
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package ruby-gd_0.8.0-7+b10_amd64.deb
Source Package ruby-gd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-gd deb package:
    # sudo apt-get install ruby-gd

Files

Path
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/GD.so
/usr/share/doc-base/ruby-gd
/usr/share/doc/ruby-gd/changelog.Debian.amd64.gz
/usr/share/doc/ruby-gd/changelog.Debian.gz
/usr/share/doc/ruby-gd/changelog.gz
/usr/share/doc/ruby-gd/copyright
/usr/share/doc/ruby-gd/manual.html
/usr/share/doc/ruby-gd/manual.rd.gz
/usr/share/doc/ruby-gd/readme.en
/usr/share/doc/ruby-gd/readme.ja
/usr/share/doc/ruby-gd/examples/example.rb
/usr/share/doc/ruby-gd/examples/gdtestttf.png
/usr/share/doc/ruby-gd/examples/gdtestttf.rb
/usr/share/doc/ruby-gd/examples/webpng.rb
/usr/share/rubygems-integration/2.5.0/specifications/ruby-gd-0.8.0.gemspec

Changelog

2014-04-15 - Antonio Terceiro <terceiro@debian.org>
ruby-gd (0.8.0-7) unstable; urgency=medium
[ Antonio Terceiro ]
* Team upload.
* Port to Ruby 2.1 (Closes: #743982)
* Add very basic test suite in debian/ruby-tests.rb
[ Christian Hofstaedtler ]
* Drop transitional packages
2013-12-27 - Christian Hofstaedtler <zeha@debian.org>
ruby-gd (0.8.0-6) unstable; urgency=medium
* Team upload.
* Drop debian/patches/options-extconf.patch and replace it with a less
instrusive way of enabling the addtl. features.
2013-12-27 - Cédric Boutillier <boutil@debian.org>
ruby-gd (0.8.0-5) unstable; urgency=medium
* Team upload.
* Add debian/patches/options-extconf.patch, to force --with-xpm,
--with-freetype, --with-jpeg and --enable-gd2_0 options in extconf.rb.
(Closes: #733157)
* update restore-ruby18-support.patch to add ruby 1.9+ support for
additional extconf options.
2013-12-18 - Cédric Boutillier <boutil@debian.org>
ruby-gd (0.8.0-4) unstable; urgency=medium
* Team upload
* debian/control:
+ bump Standards-Version to 3.9.5 (no changes needed)
+ build with gem2deb >= 0.5 to add Ruby2.0 support and drop Ruby1.8
+ build against libgd-dev instead of obsolete libgd2-xpm-dev
+ remove obsolete DM-Upload-Allowed flag
+ use canonical URI in Vcs-* fields
* Import patches from https://github.com/Spakman/ruby-gd/
to fix build with Ruby1.9+ (Closes: #730907)
* Add doc-base registration
2012-06-26 - Paul van Tilburg <paulvt@debian.org>
ruby-gd (0.8.0-3) unstable; urgency=low
* Bumped the build-dependency on gem2deb to >= 0.3.0~.
* debian/source/lintian-overrides: added overrides for the descriptions
of the transitional packages. 
2012-04-23 - Paul van Tilburg <paulvt@debian.org>
ruby-gd (0.8.0-2) unstable; urgency=low
* Really added libgd-ruby and libgd-ruby1.8 as transitional packages.
2012-04-23 - Paul van Tilburg <paulvt@debian.org>
ruby-gd (0.8.0-1) unstable; urgency=low
* New upstream release.
* Source packages adapted according to the new Ruby policy:
- Build for both ruby1.8 and ruby1.9.1.
- Migrated to pkg-ruby-extras git repos. Changed the Vcs-* fields in
debian/control accordingly.
- Changed the depends and recommends to follow the new Ruby library
naming scheme.
* debian/control:
- Added a default DM-Upload-Allowed field set to yes.
- Standards-Version bumped to 3.9.3.
- Set XS-Ruby-Versions to ruby1.8.
- Changed the build-depends for using gem2deb instead of ruby-pkg-tools.
- Changed the build-depend on libpng12-dev to libpng-dev (closes: #662400).
- Removed the build-depends on ruby1.8 and ruby1.8-dev as it is handled
via gem2deb now.
- Switched the maintainer with the uploaders field as per new
convention the team is the default maintainer.
- Added libgd-ruby and libgd-ruby1.8 as transitional packages.
* debian/copyright: reworked to fit the copyright format 1.0.
* debian/patches: refreshed patches for use by quilt.
* debian/ruby-gd.{docs,examples}: renamed from libgd-ruby.{docs,examples}.
* debian/source/options: set the "unapply-patches" option.
2011-09-11 - gregor herrmann <gregoa@debian.org>
libgd-ruby (0.7.4.1-6.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "FTBFS: Please Build-Depends on libjpeg-dev, not libjpeg62-dev":
do as the bug report says (closes: #635489).
2008-08-30 - Paul van Tilburg <paulvt@debian.org>
libgd-ruby (0.7.4.1-6) unstable; urgency=low
[ Paul van Tilburg ]
* Added watch file (use RAA cache, since upstream website is gone!).
* Moved the team to the Uploaders field, set myself as maintainer
in debian/control (closes: #472438).
* Removed superfluous debian/dirs and Debian-specific changes
to extconf.rb. 
* Bumped the standards version to 3.8.0; no changes required.
[ Antonio Terceiro ]
* Added debian/patches/fix-set-interlace-on-amd64.patch to fix segmentation
faults on amd64 when using the interlace option (Closes: #497191).
* Added myself to Uploaders in debian/control.

See Also

Package Description
ruby-gdk-pixbuf2_3.3.0-1_all.deb Gdk-Pixbuf 2 bindings for the Ruby language
ruby-gdk3_3.3.0-1_all.deb GDK 3 bindings for the Ruby language
ruby-gelf_1.4.0-4_all.deb Ruby GELF library - Graylog2 Extended Log Format library for Ruby
ruby-gemnasium-gitlab-service_0.2.6-2_all.deb Gemnasium service for Gitlab
ruby-gemojione_3.3.0-1_all.deb gem to provide EmojiOne
ruby-generator-spec_0.9.3-1_all.deb Test Rails generators with RSpec
ruby-geos_3.7.0-1_amd64.deb GEOS bindings for Ruby
ruby-get-process-mem_0.2.0-2_all.deb get memory usage of a process in Ruby
ruby-gettext-i18n-rails-js_1.3.0+dfsg-2_all.deb make your .po files available to client side javascript as JSON
ruby-gettext-i18n-rails_1.8.0-1_all.deb Simple FastGettext Rails integration
ruby-gettext-setup_0.30-2_all.deb fast_gettext helper for Ruby
ruby-gettext_3.2.9-1_all.deb gettext for Ruby
ruby-gherkin_4.0.0-2_all.deb lexer and parser for the Gherkin language in Ruby
ruby-gio2_3.3.0-1_amd64.deb GIO bindings for the Ruby language
ruby-gir-ffi_0.14.1-1_all.deb FFI-based GObject binding using the GObject Introspection Repository
Advertisement
Advertisement