ruby-fog-core_1.45.0-2_all.deb


Advertisement

Description

ruby-fog-core - shared classes and tests for fog providers and services

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-fog-core
Package version 1.45.0
Package release 2
Package architecture all
Package type deb
Installed size 197 B
Download size 35.36 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-fog-core_1.45.0-2_all.deb 1.45.0 all Debian Main
ruby-fog-core - - -

Requires

Name Value
ruby -
ruby-builder -
ruby-excon >= 0.58~
ruby-formatador -
ruby-interpreter -
ruby-mime-types -
ruby-net-scp -
ruby-net-ssh -

Replaces

Name Value
ruby-fog << 1.22.0-2~

Download

Type URL
Binary Package ruby-fog-core_1.45.0-2_all.deb
Source Package ruby-fog-core

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-fog-core deb package:
    # sudo apt-get install ruby-fog-core

Files

Path
/usr/lib/ruby/vendor_ruby/fog/account.rb
/usr/lib/ruby/vendor_ruby/fog/baremetal.rb
/usr/lib/ruby/vendor_ruby/fog/billing.rb
/usr/lib/ruby/vendor_ruby/fog/cdn.rb
/usr/lib/ruby/vendor_ruby/fog/compute.rb
/usr/lib/ruby/vendor_ruby/fog/core.rb
/usr/lib/ruby/vendor_ruby/fog/dns.rb
/usr/lib/ruby/vendor_ruby/fog/formatador.rb
/usr/lib/ruby/vendor_ruby/fog/identity.rb
/usr/lib/ruby/vendor_ruby/fog/image.rb
/usr/lib/ruby/vendor_ruby/fog/introspection.rb
/usr/lib/ruby/vendor_ruby/fog/metering.rb
/usr/lib/ruby/vendor_ruby/fog/monitoring.rb
/usr/lib/ruby/vendor_ruby/fog/network.rb
/usr/lib/ruby/vendor_ruby/fog/nfv.rb
/usr/lib/ruby/vendor_ruby/fog/orchestration.rb
/usr/lib/ruby/vendor_ruby/fog/storage.rb
/usr/lib/ruby/vendor_ruby/fog/support.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers.rb
/usr/lib/ruby/vendor_ruby/fog/volume.rb
/usr/lib/ruby/vendor_ruby/fog/vpn.rb
/usr/lib/ruby/vendor_ruby/fog/compute/models/server.rb
/usr/lib/ruby/vendor_ruby/fog/core/association.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes.rb
/usr/lib/ruby/vendor_ruby/fog/core/cache.rb
/usr/lib/ruby/vendor_ruby/fog/core/collection.rb
/usr/lib/ruby/vendor_ruby/fog/core/connection.rb
/usr/lib/ruby/vendor_ruby/fog/core/credentials.rb
/usr/lib/ruby/vendor_ruby/fog/core/current_machine.rb
/usr/lib/ruby/vendor_ruby/fog/core/deprecated_connection_accessors.rb
/usr/lib/ruby/vendor_ruby/fog/core/deprecation.rb
/usr/lib/ruby/vendor_ruby/fog/core/errors.rb
/usr/lib/ruby/vendor_ruby/fog/core/hmac.rb
/usr/lib/ruby/vendor_ruby/fog/core/logger.rb
/usr/lib/ruby/vendor_ruby/fog/core/mock.rb
/usr/lib/ruby/vendor_ruby/fog/core/model.rb
/usr/lib/ruby/vendor_ruby/fog/core/provider.rb
/usr/lib/ruby/vendor_ruby/fog/core/scp.rb
/usr/lib/ruby/vendor_ruby/fog/core/service.rb
/usr/lib/ruby/vendor_ruby/fog/core/services_mixin.rb
/usr/lib/ruby/vendor_ruby/fog/core/ssh.rb
/usr/lib/ruby/vendor_ruby/fog/core/stringify_keys.rb
/usr/lib/ruby/vendor_ruby/fog/core/time.rb
/usr/lib/ruby/vendor_ruby/fog/core/utils.rb
/usr/lib/ruby/vendor_ruby/fog/core/uuid.rb
/usr/lib/ruby/vendor_ruby/fog/core/version.rb
/usr/lib/ruby/vendor_ruby/fog/core/wait_for.rb
/usr/lib/ruby/vendor_ruby/fog/core/wait_for_defaults.rb
/usr/lib/ruby/vendor_ruby/fog/core/whitelist_keys.rb
/usr/lib/ruby/vendor_ruby/fog/core/associations/default.rb
/usr/lib/ruby/vendor_ruby/fog/core/associations/many_identities.rb
/usr/lib/ruby/vendor_ruby/fog/core/associations/many_models.rb
/usr/lib/ruby/vendor_ruby/fog/core/associations/one_identity.rb
/usr/lib/ruby/vendor_ruby/fog/core/associations/one_model.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes/array.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes/boolean.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes/default.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes/float.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes/integer.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes/string.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes/time.rb
/usr/lib/ruby/vendor_ruby/fog/core/attributes/timestamp.rb
/usr/lib/ruby/vendor_ruby/fog/schema/data_validator.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/collection_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/formats_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/mock_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/model_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/responds_to_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/succeeds_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/types_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/compute/flavors_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/compute/server_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/compute/servers_helper.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/minitest/assertions.rb
/usr/lib/ruby/vendor_ruby/fog/test_helpers/minitest/expectations.rb
/usr/lib/ruby/vendor_ruby/tasks/test_task.rb
/usr/share/doc/ruby-fog-core/README.md
/usr/share/doc/ruby-fog-core/changelog.Debian.gz
/usr/share/doc/ruby-fog-core/changelog.gz
/usr/share/doc/ruby-fog-core/copyright
/usr/share/rubygems-integration/all/specifications/fog-core-1.45.0.gemspec

Changelog

2018-04-28 - Pirate Praveen <praveen@debian.org>
ruby-fog-core (1.45.0-2) unstable; urgency=medium
* Tighten dependency on ruby-excon
* Use salsa.debian.org in Vcs-* fields
* Bump Standards-Version to 4.1.4 (no changes needed)
* Update gemwatch url
* Enable tests (set HOME=/tmp for tests)
2018-02-23 - Pirate Praveen <praveen@debian.org>
ruby-fog-core (1.45.0-1) unstable; urgency=medium
* New upstream version 1.45.0
* Bump standards version to 4.1.3 and debhelper compat to 11
2017-08-19 - Pirate Praveen <praveen@debian.org>
ruby-fog-core (1.44.3-2) unstable; urgency=medium
* Reupload to unstable 
2017-06-03 - Sagar Ippalpalli <i.vikram15@gmail.com>
ruby-fog-core (1.44.3-1) experimental; urgency=medium
* Team upload
* New upstream release
2016-08-18 - Sruthi Chandran <srud@openmailbox.org>
ruby-fog-core (1.42.0-1) unstable; urgency=medium
* Team upload
* New upstream release
2016-06-17 - Pirate Praveen <praveen@debian.org>
ruby-fog-core (1.40.0-2) unstable; urgency=medium
* Update minimum version of ruby-excon dependecy 
2016-06-11 - Pirate Praveen <praveen@debian.org>
ruby-fog-core (1.40.0-1) unstable; urgency=medium
* New upstream release 
2015-09-15 - Pirate Praveen <praveen@debian.org>
ruby-fog-core (1.32.1-1) unstable; urgency=medium
* New upstream release
* Check gemspec dependencies during build
* Add ruby-net-scp, ruby-net-ssh to build deps as well.
2015-05-02 - Pirate Praveen <praveen@debian.org>
ruby-fog-core (1.30.0-2) unstable; urgency=medium
* Re-upload to unstable. 
2015-04-10 - Pirate Praveen <praveen@debian.org>
ruby-fog-core (1.30.0-1) experimental; urgency=medium
* New upstream release.
* Remove patch: add-fog-core-require.patch (tests are removed upstream)

See Also

Package Description
ruby-fog-dynect_0.0.2-1_all.deb Module for the 'fog' gem to support Dynect DNS
ruby-fog-ecloud_0.1.1-1_all.deb Module for the 'fog' gem to support Terremark EnterpriseCloud
ruby-fog-google_1.3.3-2_all.deb module for the 'fog' library to support Google cloud services
ruby-fog-json_1.0.0-1_all.deb JSON parsing for fog providers
ruby-fog-libvirt_0.5.0-1_all.deb Module for the 'fog' gem to support libvirt
ruby-fog-local_0.3.0-1_all.deb Module for the 'fog' gem to support local filesystem storage
ruby-fog-openstack_0.1.6-4_all.deb module for 'fog' libraryto support OpenStack instances
ruby-fog-powerdns_0.1.1+debian-1_all.deb module for the 'fog' library to support PowerDNS DNS services
ruby-fog-profitbricks_0.0.1-2_all.deb library to use ProfitBricks cloud in applications
ruby-fog-rackspace_0.1.1-4_all.deb Rackspace support for Fog
ruby-fog-radosgw_0.0.4-2_all.deb fog backend for provisioning Ceph Radosgw
ruby-fog-riakcs_0.1.0-2_all.deb Module for the 'fog' gem to support Riakcs
ruby-fog-sakuracloud_1.7.5-1_all.deb Module for the 'fog' gem to support Sakura no Cloud
ruby-fog-serverlove_0.1.1-2_all.deb Module for the 'fog' gem to support ServerLove
ruby-fog-softlayer_0.3.17-1_all.deb fog module to use the SoftLayer Cloud in applications
Advertisement
Advertisement