ruby-flexmock_2.0.4-1_all.deb


Advertisement

Description

ruby-flexmock - simple and flexible mock objects for testing

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-flexmock
Package version 2.0.4
Package release 1
Package architecture all
Package type deb
Installed size 155 B
Download size 41.21 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-flexmock_2.0.4-1_all.deb 2.0.4 all Debian Main
ruby-flexmock - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-flexmock_2.0.4-1_all.deb
Source Package ruby-flexmock

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-flexmock deb package:
    # sudo apt-get install ruby-flexmock

Files

Path
/usr/lib/ruby/vendor_ruby/flexmock.rb
/usr/lib/ruby/vendor_ruby/flexmock/argument_matchers.rb
/usr/lib/ruby/vendor_ruby/flexmock/argument_matching.rb
/usr/lib/ruby/vendor_ruby/flexmock/argument_types.rb
/usr/lib/ruby/vendor_ruby/flexmock/base.rb
/usr/lib/ruby/vendor_ruby/flexmock/call_record.rb
/usr/lib/ruby/vendor_ruby/flexmock/call_validator.rb
/usr/lib/ruby/vendor_ruby/flexmock/class_extensions.rb
/usr/lib/ruby/vendor_ruby/flexmock/composite_expectation.rb
/usr/lib/ruby/vendor_ruby/flexmock/core.rb
/usr/lib/ruby/vendor_ruby/flexmock/core_class_methods.rb
/usr/lib/ruby/vendor_ruby/flexmock/default_framework_adapter.rb
/usr/lib/ruby/vendor_ruby/flexmock/deprecated_methods.rb
/usr/lib/ruby/vendor_ruby/flexmock/errors.rb
/usr/lib/ruby/vendor_ruby/flexmock/expectation.rb
/usr/lib/ruby/vendor_ruby/flexmock/expectation_builder.rb
/usr/lib/ruby/vendor_ruby/flexmock/expectation_director.rb
/usr/lib/ruby/vendor_ruby/flexmock/expectation_recorder.rb
/usr/lib/ruby/vendor_ruby/flexmock/explicit_needed.rb
/usr/lib/ruby/vendor_ruby/flexmock/minitest.rb
/usr/lib/ruby/vendor_ruby/flexmock/minitest_extensions.rb
/usr/lib/ruby/vendor_ruby/flexmock/minitest_integration.rb
/usr/lib/ruby/vendor_ruby/flexmock/mock_builder.rb
/usr/lib/ruby/vendor_ruby/flexmock/mock_container.rb
/usr/lib/ruby/vendor_ruby/flexmock/noop.rb
/usr/lib/ruby/vendor_ruby/flexmock/object_extensions.rb
/usr/lib/ruby/vendor_ruby/flexmock/ordering.rb
/usr/lib/ruby/vendor_ruby/flexmock/partial_mock.rb
/usr/lib/ruby/vendor_ruby/flexmock/rails.rb
/usr/lib/ruby/vendor_ruby/flexmock/recorder.rb
/usr/lib/ruby/vendor_ruby/flexmock/rspec.rb
/usr/lib/ruby/vendor_ruby/flexmock/rspec_spy_matcher.rb
/usr/lib/ruby/vendor_ruby/flexmock/spy_describers.rb
/usr/lib/ruby/vendor_ruby/flexmock/symbol_extensions.rb
/usr/lib/ruby/vendor_ruby/flexmock/test_unit.rb
/usr/lib/ruby/vendor_ruby/flexmock/test_unit_assert_spy_called.rb
/usr/lib/ruby/vendor_ruby/flexmock/test_unit_integration.rb
/usr/lib/ruby/vendor_ruby/flexmock/test_unit_testcase_extensions.rb
/usr/lib/ruby/vendor_ruby/flexmock/undefined.rb
/usr/lib/ruby/vendor_ruby/flexmock/validators.rb
/usr/lib/ruby/vendor_ruby/flexmock/version.rb
/usr/lib/ruby/vendor_ruby/flexmock/extensions/active_record_model.rb
/usr/lib/ruby/vendor_ruby/flexmock/rspec/configure.rb
/usr/share/doc/ruby-flexmock/README.md.gz
/usr/share/doc/ruby-flexmock/changelog.Debian.gz
/usr/share/doc/ruby-flexmock/changelog.gz
/usr/share/doc/ruby-flexmock/copyright
/usr/share/rubygems-integration/all/specifications/flexmock-2.0.4.gemspec

Changelog

2016-03-02 - Sebastien Badia <seb@sebian.fr>
ruby-flexmock (2.0.4-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 2.0.4
* d/control:
Update Vcs-* fields (use https everywhere)
Bump Standards-Version to 3.9.7 (no changes)
* d/copyright: Fix upstream URL
2015-09-15 - Antonio Terceiro <terceiro@debian.org>
ruby-flexmock (2.0.0~rc1-1) unstable; urgency=medium
[ C├ędric Boutillier ]
* debian/control: remove obsolete DM-Upload-Allowed flag
* use canonical URI in Vcs-* fields
* debian/copyright: use DEP5 copyright-format/1.0 official URL for Format
field
[ Jonas Genannt ]
* d/control: removed transitional packages
* d/control: bumped standards version to 3.9.5 (no changes needed)
* added ruby-rspec, ruby-minitest, needed for tests on build time
[ Roberto C. Sanchez ]
* Remove /me from uploaders
[ Jonas Genannt ]
* refresh debian/ with dh-make-ruby
* d/copyright: updated format and years
[ Antonio Terceiro ]
* New upstream release (Closes: #794171)
* debian/watch: point at github
* Update packaging with a new dh-make-ruby run
* added debian/patches/0001-gemspec-skip-git-usage.patch
* improve debian/copyright
* added debian/patches/0002-gemspec-don-t-assume-lib-exists.patc
2011-11-19 - Antonio Terceiro <terceiro@debian.org>
ruby-flexmock (0.9.0-1) unstable; urgency=low
* Migrate to gem2deb and to the new Ruby packaging and naming standard.
Added transitional packages.
2010-02-20 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
libflexmock-ruby (0.8.6-2) unstable; urgency=low
* Bump standards version to 3.8.4 (no changes)
* Switch to Ruby 1.9.1. Closes: #569854.
2009-08-27 - Roberto C. Sanchez <roberto@connexer.com>
libflexmock-ruby (0.8.6-1) unstable; urgency=low
* New upstream release
* Bump standards version to 3.8.3 (no changes)
* Change section to ruby (to line up with archive override file)
2009-03-17 - Roberto C. Sanchez <roberto@connexer.com>
libflexmock-ruby (0.8.5-1) unstable; urgency=low
* New upstream release
* Bump Standards-Version to 3.8.1 (no changes).
2009-03-09 - Roberto C. Sanchez <roberto@connexer.com>
libflexmock-ruby (0.8.4-1) unstable; urgency=low
* New upstream release
2008-09-23 - Roberto C. Sanchez <roberto@connexer.com>
libflexmock-ruby (0.8.3-1) unstable; urgency=low
* New upstream release
2008-06-17 - Roberto C. Sanchez <roberto@connexer.com>
libflexmock-ruby (0.8.2-2) unstable; urgency=high
* Build-Depends on ruby-pkg-tools >= 0.14 and install 1.9 module files
into /usr/lib/ruby/1.9.0/ (Closes: #484614)
* Bump Standards-Version to 3.8.0 (no changes).
2008-06-03 - Roberto C. Sanchez <roberto@connexer.com>
libflexmock-ruby (0.8.2-1) unstable; urgency=low
* New upstream release.

See Also

Package Description
ruby-flipper_0.13.0-3_all.deb Feature flipper for ANYTHING
ruby-flot-rails_0.0.7-1_all.deb jQuery Flot for Rails Asset pipeline
ruby-flowdock_0.7.1-1_all.deb Ruby library for using Flowdock's API
ruby-fog-aliyun_0.2.0-1_all.deb Fog provider for Aliyun Web Services
ruby-fog-atmos_0.1.0-3_all.deb Module for the 'fog' gem to support Atmos
ruby-fog-aws_2.0.1-1_all.deb module for the 'fog' gem to support Amazon Web Services
ruby-fog-azure_0.0.2-1_all.deb module for the 'fog' brary to support Azure cloud services
ruby-fog-brightbox_0.7.1-2_all.deb library to use the Brightbox Cloud in applications
ruby-fog-cloudatcost_0.2.3-1_all.deb module for the 'fog' library to support CloudAtCost
ruby-fog-core_1.45.0-2_all.deb shared classes and tests for fog providers and services
ruby-fog-dynect_0.0.2-1_all.deb Module for the 'fog' gem to support Dynect DNS
ruby-fog-ecloud_0.1.1-1_all.deb Module for the 'fog' gem to support Terremark EnterpriseCloud
ruby-fog-google_1.3.3-2_all.deb module for the 'fog' library to support Google cloud services
ruby-fog-json_1.0.0-1_all.deb JSON parsing for fog providers
ruby-fog-libvirt_0.5.0-1_all.deb Module for the 'fog' gem to support libvirt
Advertisement
Advertisement