ruby-execjs_2.6.0-1_all.deb


Advertisement

Description

ruby-execjs - Run JavaScript code from Ruby

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-execjs
Package version 2.6.0
Package release 1
Package architecture all
Package type deb
Installed size 68 B
Download size 14.48 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-execjs_2.6.0-1_all.deb 2.6.0 all Debian Main
ruby-execjs - - -

Requires

Name Value
nodejs -
ruby -
ruby-interpreter -
ruby-multi-json -

Download

Type URL
Binary Package ruby-execjs_2.6.0-1_all.deb
Source Package ruby-execjs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-execjs deb package:
    # sudo apt-get install ruby-execjs

Files

Path
/usr/lib/ruby/vendor_ruby/execjs.rb
/usr/lib/ruby/vendor_ruby/execjs/disabled_runtime.rb
/usr/lib/ruby/vendor_ruby/execjs/duktape_runtime.rb
/usr/lib/ruby/vendor_ruby/execjs/encoding.rb
/usr/lib/ruby/vendor_ruby/execjs/external_runtime.rb
/usr/lib/ruby/vendor_ruby/execjs/module.rb
/usr/lib/ruby/vendor_ruby/execjs/ruby_racer_runtime.rb
/usr/lib/ruby/vendor_ruby/execjs/ruby_rhino_runtime.rb
/usr/lib/ruby/vendor_ruby/execjs/runtime.rb
/usr/lib/ruby/vendor_ruby/execjs/runtimes.rb
/usr/lib/ruby/vendor_ruby/execjs/version.rb
/usr/lib/ruby/vendor_ruby/execjs/support/jsc_runner.js
/usr/lib/ruby/vendor_ruby/execjs/support/jscript_runner.js
/usr/lib/ruby/vendor_ruby/execjs/support/json2.js
/usr/lib/ruby/vendor_ruby/execjs/support/node_runner.js
/usr/lib/ruby/vendor_ruby/execjs/support/spidermonkey_runner.js
/usr/share/doc/ruby-execjs/README.md
/usr/share/doc/ruby-execjs/changelog.Debian.gz
/usr/share/doc/ruby-execjs/copyright
/usr/share/rubygems-integration/all/specifications/execjs-2.6.0.gemspec

Changelog

2015-08-14 - Antonio Terceiro <terceiro@debian.org>
ruby-execjs (2.6.0-1) unstable; urgency=medium
* New upstream release
* debian/watch: point at https://github.com/rails/execjs as new upstream,
and simplify
- change Homepage: field to reflect new upstream
-- Antonio Terceiro <terceiro@debian.org>  Tue, 22 Sep 2015 15:31:19 -0300
ruby-execjs (2.4.0-1) unstable; urgency=medium
* New upstream release
* Update packaging with a new dh-make-ruby run
* debian/patches/01_use_local_coffee_script_source: dropped, not needed
anymore.
* debian/rules: force C.UTF-8 locales, which the test suite expects
2014-07-29 - Caitlin Matos <caitlin.matos@zoho.com>
ruby-execjs (2.2.1-1) unstable; urgency=medium
* new upstream release
* now uses github version (not gem) so test suite is imported
* patched test suite to use local copy of coffeescript (instead of going
online)
* new build dependency: libjs-coffeescript
* updated standards to 3.9.5
* bumped dh and compat to 9
* added self to uploaders, copyright
2014-03-29 - Antonio Terceiro <terceiro@debian.org>
ruby-execjs (1.4.0-3) unstable; urgency=medium
* No changes rebuild to add support for new interpreters.
2012-07-13 - Antonio Terceiro <terceiro@debian.org>
ruby-execjs (1.4.0-2) unstable; urgency=low
* Add missing build dependency on ruby-multi-json (Closes: #680836).
2012-06-26 - Antonio Terceiro <terceiro@debian.org>
ruby-execjs (1.4.0-1) unstable; urgency=low
* Initial release.

See Also

Package Description
ruby-exif_0.1.2-21+b9_amd64.deb Ruby library for EXIF tag parsing
ruby-expression-parser-doc_0.9.1-4_all.deb mathematical expression parser for Ruby (documentation)
ruby-expression-parser_0.9.1-4_all.deb mathematical expression parser for Ruby
ruby-extendmatrix_0.3.1-3_all.deb Enhancements to the Ruby Matrix module
ruby-extlib_0.9.16-1_all.deb general Ruby class extensions for DataMapper and Merb
ruby-eye_0.7-5_all.deb process monitoring tool
ruby-facade_1.0.7-1_all.deb facade pattern aide for Ruby
ruby-facebox-rails_0.2.0-2_all.deb use Facebox with Rails applications
ruby-facets-doc_2.9.3-2_all.deb extensive additions and extensions library for Ruby -- API documentation
ruby-facets_2.9.3-2_all.deb extensive additions and extensions library for Ruby
ruby-factory-bot_4.11.1-1_all.deb Framework and DSL for defining and using model instance factories
ruby-factory-girl-rails_4.7.0-1_all.deb provides integration between factory_girl and rails 3.2+
ruby-factory-girl_4.7.0-2_all.deb framework and DSL for defining and using model instance factories
ruby-fakefs_0.14.2-1_all.deb Fake file system to be used in unit tests
ruby-faker_1.6.6-1_all.deb easily generate fake data
Advertisement
Advertisement