ruby-eventmachine_1.0.7-4+b2_amd64.deb


Advertisement

Description

ruby-eventmachine - Ruby/EventMachine library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-eventmachine
Package version 1.0.7
Package release 4+b2
Package architecture amd64
Package type deb
Installed size 564 B
Download size 133.46 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-eventmachine_1.0.7-4+b2_i386.deb 1.0.7 i386 Debian Main
ruby-eventmachine - - -

Requires

Name Value
libc6 >= 2.17
libgcc1 >= 1:3.0
libgmp10 -
libruby2.5 >= 2.5.0~preview1
libssl1.1 >= 1.1.0
libstdc++6 >= 5.2
ruby >= 1:2.5~0
ruby << 1:2.6~

Download

Type URL
Binary Package ruby-eventmachine_1.0.7-4+b2_amd64.deb
Source Package ruby-eventmachine

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-eventmachine deb package:
    # sudo apt-get install ruby-eventmachine

Files

Path
/usr/lib/ruby/vendor_ruby/eventmachine.rb
/usr/lib/ruby/vendor_ruby/jeventmachine.rb
/usr/lib/ruby/vendor_ruby/em/buftok.rb
/usr/lib/ruby/vendor_ruby/em/callback.rb
/usr/lib/ruby/vendor_ruby/em/channel.rb
/usr/lib/ruby/vendor_ruby/em/completion.rb
/usr/lib/ruby/vendor_ruby/em/connection.rb
/usr/lib/ruby/vendor_ruby/em/deferrable.rb
/usr/lib/ruby/vendor_ruby/em/file_watch.rb
/usr/lib/ruby/vendor_ruby/em/future.rb
/usr/lib/ruby/vendor_ruby/em/iterator.rb
/usr/lib/ruby/vendor_ruby/em/messages.rb
/usr/lib/ruby/vendor_ruby/em/pool.rb
/usr/lib/ruby/vendor_ruby/em/process_watch.rb
/usr/lib/ruby/vendor_ruby/em/processes.rb
/usr/lib/ruby/vendor_ruby/em/protocols.rb
/usr/lib/ruby/vendor_ruby/em/pure_ruby.rb
/usr/lib/ruby/vendor_ruby/em/queue.rb
/usr/lib/ruby/vendor_ruby/em/resolver.rb
/usr/lib/ruby/vendor_ruby/em/spawnable.rb
/usr/lib/ruby/vendor_ruby/em/streamer.rb
/usr/lib/ruby/vendor_ruby/em/threaded_resource.rb
/usr/lib/ruby/vendor_ruby/em/tick_loop.rb
/usr/lib/ruby/vendor_ruby/em/timers.rb
/usr/lib/ruby/vendor_ruby/em/version.rb
/usr/lib/ruby/vendor_ruby/em/deferrable/pool.rb
/usr/lib/ruby/vendor_ruby/em/protocols/header_and_content.rb
/usr/lib/ruby/vendor_ruby/em/protocols/httpclient.rb
/usr/lib/ruby/vendor_ruby/em/protocols/httpclient2.rb
/usr/lib/ruby/vendor_ruby/em/protocols/line_and_text.rb
/usr/lib/ruby/vendor_ruby/em/protocols/line_protocol.rb
/usr/lib/ruby/vendor_ruby/em/protocols/linetext2.rb
/usr/lib/ruby/vendor_ruby/em/protocols/memcache.rb
/usr/lib/ruby/vendor_ruby/em/protocols/object_protocol.rb
/usr/lib/ruby/vendor_ruby/em/protocols/postgres3.rb
/usr/lib/ruby/vendor_ruby/em/protocols/saslauth.rb
/usr/lib/ruby/vendor_ruby/em/protocols/smtpclient.rb
/usr/lib/ruby/vendor_ruby/em/protocols/smtpserver.rb
/usr/lib/ruby/vendor_ruby/em/protocols/socks4.rb
/usr/lib/ruby/vendor_ruby/em/protocols/stomp.rb
/usr/lib/ruby/vendor_ruby/em/protocols/tcptest.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/fastfilereaderext.so
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/rubyeventmachine.so
/usr/share/doc/ruby-eventmachine/README.md
/usr/share/doc/ruby-eventmachine/changelog.Debian.amd64.gz
/usr/share/doc/ruby-eventmachine/changelog.Debian.gz
/usr/share/doc/ruby-eventmachine/changelog.gz
/usr/share/doc/ruby-eventmachine/copyright
/usr/share/doc/ruby-eventmachine/examples/guides/getting_started/01_eventmachine_echo_server.rb
/usr/share/doc/ruby-eventmachine/examples/guides/getting_started/02_eventmachine_echo_server_that_recognizes_exit_command.rb
/usr/share/doc/ruby-eventmachine/examples/guides/getting_started/03_simple_chat_server.rb
/usr/share/doc/ruby-eventmachine/examples/guides/getting_started/04_simple_chat_server_step_one.rb
/usr/share/doc/ruby-eventmachine/examples/guides/getting_started/05_simple_chat_server_step_two.rb
/usr/share/doc/ruby-eventmachine/examples/guides/getting_started/06_simple_chat_server_step_three.rb
/usr/share/doc/ruby-eventmachine/examples/guides/getting_started/07_simple_chat_server_step_four.rb
/usr/share/doc/ruby-eventmachine/examples/guides/getting_started/08_simple_chat_server_step_five.rb
/usr/share/doc/ruby-eventmachine/examples/old/ex_channel.rb
/usr/share/doc/ruby-eventmachine/examples/old/ex_queue.rb
/usr/share/doc/ruby-eventmachine/examples/old/ex_tick_loop_array.rb
/usr/share/doc/ruby-eventmachine/examples/old/ex_tick_loop_counter.rb
/usr/share/doc/ruby-eventmachine/examples/old/helper.rb
/usr/share/lintian/overrides/ruby-eventmachine
/usr/share/rubygems-integration/2.5.0/specifications/eventmachine-1.0.7.gemspec

Changelog

2017-01-23 - Christian Hofstaedtler <zeha@debian.org>
ruby-eventmachine (1.0.7-4) unstable; urgency=medium
* Team upload.
[ Antonio Terceiro ]
* move rakelib/ back on clean target
[ Cédric Boutillier ]
* Bump debhelper compatibility level to 9
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.8 (no changes needed)
* Run wrap-and-sort on packaging files
[ Christian Hofstaedtler ]
* Disable flaky inoty test (Closes: #831244)
2015-07-20 - Antonio Terceiro <terceiro@debian.org>
ruby-eventmachine (1.0.7-3) unstable; urgency=medium
* Team upload.
* Update packaging with a new dh-make-ruby run
- switched tests from debian/ruby-tests.rb to debian/ruby-tests.rake
2015-07-14 - Christian Hofstaedtler <zeha@debian.org>
ruby-eventmachine (1.0.7-2) unstable; urgency=medium
* Team upload.
* Disable known-broken test, see upstream issue #575.
2015-04-30 - Pirate Praveen <praveen@debian.org>
ruby-eventmachine (1.0.7-1) unstable; urgency=medium
* Team upload.
* Re-upload to unstable.
* Add ruby-minitest, rake and ruby-test-unit to build deps.
* Disable more network using tests.
* Stop ignoring test failures.
2015-04-09 - Christian Hofstaedtler <zeha@debian.org>
ruby-eventmachine (1.0.7-1~exp1) experimental; urgency=medium
* Team upload.
* Imported Upstream version 1.0.7
* Bump Standards-Version to 3.9.6
* Update Vcs-Browser to cgit URL and HTTPS
* Target experimental and build for ruby2.2.
2014-04-07 - Per Andersson <avtobiff@gmail.com>
ruby-eventmachine (1.0.3-6) unstable; urgency=low
* Bump gem2deb build dependency to 0.7.5~
* Rebuild to get rid of mkmf.log (Closes: #743661)
2014-04-03 - Pirate Praveen <praveen@debian.org>
ruby-eventmachine (1.0.3-5) unstable; urgency=low
* Team upload.
* Bump gem2deb build dep to 0.7.4~ 
2014-01-16 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-eventmachine (1.0.3-4) unstable; urgency=low
* Team upload.
* d/rules: disable tests for now
* bump Standards-Version to 3.9.5 (no changes needed)
2013-06-17 - Cédric Boutillier <boutil@debian.org>
ruby-eventmachine (1.0.3-3) unstable; urgency=medium
* Team upload.
* Set urgency to medium as an RC bug is closed.
* Disable tests requiring network access. (Closes: #710941)
+ add debian/patches/skip_tests_using_network.patch some of these tests
+ skip entire test files from debian/ruby-tests.rb
2013-05-20 - Praveen Arimbrathodiyil <praveen@debian.org>
ruby-eventmachine (1.0.3-2) unstable; urgency=low
* Team upload.
* Add libssl-dev to build deps. (Closes: #591979)
- webmock needs eventmachine with encryption support.

See Also

Package Description
ruby-exception-notification_4.0.1-1_all.deb exception notification support for Rails and Rack apps
ruby-excon_0.60.0-1_all.deb Ruby library for creating fast, persistent, HTTP(S) connections
ruby-execjs_2.6.0-1_all.deb Run JavaScript code from Ruby
ruby-exif_0.1.2-21+b9_amd64.deb Ruby library for EXIF tag parsing
ruby-expression-parser-doc_0.9.1-4_all.deb mathematical expression parser for Ruby (documentation)
ruby-expression-parser_0.9.1-4_all.deb mathematical expression parser for Ruby
ruby-extendmatrix_0.3.1-3_all.deb Enhancements to the Ruby Matrix module
ruby-extlib_0.9.16-1_all.deb general Ruby class extensions for DataMapper and Merb
ruby-eye_0.7-5_all.deb process monitoring tool
ruby-facade_1.0.7-1_all.deb facade pattern aide for Ruby
ruby-facebox-rails_0.2.0-2_all.deb use Facebox with Rails applications
ruby-facets-doc_2.9.3-2_all.deb extensive additions and extensions library for Ruby -- API documentation
ruby-facets_2.9.3-2_all.deb extensive additions and extensions library for Ruby
ruby-factory-bot_4.11.1-1_all.deb Framework and DSL for defining and using model instance factories
ruby-factory-girl-rails_4.7.0-1_all.deb provides integration between factory_girl and rails 3.2+
Advertisement
Advertisement