ruby-em-synchrony_1.0.5-2_all.deb


Advertisement

Description

ruby-em-synchrony - fiber aware EventMachine libraries

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-em-synchrony
Package version 1.0.5
Package release 2
Package architecture all
Package type deb
Installed size 92 B
Download size 20.70 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-em-synchrony_1.0.5-2_all.deb 1.0.5 all Debian Main
ruby-em-synchrony - - -

Requires

Name Value
ruby -
ruby-activerecord -
ruby-amq-protocol -
ruby-amqp -
ruby-em-hiredis -
ruby-em-http-request -
ruby-em-mongo -
ruby-eventmachine -
ruby-interpreter -
ruby-mongo -
ruby-mysql2 -
ruby-remcached -

Download

Type URL
Binary Package ruby-em-synchrony_1.0.5-2_all.deb
Source Package ruby-em-synchrony

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-em-synchrony deb package:
    # sudo apt-get install ruby-em-synchrony

Files

Path
/usr/lib/ruby/vendor_ruby/em-synchrony.rb
/usr/lib/ruby/vendor_ruby/active_record/connection_adapters/em_mysql2_adapter.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/activerecord.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/activerecord_4_2.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/amqp.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/connection_pool.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/core_ext.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/em-hiredis.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/em-http.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/em-jack.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/em-memcache.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/em-mongo.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/em-multi.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/em-redis.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/em-remcached.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/fiber_iterator.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/iterator.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/kernel.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/keyboard.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/mechanize.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/mongo.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/mongoid.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/mysql2.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/tcpsocket.rb
/usr/lib/ruby/vendor_ruby/em-synchrony/thread.rb
/usr/share/doc/ruby-em-synchrony/README.md.gz
/usr/share/doc/ruby-em-synchrony/changelog.Debian.gz
/usr/share/doc/ruby-em-synchrony/copyright
/usr/share/doc/ruby-em-synchrony/examples/all.rb
/usr/share/doc/ruby-em-synchrony/examples/nethttp.rb
/usr/share/rubygems-integration/all/specifications/em-synchrony-1.0.5.gemspec

Changelog

2016-12-19 - Christian Hofstaedtler <zeha@debian.org>
ruby-em-synchrony (1.0.5-2) unstable; urgency=medium
* Team upload.
* Switch to default-mysql-server for tests (Closes: #848288)
2016-07-06 - C├ędric Boutillier <boutil@debian.org>
ruby-em-synchrony (1.0.5-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 1.0.5
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Add no-amqp-client.patch to remove reference to AMQP::Client, which
disappeared in  amqp >= 1.1 (Closes: #818258)
* Drop fix-tests-with-new-rspec-syntax.patch, not needed anymore
* Refresh patches
* Bump Standards-Version to 3.9.8 (no changes needed)
* Set Testsuite to autopkgtest-pkg-ruby
2016-03-02 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
ruby-em-synchrony (1.0.4-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 1.0.4
* Create patch to fix tests with ruby2.3 (Closes: #800029)
* Create patch to remove relative requires from tests
* Refresh existent patches
* Update disable-failing-activerecord-tests.patch, skip new activerecord test
* rename debian/start_services_and_auto_install.sh to
debian/start_services_and_run.sh and make it generic; adapt all in
debian/rules accordingly.
* Move logic for calling debian/start_services_and_run.sh for running the
tests inside debian/ruby-tests.rake
* debian/control: update Vcs ulr, silence lintian
* Declare compliance with Debian policy 3.9.7
* debian/copyright: add Upstream-Contact field and add some commas
* Update Debian packaging copyright
* Bump debhelper compatibility level to 9
* debian/control: wrap and sort
2014-05-04 - Pirate Praveen <praveen@debian.org>
ruby-em-synchrony (1.0.3-1) unstable; urgency=low
[ Jonas Genannt ]
* Initial release (Closes: #705578)

See Also

Package Description
ruby-em-websocket_0.5.1-2_all.deb EventMachine based, async, Ruby WebSocket server
ruby-email-reply-parser_0.5.8-2_all.deb Small library to parse plain text email content
ruby-email-reply-trimmer_0.1.6-1_all.deb Library to trim replies from plain text email
ruby-email-spec_1.6.0-1_all.deb easily test email in rspec and cucumber and minitest
ruby-email-validator_1.4.0-1_all.deb email validator for Rails 3+
ruby-emot_0.0.4-1_all.deb Yet another emoji handler
ruby-encryptor_3.0.0-2_all.deb wrapper for the standard Ruby OpenSSL library
ruby-entypo-rails_3.0.0-1_all.deb rails asset pipeline plugin providing Entypo icons
ruby-enum_0.7.2-1_all.deb Enum-like behavior for Ruby
ruby-enumerize_2.2.2-1_all.deb enumerated attributes with internationalisation
ruby-equalizer_0.0.11-2_all.deb Ruby module to define equality, equivalence and inspection methods
ruby-errbase_0.0.3-1_all.deb Common exception reporting for a variety of services
ruby-erubi_1.7.1-1_all.deb Small ERB Implementation
ruby-erubis_2.7.0-3_all.deb fast and extensible eRuby implementation which supports multi-language
ruby-escape-utils_1.2.1-1+b1_amd64.deb Faster string escaping routines for your web apps
Advertisement
Advertisement