ruby-diff-lcs_1.3-1_all.deb


Advertisement

Description

ruby-diff-lcs - McIlroy-Hunt longest common subsequence algorithm implementation

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-diff-lcs
Package version 1.3
Package release 1
Package architecture all
Package type deb
Installed size 108 B
Download size 25.05 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-diff-lcs_1.3-1_all.deb 1.3 all Debian Main
ruby-diff-lcs - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-diff-lcs_1.3-1_all.deb
Source Package ruby-diff-lcs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-diff-lcs deb package:
    # sudo apt-get install ruby-diff-lcs

Files

Path
/usr/lib/ruby/vendor_ruby/diff-lcs.rb
/usr/lib/ruby/vendor_ruby/diff/lcs.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/array.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/block.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/callbacks.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/change.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/htmldiff.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/hunk.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/internals.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/ldiff.rb
/usr/lib/ruby/vendor_ruby/diff/lcs/string.rb
/usr/share/doc/ruby-diff-lcs/README.rdoc
/usr/share/doc/ruby-diff-lcs/changelog.Debian.gz
/usr/share/doc/ruby-diff-lcs/changelog.gz
/usr/share/doc/ruby-diff-lcs/copyright
/usr/share/doc/ruby-diff-lcs/examples/htmldiff
/usr/share/doc/ruby-diff-lcs/examples/ldiff
/usr/share/rubygems-integration/all/specifications/diff-lcs-1.3.gemspec

Changelog

2017-07-06 - Lucas Nussbaum <lucas@debian.org>
ruby-diff-lcs (1.3-1) unstable; urgency=medium
[ Cédric Boutillier ]
* Bump debhelper compatibility level to 9
* Use https:// in Vcs-* fields
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Lucas Nussbaum ]
* New upstream version 1.3
* Bump Standards-Version. No changes needed.
* Refresh packaging
* Refresh patches
2015-08-12 - Cédric Boutillier <boutil@debian.org>
ruby-diff-lcs (1.2.5-2) unstable; urgency=medium
* Add hunk_in_spec.patch to require diff/lcs/hunk.rb in spec_hunk.rb
(closes: #794164)
* Update homepage to GitHub as rubyforge is dead
* Refresh packaging
+ Bump Standards to 3.9.6 (no changes needed)
2014-02-15 - Cédric Boutillier <boutil@debian.org>
ruby-diff-lcs (1.2.5-1) unstable; urgency=medium
* Imported Upstream version 1.2.5
* Install upstream changelog
* Bump Standards-Version to 3.9.5 (no changes needed)
2013-05-07 - Cédric Boutillier <boutil@debian.org>
ruby-diff-lcs (1.2.4-1) unstable; urgency=low
* New upstream version
* Build against gem2deb (>= 0.3.0~) to provide rubygems integration (Closes:
#698214)
* debian/control:
+ add myself to Uploaders
+ remove deprecated DM-Upload-Allowed field
+ bump Standards-Version to 3.9.4 (no changes needed)
+ use canonical URLs for Vcs-* fields
+ drop obsolete transition packages
+ depend on ruby instead of ruby1.8
* debian/copyright:
+ convert copyright file to DEP-5 copyright-format/1.0
+ update copyright information
* debian/source/local-options: add unapply-patches
* debian/patches: add fix_shebang_for_bins.patch to fix shebang for scripts
in bin/
* use ruby-tests.rake method to run the specs
* ship scripts in bin/ as examples
2011-10-09 - Lucas Nussbaum <lucas@debian.org>
ruby-diff-lcs (1.1.3-1) unstable; urgency=low
* New upstream version.
* Switch to my @d.o email address.
* Standards-Version -> 3.9.2. No changes needed.
* Conflicts -> Breaks.
* drop 10_shebangs. no need to fix shebangs in libs.
* switch to rspec to run tests.
* README renamed to README.rdoc.
2011-04-26 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-diff-lcs (1.1.2-7) unstable; urgency=low
* Switch to gem2deb-based packaging. Rename source and binary packages.
2010-04-10 - Paul van Tilburg <paulvt@debian.org>
libdifflcs-ruby (1.1.2-6) unstable; urgency=low
* This package is now maintained within the Debian/Ruby Extras team.
* debian/control: 
- Added the team (and myself) to the uploaders.
- Added the Vcs-* fields.
* debian/watch: Changed the regexp so it doesn't look at the wrong
files (e.g. GPG asc sign files). 
2010-04-06 - Tobias Grimm <etobi@debian.org>
libdifflcs-ruby (1.1.2-5) unstable; urgency=low
* Dropped shebang replacement for /usr/bin from 10_shebangs.dpatch -
libsetup-ruby will take care
* Renamed /usr/bin/*1.9 -> *1.9.1 (Closes: #570434)
* Backup and restore scripts with shebang line to work around #571981 in
libsetup-ruby
* Switched to source format 3.0 (quilt)
* Updated package description
2010-02-15 - Sebastien Delafond <seb@debian.org>
libdifflcs-ruby (1.1.2-4) unstable; urgency=low
* Move from ruby1.9 to ruby1.9.1 (Closes: #569887).
* Removed unused lintian override.
* Enabled tests in debian/rules.
* Bumped up Standards-Version.
2009-10-12 - Sebastien Delafond <seb@debian.org>
libdifflcs-ruby (1.1.2-3) unstable; urgency=low
* More proper debian/rules to deal with duplicate binaries in
/usr/bin/*.

See Also

Package Description
ruby-diffy_3.2.1-1_all.deb convenient way to diff strings in Ruby
ruby-directory-watcher_1.5.1-2_all.deb Watch directory/files and Generate events by file change
ruby-dirty-memoize_0.0.4-1_all.deb Similar to ruby-memoize, but for mutable and parameterizable objects
ruby-distribution_0.7.3+dfsg-1_all.deb Ruby library to work with probability distributions
ruby-diva_0.3.2-1_all.deb Implementation of expression for handling things for mikutter
ruby-dnsruby_1.61.2-1_all.deb Ruby DNS and DNSSEC client library
ruby-docile_1.1.5-2_all.deb Docile keeps your Ruby DSLs tame and well-behaved
ruby-docker-api_1.22.2-1_all.deb Ruby gem to interact with docker.io remote API
ruby-domain-name_0.5.20160216-2_all.deb Domain Name manipulation library for Ruby
ruby-doorkeeper-openid-connect_1.5.2-1_all.deb OpenID Connect extension for Doorkeeper
ruby-doorkeeper_4.4.2-1_all.deb OAuth 2 provider for Rails and Grape
ruby-dotenv_2.4.0-1_all.deb configuration variable loader
ruby-dropzonejs-rails_0.8.2-1_all.deb Dropzone JS File upload via Rails Asset pipeline
ruby-eb_2.6-3+b8_amd64.deb EB library interface for the Ruby
ruby-ecasound_2.9.1-7_all.deb multitrack-capable audio recorder and effect processor (ruby bindings)
Advertisement
Advertisement