ruby-dbf_3.0.5-1_all.deb


Advertisement

Description

ruby-dbf - small fast Ruby library for reading database files

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-dbf
Package version 3.0.5
Package release 1
Package architecture all
Package type deb
Installed size 67 B
Download size 18.87 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-dbf_3.0.5-1_all.deb 3.0.5 all Debian Main
ruby-dbf - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-dbf_3.0.5-1_all.deb
Source Package ruby-dbf

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-dbf deb package:
    # sudo apt-get install ruby-dbf

Files

Path
/usr/bin/dbf-rb
/usr/lib/ruby/vendor_ruby/dbf.rb
/usr/lib/ruby/vendor_ruby/dbf/column.rb
/usr/lib/ruby/vendor_ruby/dbf/column_type.rb
/usr/lib/ruby/vendor_ruby/dbf/encodings.rb
/usr/lib/ruby/vendor_ruby/dbf/header.rb
/usr/lib/ruby/vendor_ruby/dbf/record.rb
/usr/lib/ruby/vendor_ruby/dbf/schema.rb
/usr/lib/ruby/vendor_ruby/dbf/table.rb
/usr/lib/ruby/vendor_ruby/dbf/version.rb
/usr/lib/ruby/vendor_ruby/dbf/database/foxpro.rb
/usr/lib/ruby/vendor_ruby/dbf/memo/base.rb
/usr/lib/ruby/vendor_ruby/dbf/memo/dbase3.rb
/usr/lib/ruby/vendor_ruby/dbf/memo/dbase4.rb
/usr/lib/ruby/vendor_ruby/dbf/memo/foxpro.rb
/usr/share/doc/ruby-dbf/README.md.gz
/usr/share/doc/ruby-dbf/changelog.Debian.gz
/usr/share/doc/ruby-dbf/changelog.gz
/usr/share/doc/ruby-dbf/copyright
/usr/share/man/man1/dbf-rb.1.gz
/usr/share/rubygems-integration/all/specifications/dbf-3.0.5.gemspec

Changelog

2016-07-08 - Cédric Boutillier <boutil@debian.org>
ruby-dbf (3.0.5-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 3.0.5
+ does not require fastercvs in gemspecs (Closes: #830098)
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.8 (no changes needed)
* Run wrap-and-sort on packaging files
* Check gem dependencies in debian/rules
* Remove hack to use the -s switch of the interpreter
* Set default encoding to UTF-8 in tests
2015-07-18 - Christopher Baines <mail@cbaines.net>
ruby-dbf (2.0.10-1) unstable; urgency=medium
* Imported Upstream version 2.0.10
* Update my email address
2014-10-05 - David Suárez <david.sephirot@gmail.com>
ruby-dbf (2.0.7-1) unstable; urgency=medium
* Team upload.
[ David Suárez ]
* New upstream version.
* debian/changelog: set urgency to medium.
2013-12-03 - Cédric Boutillier <boutil@debian.org>
ruby-dbf (2.0.6-2) unstable; urgency=low
* Team upload.
* Rewrite shebang of /usr/bin/dbf-rb, to be able to use -s ruby switch.
(Closes: #731184)
2013-12-03 - Cédric Boutillier <boutil@debian.org>
ruby-dbf (2.0.6-1) unstable; urgency=low
* Team upload
* Imported Upstream version 2.0.6
* Build against gem2deb (>=0.5) to add Ruby2.0 support and drop Ruby1.8
* Drop dependency on ruby-fastercsv (Ruby1.8 only)
* Bump Standards-Version to 3.9.5 (no changes needed)
2013-07-06 - Christopher Baines <cbaines8@gmail.com>
ruby-dbf (2.0.5-1) unstable; urgency=low
* New upstream version
* Remove patches as they have been merged upstream
2013-02-24 - Christopher Baines <cbaines8@gmail.com>
ruby-dbf (2.0.3-1) unstable; urgency=low
* Initial release (Closes: #702161)

See Also

Package Description
ruby-dbus_0.13.0-1_all.deb Ruby binding for D-Bus
ruby-ddmemoize_1.0.0-1_all.deb Ruby library providing support for memoizing functions
ruby-ddmetrics_1.0.1-1_all.deb Non-timeseries measurements for Ruby programs
ruby-ddplugin_1.0.2-1_all.deb plugins management for Ruby apps
ruby-debian_0.3.9+b8_amd64.deb ruby interface for dpkg
ruby-declarative-option_0.1.0-1_all.deb Dynamic options for declarative to evaluate at runtime
ruby-declarative_0.0.9-1_all.deb DSL for nested schemas
ruby-deep-merge_1.1.1-1_all.deb recursively merge Hash elements in Ruby
ruby-default-value-for_3.1.0-1_all.deb provides a way to specify default values for ActiveRecord models
ruby-delayed-job-active-record_4.1.3-1_all.deb ActiveRecord backend for DelayedJob
ruby-delayed-job_4.1.5-1_all.deb database-backed asynchronous priority queue system
ruby-delayer-deferred_2.0.0-3_all.deb Ruby implementation of JSDeferred
ruby-delayer_0.0.2-5_all.deb Ruby library providing delay the processing
ruby-delorean_2.1.0-2_all.deb lets you travel in time with Ruby by mocking Time.now
ruby-dep-selector_1.0.3-2+b4_amd64.deb assignment of version to packages given their dependencies
Advertisement
Advertisement