ruby-color_1.8-2_all.deb


Advertisement

Description

ruby-color - Ruby library to provide RGB, CMYK and other colorspace support

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-color
Package version 1.8
Package release 2
Package architecture all
Package type deb
Installed size 113 B
Download size 26.92 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-color_1.8-2_all.deb 1.8 all Debian Main
ruby-color - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-color_1.8-2_all.deb
Source Package ruby-color

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-color deb package:
    # sudo apt-get install ruby-color

Files

Path
/usr/lib/ruby/vendor_ruby/color.rb
/usr/lib/ruby/vendor_ruby/color/cmyk.rb
/usr/lib/ruby/vendor_ruby/color/css.rb
/usr/lib/ruby/vendor_ruby/color/grayscale.rb
/usr/lib/ruby/vendor_ruby/color/hsl.rb
/usr/lib/ruby/vendor_ruby/color/palette.rb
/usr/lib/ruby/vendor_ruby/color/rgb.rb
/usr/lib/ruby/vendor_ruby/color/yiq.rb
/usr/lib/ruby/vendor_ruby/color/palette/adobecolor.rb
/usr/lib/ruby/vendor_ruby/color/palette/gimp.rb
/usr/lib/ruby/vendor_ruby/color/palette/monocontrast.rb
/usr/lib/ruby/vendor_ruby/color/rgb/colors.rb
/usr/lib/ruby/vendor_ruby/color/rgb/contrast.rb
/usr/lib/ruby/vendor_ruby/color/rgb/metallic.rb
/usr/share/doc/ruby-color/changelog.Debian.gz
/usr/share/doc/ruby-color/changelog.gz
/usr/share/doc/ruby-color/copyright
/usr/share/rubygems-integration/all/specifications/color-1.8.gemspec

Changelog

2017-12-03 - Cédric Boutillier <boutil@debian.org>
ruby-color (1.8-2) unstable; urgency=medium
* Drop transitional ruby-color-tool package (Closes: #878857)
* Bump debhelper compatibility level to 10
* Bump Standards-Version to 4.1.2 (no changes needed)
* Update homepage and set testsuite
* Refresh packaging with dh-make-ruby -w
2016-03-05 - Lucas Albuquerque Medeiros de Moura <lucas.moura128@gmail.com>
ruby-color (1.8-1) unstable; urgency=medium
* Team upload.
* New upstream version
* Update how tests were executed in the package
* debian/copyright: Remove nonexistent file from copyright
* debian/rules: Add check-dependencies command
2014-07-27 - Cédric Boutillier <boutil@debian.org>
ruby-color (1.7.1-1) unstable; urgency=medium
* Imported Upstream version 1.7.1
2014-07-06 - Cédric Boutillier <boutil@debian.org>
ruby-color (1.7-1) unstable; urgency=medium
* Imported Upstream version 1.7
* Update email address and years in Upstream authors entry
* Shorten the description of ruby-color-tools transitional package
2014-05-11 - Cédric Boutillier <boutil@debian.org>
ruby-color (1.5.1-1) unstable; urgency=medium
* Imported Upstream version 1.5.1
* Rename source and binary to ruby-color
+ upstream is now called color instead of color-tools
+ provide a ruby-color-tools dummy transition package
* Add myself to uploaders
* Bump standards-version to 3.9.5 (no changes needed)
* Use the Ruby method to run the tests
* patch: do not use gem to load minitest
2013-10-07 - Cédric Boutillier <boutil@debian.org>
ruby-color-tools (1.4.2-2) unstable; urgency=low
* Team upload
* Build-depend on ruby-minitest (Closes: #725548).
* Modify require_instead_of_gem patch to simply delete the gem statement
instead of replacing it with a require.
* Install History.rdoc as upstream changelog.
2013-10-01 - Gunnar Wolf <gwolf@gwolf.org>
ruby-color-tools (1.4.2-1) unstable; urgency=low
* New upstream release
* Dropped transitional packages, no longer needed
* Adjusted list of test files to what currently ships
* Replace "gem" calls by "require" in the test cases
* README.txt renamed to .rdoc
2012-06-30 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-color-tools (1.4.1-2) unstable; urgency=low
* Team upload.
* Bump build dependency on gem2deb to >= 0.3.0~.
* Bump Standard-Version: to 3.9.3 (no changes needed)
* Use Breaks instead of Conflicts for dependency relation on old packages
* Set priority of transitional packages to extra
* Override lintian warning about duplicate description of transitional
packages
2011-06-08 - Gunnar Wolf <gwolf@debian.org>
ruby-color-tools (1.4.1-1) unstable; urgency=low
* New upstream release
* Switched to gem2deb build system; renamed package libcolor-tools-
ruby → ruby-color-tools
2009-04-25 - Gunnar Wolf <gwolf@debian.org>
libcolor-tools-ruby (1.4.0-1) unstable; urgency=low
* Changed section to Ruby as per ftp-masters' request
* Updated debian/watch as the project was separated from pdf-writer
* Standards-version 3.7.2 => 3.8.1.0 (no changes needed)
* Added Vcs-Svn, Vcs-Browser and Homepage tags to debian/control
* New upstream release

See Also

Package Description
ruby-colorator_1.1.0-1_all.deb String core extensions for terminal coloring
ruby-colored_1.2-2_all.deb library to add colors or attributes to text
ruby-colorize_0.8.1-1_all.deb color methods to Ruby String class
ruby-columnize_0.9.0-1_all.deb Ruby library to format arrays as column-aligned strings
ruby-combustion_0.5.4-1_all.deb elegant rails engine testing
ruby-commander_4.4.5-1_all.deb Ruby command-line interface library
ruby-commonmarker_0.17.9-1_amd64.deb CommonMark parser and renderer - Written in C, wrapped in Ruby
ruby-compass-core_1.0.3~dfsg-5_all.deb Stylesheet Framework for CSS - core stylesheet library
ruby-compass-import-once_1.0.5~dfsg-5_all.deb Stylesheet Framework for CSS - Sass compilation optimizer
ruby-compass-rails_2.0.5-5_all.deb integrate Compass into Rails 3.2 and up
ruby-compass_1.0.3~dfsg-5_all.deb Stylesheet Framework streamlining creation and maintenance of CSS
ruby-compat-resource_12.10.5-1_all.deb cookbook with some features of Chef 12.5 in previous 12.X releases
ruby-concurrent-ext_1.0.5-1+b2_amd64.deb C extensions to optimize concurrent-ruby under MRI
ruby-concurrent_1.0.5-2_all.deb modern concurrency tools for Ruby
ruby-configurate_0.3.1-1_all.deb Flexible configuration system for Ruby
Advertisement
Advertisement