ruby-clamp_1.1.1-1_all.deb


Advertisement

Description

ruby-clamp - minimal framework for Ruby command-line utilities

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-clamp
Package version 1.1.1
Package release 1
Package architecture all
Package type deb
Installed size 79 B
Download size 17.67 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-clamp_1.1.1-1_all.deb 1.1.1 all Debian Main
ruby-clamp - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-clamp_1.1.1-1_all.deb
Source Package ruby-clamp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-clamp deb package:
    # sudo apt-get install ruby-clamp

Files

Path
/usr/lib/ruby/vendor_ruby/clamp.rb
/usr/lib/ruby/vendor_ruby/clamp/command.rb
/usr/lib/ruby/vendor_ruby/clamp/errors.rb
/usr/lib/ruby/vendor_ruby/clamp/help.rb
/usr/lib/ruby/vendor_ruby/clamp/messages.rb
/usr/lib/ruby/vendor_ruby/clamp/truthy.rb
/usr/lib/ruby/vendor_ruby/clamp/version.rb
/usr/lib/ruby/vendor_ruby/clamp/attribute/declaration.rb
/usr/lib/ruby/vendor_ruby/clamp/attribute/definition.rb
/usr/lib/ruby/vendor_ruby/clamp/attribute/instance.rb
/usr/lib/ruby/vendor_ruby/clamp/option/declaration.rb
/usr/lib/ruby/vendor_ruby/clamp/option/definition.rb
/usr/lib/ruby/vendor_ruby/clamp/option/parsing.rb
/usr/lib/ruby/vendor_ruby/clamp/parameter/declaration.rb
/usr/lib/ruby/vendor_ruby/clamp/parameter/definition.rb
/usr/lib/ruby/vendor_ruby/clamp/parameter/parsing.rb
/usr/lib/ruby/vendor_ruby/clamp/subcommand/declaration.rb
/usr/lib/ruby/vendor_ruby/clamp/subcommand/definition.rb
/usr/lib/ruby/vendor_ruby/clamp/subcommand/execution.rb
/usr/lib/ruby/vendor_ruby/clamp/subcommand/parsing.rb
/usr/share/doc/ruby-clamp/CHANGES.md
/usr/share/doc/ruby-clamp/README.md.gz
/usr/share/doc/ruby-clamp/changelog.Debian.gz
/usr/share/doc/ruby-clamp/changelog.gz
/usr/share/doc/ruby-clamp/copyright
/usr/share/doc/ruby-clamp/examples/admin
/usr/share/doc/ruby-clamp/examples/defaulted
/usr/share/doc/ruby-clamp/examples/flipflop
/usr/share/doc/ruby-clamp/examples/fubar
/usr/share/doc/ruby-clamp/examples/gitdown
/usr/share/doc/ruby-clamp/examples/scoop
/usr/share/doc/ruby-clamp/examples/speak
/usr/share/doc/ruby-clamp/examples/subcommand_missing
/usr/share/rubygems-integration/all/specifications/clamp-1.1.1.gemspec

Changelog

2016-11-07 - Michael Moll <kvedulv@kvedulv.de>
ruby-clamp (1.1.1-1) unstable; urgency=low
* Team upload.
[ Michael Moll ]
* New upstream release
* Bump Standards-Version to 3.9.8 (no changes needed)
[ C├ędric Boutillier ]
* Run wrap-and-sort on packaging files
* Use https:// in Vcs-* fields
* Remove version in the gem2deb build-dependency
* Bump debhelper compatibility level to 9
2015-08-10 - Michael Moll <kvedulv@kvedulv.de>
ruby-clamp (1.0.0-1) unstable; urgency=low
* Team upload
* New upstream release which is Ruby 2.2 and rspec 3 ready (Closes: #794163)
2014-10-14 - Tim Potter <tpot@hp.com>
ruby-clamp (0.6.3-1) unstable; urgency=medium
* Initial release (Closes: #704685)

See Also

Package Description
ruby-classifier-reborn_2.2.0-1_all.deb Successor of Ruby::Classifier
ruby-classifier_1.3.4-2_all.deb Ruby module to allow Bayesian and other types of classifications
ruby-clean-test_1.0.0-1_all.deb Get unit tests readable and fluent
ruby-cleanroom_1.0.0-1_all.deb Ruby module for safer evaluation of Ruby DSLs
ruby-client-side-validations_3.2.6+gh-1_all.deb client side validations made easy for your Rails v3.1+ apps
ruby-climate-control_0.0.3-1_all.deb library to easily manage environment variables
ruby-cliver_0.3.2-3_all.deb cross-platform version constraints for cli tools
ruby-clockwork_1.2.0-3_all.deb scheduler process to replace cron
ruby-clutter-gdk_3.3.0-1_all.deb Clutter-Gdk bindings for the Ruby language
ruby-clutter-gtk_3.3.0-1_all.deb Clutter-Gtk bindings for the Ruby language
ruby-clutter_3.3.0-1_all.deb Clutter bindings for the Ruby language
ruby-cmdparse_2.0.6-1_all.deb Advanced command line parsing Ruby module supporting sub-commands
ruby-cocaine_0.5.8-1_all.deb library for running command line commands in Ruby
ruby-cocoon_1.2.6-2_all.deb tool to handle nested forms using jQuery
ruby-codemirror-rails_5.16.0-1_all.deb use codemirror with rails
Advertisement
Advertisement