ruby-amq-protocol_2.3.0-1_all.deb


Advertisement

Description

ruby-amq-protocol - AMQP 0.9.1 encoder & decoder

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name ruby-amq-protocol
Package version 2.3.0
Package release 1
Package architecture all
Package type deb
Installed size 139 B
Download size 21.37 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
ruby-amq-protocol_2.3.0-1_all.deb 2.3.0 all Debian Main
ruby-amq-protocol - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-amq-protocol_2.3.0-1_all.deb
Source Package ruby-amq-protocol

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-amq-protocol deb package:
    # sudo apt-get install ruby-amq-protocol

Files

Path
/usr/lib/ruby/vendor_ruby/amq/bit_set.rb
/usr/lib/ruby/vendor_ruby/amq/endianness.rb
/usr/lib/ruby/vendor_ruby/amq/int_allocator.rb
/usr/lib/ruby/vendor_ruby/amq/pack.rb
/usr/lib/ruby/vendor_ruby/amq/protocol.rb
/usr/lib/ruby/vendor_ruby/amq/settings.rb
/usr/lib/ruby/vendor_ruby/amq/uri.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/client.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/constants.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/exceptions.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/float_32bit.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/frame.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/table.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/table_value_decoder.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/table_value_encoder.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/type_constants.rb
/usr/lib/ruby/vendor_ruby/amq/protocol/version.rb
/usr/share/doc/ruby-amq-protocol/README.md
/usr/share/doc/ruby-amq-protocol/changelog.Debian.gz
/usr/share/doc/ruby-amq-protocol/changelog.gz
/usr/share/doc/ruby-amq-protocol/copyright
/usr/share/rubygems-integration/all/specifications/amq-protocol-2.3.0.gemspec

Changelog

2018-04-27 - Lucas Kanashiro <kanashiro@debian.org>
ruby-amq-protocol (2.3.0-1) unstable; urgency=medium
* Team upload.
* New upstream version 2.3.0
* Update years of upstream copyright
* Update Debian packaging copyright
* Declare compliance with Debian policy 4.1.4
* Bump debhelper compatibility level to 11
* Refresh disable_bundler patch
* debian/watch: use https:// instead of http://
* Update VCS urls to point to salsa
2016-03-09 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
ruby-amq-protocol (2.0.1-1) unstable; urgency=medium
* Team upload.
[ Cédric Boutillier ]
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Lucas Kanashiro ]
* Imported Upstream version 2.0.1
* debian/rules: add --check-dependencies flag
* debian/patches: refresh disable_bundler patch
* debian/copyright: update year of upstream copyright
* debian/copyright: update Debian packaging copyright
* debian/ruby-tests.rake: change spec.pattern
* debian/control: add build dependency on ruby-rspec-its
2014-10-13 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-amq-protocol (1.9.2-2) unstable; urgency=low
* Team upload.
* d/control:
- added Testsuite header
- bumped up standards version to 3.9.6 (no changes needed)
* d/{control,copyright}: switched Homepage to https
2014-01-28 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-amq-protocol (1.9.2-1) unstable; urgency=low
* Team upload.
[ Cédric Boutillier ]
* debian/control:
- remove obsolete DM-Upload-Allowed flag
- use canonical URI in Vcs-* fields
* debian/copyright: use copyright-format/1.0 official URL for Format field
[ Jonas Genannt ]
* Imported Upstream version 1.9.2
* d/control:
- bumped standards version to 3.9.5 (no changes needed)
* added ruby-amq-protocol.docs
* d/copyright:
- switched MIT to Expat
- added myself to copyright
* refreshed patch disable_bundler, added DEP3 header
* removed ruby-tests.rb, added ruby-tests.rake
2012-06-27 - Tollef Fog Heen <tfheen@debian.org>
ruby-amq-protocol (0.9.2-1) unstable; urgency=low
* New upstream version
* Stop installing README.textile, it's gone upstream.
* Bump gem2deb build-dep.
2012-06-22 - Tollef Fog Heen <tfheen@debian.org>
ruby-amq-protocol (0.9.0-2) unstable; urgency=low
* Fix up Source line in copyright file.
2012-06-21 - Tollef Fog Heen <tfheen@debian.org>
ruby-amq-protocol (0.9.0-1) unstable; urgency=low
* Initial release

See Also

Package Description
ruby-amqp_1.6.0-1_all.deb feature-rich, asynchronous AMQP client
ruby-ansi_1.5.0-1_all.deb ANSI escape codes at your fingertips
ruby-api-pagination_4.2.0-1_all.deb API pagination support
ruby-appraisal_0.5.1-2_all.deb Find out what your Ruby gems are worth
ruby-appraiser-reek_1.0.0-1_all.deb Run Reek inside RubyAppraiser
ruby-appraiser-rubocop_1.0.1-1_all.deb Run Rubocop inside RubyAppraiser
ruby-appraiser_0.2.0-3_all.deb simple rubygems subcommand for Gemfile
ruby-archive-tar-minitar_0.6.1-1_all.deb Provides POSIX tarchive management for Ruby - transitional package
ruby-archive-zip_0.11.0-1_all.deb Simple, extensible, pure Ruby ZIP archive support
ruby-arel_6.0.4-1_all.deb SQL AST manager for Ruby
ruby-aruba_0.14.6-2_all.deb Cucumber extension for CLI applications
ruby-asana_0.6.0-1_all.deb official Ruby client for the Asana API
ruby-ascii85_1.0.3-1_all.deb Ruby library to encode/decode the Ascii85 format
ruby-asciidoctor-plantuml_0.0.8-1_all.deb extension for Asciidoctor to enable support for PlantUML diagrams
ruby-asciidoctor_1.5.7.1-1_all.deb AsciiDoc to HTML rendering for Ruby (core libraries)
Advertisement
Advertisement