rssh_2.3.4-8_amd64.deb


Advertisement

Description

rssh - Restricted shell allowing scp, sftp, cvs, svn, rsync or rdist

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name rssh
Package version 2.3.4
Package release 8
Package architecture amd64
Package type deb
Installed size 146 B
Download size 52.93 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
rssh_2.3.4-8_i386.deb 2.3.4 i386 Debian Main
rssh - - -

Requires

Name Value
debconf >= 0.5
debconf-2.0 -
libc6 >= 2.14
openssh-server -

Download

Type URL
Binary Package rssh_2.3.4-8_amd64.deb
Source Package rssh

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install rssh deb package:
    # sudo apt-get install rssh

Files

Path
/etc/rssh.conf
/etc/logcheck/ignore.d.server/rssh
/usr/bin/rssh
/usr/lib/rssh/rssh_chroot_helper
/usr/share/doc/rssh/CHROOT.gz
/usr/share/doc/rssh/NEWS.Debian.gz
/usr/share/doc/rssh/README
/usr/share/doc/rssh/README.Debian
/usr/share/doc/rssh/SECURITY.gz
/usr/share/doc/rssh/TODO
/usr/share/doc/rssh/changelog.Debian.gz
/usr/share/doc/rssh/changelog.gz
/usr/share/doc/rssh/copyright
/usr/share/doc/rssh/examples/mkchroot.sh
/usr/share/man/man1/rssh.1.gz
/usr/share/man/man5/rssh.conf.5.gz
/usr/share/rssh/conf_convert

Changelog

2018-04-22 - Russ Allbery <rra@debian.org>
rssh (2.3.4-8) unstable; urgency=medium
* Update Vcs-Git and Vcs-Browser for the move to salsa.debian.org.
* Use https URL for copyright-format 1.0.
* Update standards version to 4.1.4 (no changes required).
2017-12-23 - Russ Allbery <rra@debian.org>
rssh (2.3.4-7) unstable; urgency=medium
* Change the specified mode of conf_convert in the Debian patch to be
0644, since dpkg doesn't support modes the way that Git does and will
ignore the mode anyway.  This mismatch was breaking use of dgit for
this package.
2017-12-17 - Russ Allbery <rra@debian.org>
rssh (2.3.4-6) unstable; urgency=medium
* Add Rules-Requires-Root: no.
* Update to debhelper compatibility level V11.
- Remove now-useless build dependency on dh-autoreconf.
* Clean up trailing whitespace in debian/changelog.
* Update standards version to 4.1.2 (no changes required).
2016-09-05 - Russ Allbery <rra@debian.org>
rssh (2.3.4-5) unstable; urgency=medium
* Enable all hardening flags.
* Fix another spelling error in the rssh man page, caught by Lintian.
* Translation updates:
- Indonesian, thanks Izharul Haq.  (Closes: #835621)
* Switch to the DEP-14 branch layout and update debian/gbp.conf and
Vcs-Git accordingly.
* Run wrap-and-sort -ast on packaging files.
* Switch to https for Vcs-Git and Vcs-Browser URLs.
* Fix duplicate license clause in debian/copyright.
* Update standards version to 3.9.8 (no changes required).
2013-12-07 - Russ Allbery <rra@debian.org>
rssh (2.3.4-4) unstable; urgency=low
* Fix typo in the example mkchroot script that causes it to fail to
copy the libnss compat modules.  Patch from Jeremy Jongepier.
(Closes: #729294)
* This package is now maintained using gbp pq from git-buildpackage.
Remove the TopGit glue and the obsolete README.source package and
rename the patches based on the export convention of gbp pq.
* Drop override to use xz compression for the binary package.  This is
now the default in dpkg-buildpackage.
* Update standards version to 3.9.5 (no changes required).
* Translation updates:
- Portuguese (Brazilian), thanks Fernando Ike de Oliveira.
(Closes: #723148)
* Reformat translations with debconf-updatepo.  Add some missing
Language fields and update the Report-Msgid-Bugs-To address.
2013-05-28 - Russ Allbery <rra@debian.org>
rssh (2.3.4-3) unstable; urgency=low
* Patch the upstream build system to honor CFLAGS and CPPFLAGS as passed
to configure.  This fixes use of hardening flags during the build.
Thanks to Simon Ruderich for the patch.  (Closes: #709941)
2013-05-11 - Russ Allbery <rra@debian.org>
rssh (2.3.4-2) unstable; urgency=low
* Upload to unstable.
* Fix implicit function declaration compiler warning from the svnserve
patch.
* Use xz compression for the Debian source and binary package.
* Canonicalize the Vcs-Git and Vcs-Browser control fields.
* Update standards version to 3.9.4 (no changes required).
2012-12-07 - Russ Allbery <rra@debian.org>
rssh (2.3.4-1) experimental; urgency=low
* New upstream release.
- Merges fixes/command-line-checking.
- Fix a (probably not exploitable) flaw in determining the command
to run from the provided command line.
* Adjust the installation process for the new upstream behavior of
installing rssh.conf as rssh.conf.default.  The Debian package
continues to install it as /etc/rssh.conf.
* Add new logcheck ignore line for a new upstream log message.
* Fix the log level for a notice of global svnserve access to use debug,
matching the (patched) behavior for the other program types.
* Fix the regular expression in the previous change to correctly match a
literal period instead of any character.  (This fix is not critical,
but adds further defense in depth.)  Remove an unused variable to
silence compiler warnings.  Patch from Tomas Hoger.
* Change debian/watch to use the sf.net redirector.

See Also

Package Description
rsstail_1.8-1+b1_amd64.deb console RSS reader that monitors a feed and outputs new entries
rst2pdf_0.93-6_all.deb ReportLab-based reStructuredText to PDF renderer
rstat-client_4.0.1-9_amd64.deb client for rstatd
rstatd_4.0.1-9_amd64.deb displays uptime information for remote machines
rsync_3.1.2-2.2_amd64.deb fast, versatile, remote (and local) file-copying tool
rsyncrypto_1.14-1_amd64.deb rsync friendly encryption
rsyslog-czmq_8.39.0-2_amd64.deb ZeroMQ protocol support for rsyslog via CZMQ
rsyslog-doc_8.39.0-1_all.deb documentation for rsyslog
rsyslog-elasticsearch_8.39.0-2_amd64.deb Elasticsearch output plugin for rsyslog
rsyslog-gnutls_8.39.0-2_amd64.deb TLS protocol support for rsyslog
rsyslog-gssapi_8.39.0-2_amd64.deb GSSAPI authentication and encryption support for rsyslog
rsyslog-hiredis_8.39.0-2_amd64.deb Redis output plugin for rsyslog
rsyslog-kafka_8.39.0-2_amd64.deb Apache Kafka support for rsyslog
rsyslog-mongodb_8.39.0-2_amd64.deb MongoDB output plugin for rsyslog
rsyslog-mysql_8.39.0-2_amd64.deb MySQL output plugin for rsyslog
Advertisement
Advertisement