rhc_1.38.7-2_all.deb


Advertisement

Description

rhc - OpenShift command-line client tools

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name rhc
Package version 1.38.7
Package release 2
Package architecture all
Package type deb
Installed size 569 B
Download size 113.23 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
rhc_1.38.7-2_all.deb 1.38.7 all Debian Main
rhc - - -

Requires

Name Value
ruby -
ruby-archive-tar-minitar -
ruby-commander >= 4.0
ruby-highline >= 1.6.11
ruby-httpclient -
ruby-interpreter -
ruby-net-scp >= 1.1.2
ruby-net-ssh >= 3.0
ruby-net-ssh-multi >= 1.2.0
ruby-open4 -

Download

Type URL
Binary Package rhc_1.38.7-2_all.deb
Source Package rhc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install rhc deb package:
    # sudo apt-get install rhc

Files

Path
/etc/openshift/express.conf
/usr/bin/rhc
/usr/lib/ruby/vendor_ruby/rhc.rb
/usr/lib/ruby/vendor_ruby/rhc/auth.rb
/usr/lib/ruby/vendor_ruby/rhc/autocomplete.rb
/usr/lib/ruby/vendor_ruby/rhc/cartridge_helpers.rb
/usr/lib/ruby/vendor_ruby/rhc/cli.rb
/usr/lib/ruby/vendor_ruby/rhc/command_runner.rb
/usr/lib/ruby/vendor_ruby/rhc/commands.rb
/usr/lib/ruby/vendor_ruby/rhc/config.rb
/usr/lib/ruby/vendor_ruby/rhc/context_helper.rb
/usr/lib/ruby/vendor_ruby/rhc/core_ext.rb
/usr/lib/ruby/vendor_ruby/rhc/coverage_helper.rb
/usr/lib/ruby/vendor_ruby/rhc/deployment_helpers.rb
/usr/lib/ruby/vendor_ruby/rhc/exceptions.rb
/usr/lib/ruby/vendor_ruby/rhc/git_helpers.rb
/usr/lib/ruby/vendor_ruby/rhc/help_formatter.rb
/usr/lib/ruby/vendor_ruby/rhc/helpers.rb
/usr/lib/ruby/vendor_ruby/rhc/highline_extensions.rb
/usr/lib/ruby/vendor_ruby/rhc/json.rb
/usr/lib/ruby/vendor_ruby/rhc/output_helpers.rb
/usr/lib/ruby/vendor_ruby/rhc/rest.rb
/usr/lib/ruby/vendor_ruby/rhc/scp_helpers.rb
/usr/lib/ruby/vendor_ruby/rhc/server_helpers.rb
/usr/lib/ruby/vendor_ruby/rhc/servers.rb
/usr/lib/ruby/vendor_ruby/rhc/ssh_helpers.rb
/usr/lib/ruby/vendor_ruby/rhc/tar_gz.rb
/usr/lib/ruby/vendor_ruby/rhc/version.rb
/usr/lib/ruby/vendor_ruby/rhc/wizard.rb
/usr/lib/ruby/vendor_ruby/rhc/auth/basic.rb
/usr/lib/ruby/vendor_ruby/rhc/auth/token.rb
/usr/lib/ruby/vendor_ruby/rhc/auth/token_store.rb
/usr/lib/ruby/vendor_ruby/rhc/auth/x509.rb
/usr/lib/ruby/vendor_ruby/rhc/autocomplete_templates/bash.erb
/usr/lib/ruby/vendor_ruby/rhc/commands/account.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/alias.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/app.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/apps.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/authorization.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/base.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/cartridge.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/deployment.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/domain.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/env.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/git_clone.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/logout.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/member.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/port_forward.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/region.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/scp.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/server.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/setup.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/snapshot.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/ssh.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/sshkey.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/tail.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/team.rb
/usr/lib/ruby/vendor_ruby/rhc/commands/threaddump.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/activation.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/alias.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/api.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/application.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/attributes.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/authorization.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/base.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/cartridge.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/client.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/deployment.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/domain.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/environment_variable.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/gear_group.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/httpclient.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/key.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/membership.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/mock.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/region.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/team.rb
/usr/lib/ruby/vendor_ruby/rhc/rest/user.rb
/usr/lib/ruby/vendor_ruby/rhc/usage_templates/command_help.erb
/usr/lib/ruby/vendor_ruby/rhc/usage_templates/command_syntax_help.erb
/usr/lib/ruby/vendor_ruby/rhc/usage_templates/help.erb
/usr/lib/ruby/vendor_ruby/rhc/usage_templates/missing_help.erb
/usr/lib/ruby/vendor_ruby/rhc/usage_templates/options_help.erb
/usr/lib/ruby/vendor_ruby/rhc/vendor/okjson.rb
/usr/lib/ruby/vendor_ruby/rhc/vendor/parseconfig.rb
/usr/lib/ruby/vendor_ruby/rhc/vendor/sshkey.rb
/usr/lib/ruby/vendor_ruby/rhc/vendor/zliby.rb
/usr/share/doc/rhc/README.md
/usr/share/doc/rhc/changelog.Debian.gz
/usr/share/doc/rhc/copyright
/usr/share/doc/rhc/examples/express.conf
/usr/share/man/man1/rhc.1.gz
/usr/share/man/man5/express.conf.5.gz
/usr/share/rubygems-integration/all/specifications/rhc-1.38.7.gemspec

Changelog

2016-12-30 - Chow Loong Jin <hyperair@debian.org>
rhc (1.38.7-2) unstable; urgency=medium
* [435e09c] Merge changes introduced in 1.38.4-2
* [98a7f6b] Drop upstreamed allow-net-ssh-3.x.patch
2016-08-21 - Chow Loong Jin <hyperair@debian.org>
rhc (1.38.7-1) unstable; urgency=medium
* [2cc6553] Imported Upstream version 1.38.7
* [6426977] Bump Standards-Version to 3.9.8
2016-02-10 - Pirate Praveen <praveen@debian.org>
rhc (1.38.4-2) unstable; urgency=medium
* Team upload
* Allow net-ssh >= 3.0 (Closes: #812910)
2015-11-11 - Chow Loong Jin <hyperair@debian.org>
rhc (1.38.4-1) unstable; urgency=medium
* [2ffd8b2] Imported Upstream version 1.38.4
2015-09-14 - Chow Loong Jin <hyperair@debian.org>
rhc (1.37.1-1) unstable; urgency=medium
* [0847763] Imported Upstream version 1.37.1
2015-07-24 - Chow Loong Jin <hyperair@debian.org>
rhc (1.36.4-1) UNRELEASED; urgency=medium
* [85bd167] Imported Upstream version 1.36.4
2015-06-30 - Antonio Terceiro <terceiro@debian.org>
rhc (1.35.4-3) unstable; urgency=medium
* Team upload
* Update packaging with a new dh-make-ruby run (Closes: #790510)
* Continue skipping test suite
* Drop << dependency restrictions
* Drop >= restrictions on ruby-httpclient dependency
2015-06-29 - Antonio Terceiro <terceiro@debian.org>
rhc (1.35.4-2) unstable; urgency=medium
* Team upload.
* Drop spurious dependency on ruby-rspec (Closes: #790134)
2015-06-15 - Chow Loong Jin <hyperair@debian.org>
rhc (1.35.4-1) unstable; urgency=medium
* [4538d74] Imported Upstream version 1.35.4
2015-04-20 - Chow Loong Jin <hyperair@debian.org>
rhc (1.35.3-1) experimental; urgency=medium
* [c5f1fa6] Imported Upstream version 1.35.3

See Also

Package Description
rheolef-doc_7.0-2_all.deb efficient Finite Element environment - documentation
rheolef_7.0-2+b1_amd64.deb efficient Finite Element environment
rhino_1.7.7.1-1_all.deb JavaScript engine written in Java
rhinote_0.7.4-3_all.deb virtual sticky-notes for your desktop
rhythmbox-ampache_0.11.1+svn43-1_all.deb play audio streams from an Ampache server
rhythmbox-data_3.4.2-4_all.deb data files for rhythmbox
rhythmbox-dev_3.4.2-4_amd64.deb development files for the rhythmbox music player
rhythmbox-doc_3.4.2-4_all.deb documentation files for the rhythmbox music player
rhythmbox-plugin-alternative-toolbar_0.18.1-1_all.deb Enhanced play controls and interface for Rhythmbox
rhythmbox-plugin-cdrecorder_3.4.2-4_amd64.deb burning plugin for rhythmbox music player
rhythmbox-plugins_3.4.2-4_amd64.deb plugins for rhythmbox music player
rhythmbox_3.4.2-4_amd64.deb music player and organizer for GNOME
ri-li-data_2.0.1+ds-7_all.deb toy train simulation game - data files
ri-li_2.0.1+ds-7_amd64.deb toy train simulation game
ri_2.5.1_all.deb Ruby Interactive reference
Advertisement
Advertisement