python3-xapian_1.4.12-2_amd64.deb


Advertisement

Description

python3-xapian - Xapian search engine interface for Python3

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename python3-xapian_1.4.12-2_amd64.deb
Package name python3-xapian
Package version 1.4.12
Package release 2
Package architecture amd64
Package type deb
Category python
Homepage https://xapian.org/
License -
Maintainer Olly Betts <olly@survex.com>
Download size 509.40 KB
Installed size 2.29 MB

Alternatives

Package Version Architecture Repository
python3-xapian_1.4.12-2_i386.deb 1.4.12 i386 Debian Main
python3-xapian - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libstdc++6 >= 5.2
libxapian30 >= 1.4.12~
python3 >= 3.7~
python3 << 3.8
python3:any -

Provides

Name Value
python3.7-xapian -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-xapian_1.4.12-2_amd64.deb
Source Package xapian-bindings

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-xapian deb package:
    # sudo apt-get install python3-xapian

Files

Path
/usr/lib/python3/dist-packages/xapian/__init__.py
/usr/lib/python3/dist-packages/xapian/_xapian.cpython-37m-x86_64-linux-gnu.so
/usr/share/doc-base/xapian-python3-docs
/usr/share/doc/python3-xapian/changelog.Debian.gz
/usr/share/doc/python3-xapian/changelog.gz
/usr/share/doc/python3-xapian/copyright
/usr/share/doc/python3-xapian/examples/simpleexpand.py
/usr/share/doc/python3-xapian/examples/simpleindex.py
/usr/share/doc/python3-xapian/examples/simplematchdecider.py
/usr/share/doc/python3-xapian/examples/simplesearch.py
/usr/share/doc/python3-xapian/html/.buildinfo
/usr/share/doc/python3-xapian/html/examples.html
/usr/share/doc/python3-xapian/html/genindex.html
/usr/share/doc/python3-xapian/html/index.html
/usr/share/doc/python3-xapian/html/introduction.html
/usr/share/doc/python3-xapian/html/objects.inv
/usr/share/doc/python3-xapian/html/search.html
/usr/share/doc/python3-xapian/html/searchindex.js
/usr/share/doc/python3-xapian/html/xapian.html
/usr/share/doc/python3-xapian/html/_sources/examples.rst.txt
/usr/share/doc/python3-xapian/html/_sources/index.rst.txt
/usr/share/doc/python3-xapian/html/_sources/introduction.rst.txt
/usr/share/doc/python3-xapian/html/_sources/xapian.rst.txt
/usr/share/doc/python3-xapian/html/_static/ajax-loader.gif
/usr/share/doc/python3-xapian/html/_static/basic.css
/usr/share/doc/python3-xapian/html/_static/classic.css
/usr/share/doc/python3-xapian/html/_static/comment-bright.png
/usr/share/doc/python3-xapian/html/_static/comment-close.png
/usr/share/doc/python3-xapian/html/_static/comment.png
/usr/share/doc/python3-xapian/html/_static/default.css
/usr/share/doc/python3-xapian/html/_static/doctools.js
/usr/share/doc/python3-xapian/html/_static/documentation_options.js
/usr/share/doc/python3-xapian/html/_static/down-pressed.png
/usr/share/doc/python3-xapian/html/_static/down.png
/usr/share/doc/python3-xapian/html/_static/file.png
/usr/share/doc/python3-xapian/html/_static/jquery.js
/usr/share/doc/python3-xapian/html/_static/language_data.js
/usr/share/doc/python3-xapian/html/_static/minus.png
/usr/share/doc/python3-xapian/html/_static/plus.png
/usr/share/doc/python3-xapian/html/_static/pygments.css
/usr/share/doc/python3-xapian/html/_static/searchtools.js
/usr/share/doc/python3-xapian/html/_static/sidebar.js
/usr/share/doc/python3-xapian/html/_static/underscore.js
/usr/share/doc/python3-xapian/html/_static/up-pressed.png
/usr/share/doc/python3-xapian/html/_static/up.png
/usr/share/doc/python3-xapian/html/_static/websupport.js

Changelog

2019-08-23 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.12-2) unstable; urgency=medium
* debian/patches/ruby2.4-compat.patch: Cherry-pick patch from upstream
to restore compatibility with Ruby 2.4.  Not important for the package
in unstable or buster, but it is for backports to stretch, etc.
2019-08-23 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.12-1) unstable; urgency=medium
* New upstream release
* debian/control.in: Mark conformance with policy 4.4.0.
2019-03-02 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.11-2) unstable; urgency=medium
* debian/control: Needs libxapian-dev (>= 1.4.11) for
Xapian::MSet::SNIPPET_CJK_NGRAM.
2019-03-02 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.11-1) unstable; urgency=medium
* New upstream release
* debian/control.in: Mark conformance with policy 4.3.0.
2019-02-12 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.10-1) unstable; urgency=medium
* New upstream release
* Enable Multi-Arch for Java bindings.
* debian/control.in: Specify "Rules-Requires-Root: no"
2018-11-03 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.9-1) unstable; urgency=medium
* New upstream release
+ debian/patches/php7.3-compat.patch: Included upstream so drop.
2018-10-29 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.8-1) unstable; urgency=medium
* New upstream release
* debian/rules: xapian-core now has a shlibs file so drop hack here to add
versioning to the libxapian dependency.  (Closes: #912105)
* debian/control.in: Mark conformance with policy 4.2.1.
* debian/patches/php7.3-compat.patch: Add patch for PHP 7.3 compatibility.
2018-07-21 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.7-2) unstable; urgency=medium
* debian/control-ruby.in: Correct typo: $${ruby:Versions} -> ${ruby:Versions}
* debian/tests/control: Need default-jdk for the java bindings test.
* debian/tests/control: Add explicit dependencies for tests, so each test
only depends on the bindings it is actually testing.
2018-07-20 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.7-1) unstable; urgency=medium
* New upstream release
* Add autopkgtest which checks that each of bindings can be imported or
equivalent.
* debian/control.in: Mark conformance with policy 4.1.5.
2018-07-03 - Olly Betts <olly@survex.com>
xapian-bindings (1.4.6-1) unstable; urgency=medium
* New upstream release
* debian/rules: Take PHP7_VERSIONS from environment variable if set.
* debian/control.in: Declare conformance with standards-version 4.1.4.
* debian/control.in: Update Vcs-* to point to salsa.d.o.
* Drop "X-Python-Version: 2.3" - Debian oldstable satisfies this requirement
so it's no longer useful.
* debian/ruby-xapian.doc-base: Remove unused wildcard pattern to silence
Lintian error.

See Also

Package Description
python3-xapp_1.6.0-1_all.deb Python 3 XApp library
python3-xarray_0.14.0-1_all.deb N-D labeled arrays and datasets in Python 3
python3-xattr_0.9.6-1_amd64.deb module for manipulating filesystem extended attributes - Python 3
python3-xcffib_0.8.1-0.5_amd64.deb This package is a Python binding for XCB (Python 3)
python3-xdg_0.25-5_all.deb Python 3 library to access freedesktop.org standards
python3-xdmf_3.0+git20190531-1_amd64.deb Python3 wrappers for the eXtensible Data Model and Format library
python3-xdo_0.4-2_all.deb Python 3 library for simulating X11 keyboard/mouse input (libxdo bindings)
python3-xeddsa_0.4.6-1+b1_amd64.deb Python 3 implementation of the XEdDSA signature scheme
python3-xhtml2pdf_0.2.2-3_all.deb A library for converting HTML into PDFs using ReportLab (Python 3 module)
python3-xkcd_2.4.2-3_all.deb Python3 library for accessing xkcd.com
python3-xlib_0.23-2_all.deb interface for Python 3 to the X11 protocol
python3-xlrd_1.1.0-3_all.deb extract data from Microsoft Excel spreadsheet files (Python3 version)
python3-xlsxwriter_1.1.2-0.1_all.deb Python 3 module for creating Excel XLSX files
python3-xlwt_1.3.0-2_all.deb module for writing Microsoft Excel spreadsheet files - Python 3.x
python3-xmltodict_0.11.0-2_all.deb Makes working with XML feel like you are working with JSON (Python 3)
Advertisement
Advertisement