python3-mathgl_2.4.2.1-5_amd64.deb


Advertisement

Description

python3-mathgl - library for scientific graphs (Python v.3 module)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename python3-mathgl_2.4.2.1-5_amd64.deb
Package name python3-mathgl
Package version 2.4.2.1
Package release 5
Package architecture amd64
Package type deb
Category python
Homepage http://mathgl.sourceforge.net/doc_en/Main.html
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 393.86 KB
Installed size 1.98 MB

Alternatives

Package Version Architecture Repository
python3-mathgl_2.4.2.1-5_i386.deb 2.4.2.1 i386 Debian Main
python3-mathgl - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libgif7 >= 5.1
libgl1 -
libglu1 -
libglu1-mesa -
libgsl23 >= 2.5
libgslcblas0 >= 2.4
libhdf4-0 >= 4.1r2
libhdf5-103 -
libhpdf-2.3.0 >= 2.3.0
libjpeg62-turbo >= 1.3.1
libltdl7 >= 2.4.6
libmgl7.5.0 -
libpng16-16 >= 1.6.2-1
libpython3.7 >= 3.7.0
libstdc++6 >= 5
libsz2 -
python3 -
python3-numpy >= 1:1.14.3
python3-numpy-abi9 -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package python3-mathgl_2.4.2.1-5_amd64.deb
Source Package mathgl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python3-mathgl deb package:
    # sudo apt-get install python3-mathgl

Files

Path
/usr/lib/python3/dist-packages/_mathglp3.so
/usr/lib/python3/dist-packages/mathgl.py
/usr/share/doc/python3-mathgl/changelog.Debian.gz
/usr/share/doc/python3-mathgl/changelog.gz
/usr/share/doc/python3-mathgl/copyright

Changelog

2018-12-04 - Dimitrios Eftaxiopoulos <eftaxi12@otenet.gr>
mathgl (2.4.2.1-5) unstable; urgency=medium
* Try to fix FTBFS on mips and mipsel arches (Closes: #915506)
2018-11-25 - Dimitrios Eftaxiopoulos <eftaxi12@otenet.gr>
mathgl (2.4.2.1-4) unstable; urgency=medium
[ Jelmer Vernooń≥ ]
* Trim trailing whitespace. Fixed-Lintian-Tags:
file-contains-trailing-whitespace
* Use secure copyright file specification URI. Fixed-Lintian-Tags:
insecure-copyright-format-uri
[ Dimitrios Eftaxiopoulos ]
* Restrict qtwebengine5-dev B-D to the arches where it is available
(Closes: #914585)
2018-11-01 - Alastair McKinstry <mckinstry@debian.org>
mathgl (2.4.2.1-3) unstable; urgency=medium
* Fix FTBFS with python3.7. Closes: #912590
2018-06-23 - Dimitrios Eftaxiopoulos <eftaxi12@otenet.gr>
mathgl (2.4.2.1-2) unstable; urgency=medium
* Add qtwebengine5-dev to Build-Depends due to the output of cmake
* Update standards version to 4.1.4
* Add Replaces/Conflicts for libmgl-*7.4.1 library packages
* Provide both python2 and python3 modules, using patch from Fedora project
* Mark libmgl-data as Multi-Arch: foreign (Closes: #897619)
2018-04-04 - Dimitrios Eftaxiopoulos <eftaxi12@otenet.gr>
mathgl (2.4.2.1-1) unstable; urgency=medium
* New upstream version 2.4.2.1
2018-04-03 - Dimitrios Eftaxiopoulos <eftaxi12@otenet.gr>
mathgl (2.4.2-1) unstable; urgency=medium
* New upstream version 2.4.2
* Remove M-A header from libmgl7.5.0 library (Closes: #872205)
* Refresh patch CMakeLists.patch
* Remove no more needed patches fix_hdf5.patch and pthread-fix.patch
* Update Standards-Version to current Policy version 4.1.3
* Update Vcs fields so that they point to salsa.d.o in d/control
* Update debhelper version and compat level to 11
2017-08-02 - Alastair McKinstry <mckinstry@debian.org>
mathgl (2.4.1-2) unstable; urgency=medium
* Push to unstable. Closes: #868622
2017-08-01 - Alastair McKinstry <mckinstry@debian.org>
mathgl (2.4.1-1) experimental; urgency=medium
* New upstream release
* Remove spurious build-dependency on libtwebkit-dev. Closes: #867297
2017-06-28 - Alastair McKinstry <mckinstry@debian.org>
mathgl (2.4-1) unstable; urgency=medium
* New upstream release
* Library version numbers updated to soname 7.4.1->7.5.0
* Standards-Version: 4.0.0
* Set libmgl-data as M-A: foreign
* Added myself as uploader
2016-09-12 - Alastair McKinstry <mckinstry@debian.org>
mathgl (2.3.4-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix from Bas  Couwenberg for HDF5 build issue. Closes: #835680

See Also

Package Description
python3-matplotlib-venn_0.11.5-5_all.deb Python 3 plotting area-proportional two- and three-way Venn diagrams
python3-matplotlib_3.0.2-2_amd64.deb Python based plotting system in a style similar to Matlab (Python 3)
python3-maxminddb_1.4.1-1_amd64.deb Python 3 module for reading the MaxMind DB format
python3-mbed-host-tests-doc_1.4.4-1_all.deb module and utilities to flash, reset and test Mbed Enabled devices (docs)
python3-mbed-host-tests_1.4.4-1_all.deb module and utilities to flash, reset and test Mbed Enabled devices
python3-mbed-ls-doc_1.6.2+dfsg-1_all.deb mbed-ls library documentation
python3-mbed-ls_1.6.2+dfsg-1_all.deb module listing mbed-enabled devices connected to host (Python 3)
python3-mccabe_0.6.1-2_all.deb Python code complexity checker (Python 3)
python3-mdp_3.5-1_all.deb Modular toolkit for Data Processing
python3-mdx-math_0.6-1_all.deb math extension for Python-Markdown
python3-measurement_2.0.1-1_all.deb unit-aware measurement objects (Python3 version)
python3-mecavideo_6.5.1-1_all.deb pedagogic tool to analyze video records for mechanics
python3-mechanicalsoup_0.10.0-2_all.deb library for automating interaction with websites (Python 3)
python3-med_4.0.0+repack-7_amd64.deb python3 API for MED-fichier
python3-mediainfodll_18.12-1_all.deb library for reading metadata from media files -- shared library
Advertisement
Advertisement