python-fabio_0.5.0+dfsg-2_amd64.deb


Advertisement

Description

python-fabio - I/O library for images produced by 2D X-ray detector - Python2

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: python-fabio
Package version: 0.5.0+dfsg
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 1.66 KB
Download size: 337.44 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: python-fabio

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-fabio deb package:
      # sudo apt-get install python-fabio

    Changelog

    2017-09-20 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.5.0+dfsg-2) unstable; urgency=medium * d/control - python-qt4 -> python3-pyqt4-dbg (Closes: #876288)

    2017-09-02 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.5.0+dfsg-1) unstable; urgency=medium * New upstream version 0.5.0+dfsg * switch to compat level 10 * d/control - fabio-viewer scripts python2 -> python3 - Bump Standard-Versions to 4.1.0 (extra -> optional) - cme fixed - wrap-and-sort - Build-Depends + Added help2man, python[3]-h5py[-dbg], python[3]-matplotlib[-dbg], python-pil[-dbg], python-qt4|dbg], python3-pyqt4[-dbg], xauth, xvfb - Removed python-imaging[-dbg] * d/copyright - updated the Files-excludes for 0.5.0 - Setting up and using cme upgrade dpkg-copyright * d/patch - Added 0001-do-not-touch-PYTHONPATH.patch - Added 0002-fix-the-install_requires-depends.patch * d/rules - Used xvfb to generate the manpages

    2016-07-28 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.4.0+dfsg-2) unstable; urgency=medium * debian/rules * fixed for jessie-backports

    2016-07-27 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.4.0+dfsg-1) unstable; urgency=medium * Imported Upstream version 0.4.0+dfsg * New homepage https://github.com/silx-kit/fabio * debian/control * Remove Build-Dep: pymca * debian/patchs - 0001-fix-the-documentation-build-process.patch (deleted) + 0002 -> 0001-fix-upstream-wrong-six-import.patch (refreshed)

    2016-01-04 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.3.0+dfsg-1) unstable; urgency=medium * Imported Upstream version 0.3.0+dfsg * debian/patchs - 0001-fix-the-build-system.patch (removed) + 0001-fix-the-documentation-build-process.patch (added) + 0002-fix-upstream-wrong-six-import.patch (added)

    2015-09-29 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.2.2+dfsg-3) unstable; urgency=medium * debian/control - fix Dependency to deal with backports (0.2.2+dfsg-2 -> 0.2.2+dfsg-2~) - remove the circular dependency (Closes: #794153) (python-fabio only Recommends fabio-viewer)

    2015-07-27 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.2.2+dfsg-2) unstable; urgency=medium * Add python3 modules and put the scripts into fabio-viewer

    2015-07-22 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.2.2+dfsg-1) unstable; urgency=medium * Imported Upstream version 0.2.2+dfsg * Repack in order to exclude third_party modules * debian/control - Bump Standard-Versions to 3.9.6 (no change) - Add Build-Depends: python-six, pymca, python-sphinxcontrib.programoutput * debian/patchs - 0001-fix-the-build-system.patch (added) * debian/watch - use the PyPi redirector

    2014-04-05 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.1.4-1) unstable; urgency=medium * Imported Upstream version 0.1.4 (Closes: #735432, #693121) * Run all tests during the build (thanks to pybuild) * debian/control - Add Build-Depends: dh-python for pybuild * debian/compat - switch to compat level 9 * debian/copyright - updated for 0.1.4 version * debian/patchs - deleted (applyed by upstream) - 0001-forwarded-upstream-cythonize-during-the-build.patch - 0002-compat_2.5.patch * debian/rules - use the pybuild buildsystem * debian/watch - use the sourceforge redirector

    2014-01-15 - Picca Frédéric-Emmanuel <picca@debian.org> python-fabio (0.1.3-3) unstable; urgency=medium * fix the FTBFS when sphinxdoc is not installed

    Advertisement
    Advertisement