python-dtcwt_0.12.0-1_all.deb


Advertisement

Description

python-dtcwt - Dual-Tree Complex Wavelet Transform library for Python 2

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: python-dtcwt
Package version: 0.12.0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 349 B
Download size: 52.38 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: python-dtcwt

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-dtcwt deb package:
      # sudo apt-get install python-dtcwt

    Changelog

    2017-09-15 - Ghislain Antony Vaillant <ghisvail@gmail.com> python-dtcwt (0.12.0-1) unstable; urgency=medium * Sign tags on gbp import * Upgrade watch file to version 4 * New upstream version 0.12.0 * Drop superfluous Testsuite field * Bump debhelper version to 10 * Move pyopencl dependency to Suggests * Fixup the upstream name in copyright * Update the copyright dates * Update the BSD-2-Clause paragraph * Update the binary package descriptions * Fixup the proxy settings for the docs * Add new dependency on the Sphinx RTD theme * Build the docs with Python 3 * Add support for the nodoc build profile * Add the Build-Using metadata for the docs * Add recommended get-orig-source target * Simplify integration with the system MathJax - Hardcode the path to MathJax in conf.py - Drop the .links file, no longer required - Drop dh_sphinxdoc override, no longer required * Add new test dependency on scipy * Add support for the nocheck build profile * Run autopkgtests for all supported Python versions * Bump standards version to 4.1.0

    2016-08-03 - Ghislain Antony Vaillant <ghisvail@gmail.com> python-dtcwt (0.11.0-2) unstable; urgency=medium * Make build reproducible. * Simplify packaging testsuite using Test-Command. * cme fix dpkg-control: - Drop unnecessary versioned dependency on sphinx. - Bump standards version to 3.9.8, no changes required.

    2016-03-10 - Ghislain Antony Vaillant <ghisvail@gmail.com> python-dtcwt (0.11.0-1) unstable; urgency=medium * New upstream release. * DFSG cleaning is no longer required: - d/copyright: remove Files-Excluded entry. - d/gbp.conf: synchronise with upstream master branch and tags. - d/watch: remove repacksuffix option. * Update patch queue: - Refresh use-system-mathjax.patch and reproducible-build.patch. - Drop Fix-usage-of-unsafe-inplace-casting.patch, applied upstream. - Drop Use-explicit-integer-division.patch, applied upstream. * d/{control,tests/*}: replace dependency on nose with pytest. * d/gbp.conf: switch to DEP-14 repository layout.

    2016-03-08 - Ghislain Antony Vaillant <ghisvail@gmail.com> python-dtcwt (0.10.1+dfsg1-4) unstable; urgency=medium * Clean documentation build and egg-info directories. * Add patch fixing runtime failure with Python 3. File: Use-explicit-integer-division.patch * Bump standards version to 3.9.7, no changes required. * d/watch: add missing repacksuffix option.

    2016-01-27 - Ghislain Antony Vaillant <ghisvail@gmail.com> python-dtcwt (0.10.1+dfsg1-3) unstable; urgency=medium * d/control: use secure VCS-Git URI. * d/rules: simplify doc install targets. * d/rules: remove test override, use pybuild instead. * Add patch fixing an FTBFS error in the testsuite. File: Fix-usage-of-unsafe-inplace-casting.patch * Add autopkgtest testsuite. * d/control: move dependency on pyopencl to Recommends. * d/control: cme fixed.

    2015-08-08 - Ghislain Antony Vaillant <ghisvail@gmail.com> python-dtcwt (0.10.1+dfsg1-2) unstable; urgency=medium * Make build reproducible. (Closes: #794005) Thanks to Chris Lamb for providing the patch.

    2015-07-20 - Ghislain Antony Vaillant <ghisvail@gmail.com> python-dtcwt (0.10.1+dfsg1-1) unstable; urgency=low * Initial release (Closes: #793139)

    Advertisement
    Advertisement