python-brian-lib_1.4.3-1_amd64.deb


Advertisement

Description

python-brian-lib - simulator for spiking neural networks -- extensions

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name python-brian-lib
Package version 1.4.3
Package release 1
Package architecture amd64
Package type deb
Installed size 159 B
Download size 39.74 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
python-brian-lib_1.4.3-1~nd+1_i386.deb 1.4.3 i386 NeuroDebian Main
python-brian-lib_1.4.3-1~nd+1_amd64.deb 1.4.3 amd64 NeuroDebian Main
python-brian-lib_1.4.3-1_i386.deb 1.4.3 i386 Debian Main
python-brian-lib - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libstdc++6 >= 5.2
python >= 2.7~
python << 2.8
python-numpy >= 1:1.10.0~b1
python-numpy-abi9 -

Download

Type URL
Binary Package python-brian-lib_1.4.3-1_amd64.deb
Source Package brian

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-brian-lib deb package:
    # sudo apt-get install python-brian-lib

Files

Path
/usr/lib/python2.7/dist-packages/brian/utils/ccircular/_ccircular.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/brian/utils/fastexp/_fastexp.x86_64-linux-gnu.so
/usr/share/doc/python-brian-lib/changelog.Debian.gz
/usr/share/doc/python-brian-lib/copyright

Changelog

2016-02-16 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.4.3-1) unstable; urgency=medium
* New upstream minor release
- compatible with recent matplotlib (Closes: #811354)
* debian/copyright
- adjusted years and for BSD-3-clause
2015-08-21 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.4.1-3) unstable; urgency=medium
* Deprecate python-support (Closes: #785971)
* Fix timestamp for sphinx based on the changelog.  Thanks Juan Picca for
the report and the patch (Closes: #788393)
* Moved debian/upstream to debian/upstream/metadata
* Policy boost to 3.9.6 (no changes)
* Tuned up debian/copyright
2014-07-30 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.4.1-2) unstable; urgency=medium
* Forgotten upload to unstable
* debian/control
- policy boost to 3.9.5
- updated Vcs- fields given migration to anonscm.d.o and provided -b
debian
2013-04-30 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.4.1-1) experimental; urgency=low
* New upstream release
- absorbed/addressed all non deb_* patches
* debian/rules
- set http_proxy to avoid undesired network accesses
- prefixed with 'set -e' all 'for' loops to guarantee failure if any fails
- set env variable BRIAN_SETUP_FAIL_ON_ERROR
2012-08-30 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.4.0-1) experimental; urgency=low
* Fresh upstream release
* debian/patches:
- added up_examples_shebangs patch to address lintian warnings on
executable non-scripts
- refreshed build_extensions patch to build extensions (assuming now
that numpy is present)
- cherry-picked 0001-C-version-of-SpikeContainer-now-picklable.patch to
resolve pickling of swig'ed objects
* debian/control:
- boosted policy to 3.9.3 (no further changes)
- removed not needed XS-DM-Upload-Allowed
* debian/copyright:
- DEP5 v.1.0 compliant now
- moved references into debian/upstream
2012-01-02 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.3.1-1) unstable; urgency=low
* Fresh upstream release
* Boosted policy compliance to 3.9.2 (no changes)
* Added up_skip_tests_with_paths patch to avoid test failures on custom 
test scripts with hardcoded paths
2011-04-06 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.3.0-2) unstable; urgency=low
* Restrict numpy versioned dependency only to -lib package. Thanks Jakub
Wilk
2011-02-19 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.3.0-1) unstable; urgency=low
* Fresh upstream release
* Suggest cherrypy and build-depend on dvipng
2011-02-08 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.2.2~svn2469-1) unstable; urgency=low
* Upstream pre-release snapshot
* debian/copyright - fixed Maintainer and Source entries
* debian/rules:
- set both HOME and MPLCONFIGDIR to point to build/.
Should resolve issues of building when $HOME is read-only
(Closes: #612548)
- assure Agg matplotlib backend to avoid possible complications
during off-screen operations
- un-disabled hears unittests (model-fitting remains disabled due
to absent dependency -- playdoh)
* debian/control:
- graphviz (for graphs rendering) and texlive-latex-base,
texlive-latex-extra (for equations rendering) into build-depends
2010-11-02 - Yaroslav Halchenko <debian@onerussian.com>
brian (1.2.2~svn2229-1) unstable; urgency=low
* Initial release (Closes: #602246)

See Also

Package Description
python-brian_1.4.3-1_all.deb simulator for spiking neural networks
python-brlapi_5.6-5_amd64.deb Braille display access via BRLTTY - Python bindings
python-broccoli_0.62-1_amd64.deb Python bindings for Broccoli
python-brotli_1.0.5-2_amd64.deb lossless compression algorithm and format (Python 2 version)
python-bs4-doc_4.6.1-1_all.deb error-tolerant HTML parser for Python - documentation
python-bs4_4.6.1-1_all.deb error-tolerant HTML parser for Python
python-bsddb3-doc_6.2.6-2_all.deb Documentation for the python Berkeley DB interface module
python-bsddb3_6.2.6-2_amd64.deb Python interface for Berkeley DB
python-bson-ext_3.6.1+dfsg1-1+b1_amd64.deb C-coded extension to the python-bson package
python-bson_3.6.1+dfsg1-1+b1_amd64.deb Python implementation of BSON for MongoDB
python-btchip_0.1.24-1_all.deb Python library to communicate with BTChip dongle
python-btrees-doc_4.3.1-1_all.deb scalable persistent object containers for Python - documentation
python-btrees_4.3.1-1+b2_amd64.deb scalable persistent object containers for Python
python-buffy_0.16+b5_amd64.deb Python wrapper for the libbuffy library
python-bugzilla_2.1.0-1_all.deb Python library for interacting with Bugzilla (Python 2)
Advertisement
Advertisement