puppet-module-openstacklib_13.1.0-2_all.deb


Advertisement

Description

puppet-module-openstacklib - exposes common functionality between Openstack modules as a library

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name puppet-module-openstacklib
Package version 13.1.0
Package release 2
Package architecture all
Package type deb
Installed size 117 B
Download size 20.71 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
puppet-module-openstacklib_13.1.0-2_all.deb 13.1.0 all Debian Main
puppet-module-openstacklib - - -

Requires

Name Value
puppet-common -
puppet-module-puppetlabs-apache -
puppet-module-puppetlabs-inifile -
puppet-module-puppetlabs-mysql -
puppet-module-puppetlabs-postgresql -
puppet-module-puppetlabs-rabbitmq -
puppet-module-puppetlabs-stdlib -

Download

Type URL
Binary Package puppet-module-openstacklib_13.1.0-2_all.deb
Source Package puppet-module-openstacklib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install puppet-module-openstacklib deb package:
    # sudo apt-get install puppet-module-openstacklib

Files

Path
/etc/facter/facts.d/os_service_default.txt
/usr/share/doc/puppet-module-openstacklib/changelog.Debian.gz
/usr/share/doc/puppet-module-openstacklib/changelog.gz
/usr/share/doc/puppet-module-openstacklib/copyright
/usr/share/doc/puppet-module-openstacklib/examples/virtual_packages.pp
/usr/share/puppet/modules.available/openstacklib/metadata.json
/usr/share/puppet/modules.available/openstacklib/lib/facter/os_package_type.rb
/usr/share/puppet/modules.available/openstacklib/lib/facter/os_service_default.rb
/usr/share/puppet/modules.available/openstacklib/lib/facter/os_workers.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/parser/functions/is_service_default.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/parser/functions/normalize_ip_for_uri.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/parser/functions/os_database_connection.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/parser/functions/os_transport_url.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/provider/openstack.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/provider/openstack/auth.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/provider/openstack/credentials.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/provider/openstack_config/ini_setting.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/provider/openstack_config/ruby.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/provider/policy_rcd/policy_rcd.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/type/openstack_config.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/type/policy_rcd.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/util/openstackconfig.rb
/usr/share/puppet/modules.available/openstacklib/lib/puppet/util/openstackconfig/section.rb
/usr/share/puppet/modules.available/openstacklib/manifests/defaults.pp
/usr/share/puppet/modules.available/openstacklib/manifests/openstackclient.pp
/usr/share/puppet/modules.available/openstacklib/manifests/policy.pp
/usr/share/puppet/modules.available/openstacklib/manifests/policyrcd.pp
/usr/share/puppet/modules.available/openstacklib/manifests/service_validation.pp
/usr/share/puppet/modules.available/openstacklib/manifests/db/mysql.pp
/usr/share/puppet/modules.available/openstacklib/manifests/db/postgresql.pp
/usr/share/puppet/modules.available/openstacklib/manifests/db/mysql/host_access.pp
/usr/share/puppet/modules.available/openstacklib/manifests/messaging/rabbitmq.pp
/usr/share/puppet/modules.available/openstacklib/manifests/policy/base.pp
/usr/share/puppet/modules.available/openstacklib/manifests/wsgi/apache.pp

Changelog

2018-07-09 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (13.1.0-2) unstable; urgency=medium
* Fixed wrong maintainer email.
2018-06-16 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (13.1.0-1) unstable; urgency=medium
* New upstream release.
* Use team+openstack@debian.org for maintainer.
2018-03-20 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (12.3.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/rules: Changed UPSTREAM_GIT protocol to https
* d/copyright: Changed source URL to https protocol
* d/control: Set Vcs-* to salsa.debian.org
[ Daniel Baumann ]
* Updating copyright format url.
* Updating maintainer field.
* Running wrap-and-sort -bast.
* Removing gbp.conf, not used anymore or should be specified in the
developers dotfiles.
* Correcting permissions in debian packaging files.
* Deprecating priority extra as per policy 4.0.1.
[ Thomas Goirand ]
* New upstream release.
* Push facts.d/os_service_default.txt into /etc/facter/facts.d.
2016-10-21 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (9.4.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* d/rules: Changed UPSTREAM_GIT protocol to https
* d/copyright: Changed source URL to https protocol
[ Thomas Goirand ]
* New upstream release.
2016-04-29 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (8.0.0-3) unstable; urgency=medium
[ Ondřej Nový ]
* Standards-Version is 3.9.8 now (no change)
[ Thomas Goirand ]
* Fixed missing runtime depends.
2016-04-06 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (8.0.0-2) unstable; urgency=medium
* Added missing build-depends.
2016-04-06 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (8.0.0-1) unstable; urgency=medium
* New upstream release.
* Uploading to unstable.
* Overrides dh_auto_build and dh_auto_install.
2016-03-09 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (8.0.0~b1-1) experimental; urgency=medium
* New upstream release.
* Standards-Version: 3.9.7 (no change).
2016-02-09 - Thomas Goirand <zigo@debian.org>
puppet-module-openstacklib (7.0.0-1) unstable; urgency=medium
* Initial release. (Closes: #814215)

See Also

Package Description
puppet-module-oslo_13.1.0-1_all.deb Puppet module for OpenStack oslo lib using components
puppet-module-ovn_13.1.0-1_all.deb Puppet module for OpenStack OVN
puppet-module-panko_13.3.1-1_all.deb Puppet module for OpenStack Panko
puppet-module-puppet-archive_3.2.1-1_all.deb Puppet module to manages download, and cleanup of archive files
puppet-module-puppet-community-mcollective_0.6.2-3_all.deb Puppet module for mcollective to handle and install clusters
puppet-module-puppetlabs-apache_3.4.0-1_all.deb Puppet module for Apache
puppet-module-puppetlabs-apt_6.1.1-1_all.deb Puppet module for apt
puppet-module-puppetlabs-concat_5.1.0-1_all.deb Puppet module for concat
puppet-module-puppetlabs-firewall_1.12.0-1_all.deb Puppet module for Firewall management
puppet-module-puppetlabs-haproxy_2.1.0-1_all.deb Puppet module for HAProxy
puppet-module-puppetlabs-inifile_2.2.1-1_all.deb Puppet module for ini files
puppet-module-puppetlabs-mongodb_0.7.0-2_all.deb Puppet module for managing mongodb installation and configuration
puppet-module-puppetlabs-mysql_5.3.0-1_all.deb Puppet module for MySQL
puppet-module-puppetlabs-ntp_7.2.0-1_all.deb Puppet module for ntp
puppet-module-puppetlabs-postgresql_5.4.0-1_all.deb Puppet module for PostgreSQL database
Advertisement
Advertisement