proguard_5.3.3-1_all.deb


Advertisement

Description

proguard - Java class file shrinker, optimizer, and obfuscator

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: proguard
Package version: 5.3.3
Package release: 1
Package architecture: all
Package type: deb
Installed size: 12 B
Download size: 4.63 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Binary package: proguard_5.3.3-1_all.deb
    Source package: proguard

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install proguard deb package:
      # sudo apt-get install proguard

    Changelog

    2017-09-14 - Emmanuel Bourg <ebourg@apache.org> proguard (5.3.3-1) unstable; urgency=medium * Team upload. * New upstream release * Standards-Version updated to 4.1.0

    2016-12-12 - Emmanuel Bourg <ebourg@apache.org> proguard (5.3.2-1) unstable; urgency=medium * Team upload. * New upstream release * Packaged the library, the CLI and the GUI separately (Closes: #840317, #846463) * Modified the usage message for the command line tool

    2016-10-29 - Emmanuel Bourg <ebourg@apache.org> proguard (5.3.1-1) unstable; urgency=medium * Team upload. * New upstream release * Switch to debhelper level 10

    2016-09-23 - Emmanuel Bourg <ebourg@apache.org> proguard (5.3-1) unstable; urgency=medium * Team upload. * New upstream release * Build with Gradle instead of Ant * No longer use a patch to add the shell scripts * Relocate the proguard-gradle jar to the all in one jar to avoid duplicating the files

    2016-05-16 - Emmanuel Bourg <ebourg@apache.org> proguard (5.2.1-4) unstable; urgency=medium * Team upload. * Fixed the build failure caused by the switch from groovy2 to groovy (Closes: #823587) * Standards-Version updated to 3.9.8 (no changes)

    2016-02-06 - Markus Koschany <apo@debian.org> proguard (5.2.1-3) unstable; urgency=medium * Team upload. * wrap-and-sort -sa. * Switch from cdbs to dh sequencer. * Declare compliance with Debian Policy 3.9.7. * Build with maven-repo-helper and install proguard-gradle and proguard-base artifact. * Add debian/proguard.poms. * Update debian/copyright to copyright format 1.0.

    2015-10-27 - Kai-Chung Yan <seamlikok@gmail.com> proguard (5.2.1-2) unstable; urgency=medium * Team upload. * enable_building_of_gradle_task.patch: Remove Gradle JARs version

    2015-08-31 - komal Sukhani <komaldsukhani@gmail.com> proguard (5.2.1-1) unstable; urgency=medium * Team upload * New upstream release * Add new patches - correct_properties_file_path - enable_building_of_gradle_task * Add gradle package in build depends * d/control: Switch Vcs-Browser field to cgit

    2014-08-21 - Emmanuel Bourg <ebourg@apache.org> proguard (5.0-1) unstable; urgency=medium * Team upload. * New upstream release (Closes: #754964) - Increased the source/target level to 1.5 - Depend on java5-runtime instead of java2-runtime

    2014-04-10 - Emmanuel Bourg <ebourg@apache.org> proguard (4.11-1) unstable; urgency=medium * Team upload. * New upstream release * Removed the non-free documentation from the package (Closes: #719706) * Removed the pre-built jars from the upstream tarball * debian/control: - The package is now co-maintained with the Java Team - Standards-Version updated to 3.9.5 (no changes) - Added the Vcs-* fields - Added the Homepage field * Switch to debhelper level 9 * Use XZ compression for the upstream tarball

    Advertisement
    Advertisement