packagekit-command-not-found_1.1.12-5+b1_amd64.deb


Advertisement

Description

packagekit-command-not-found - Offer to install missing programs automatically

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename packagekit-command-not-found_1.1.12-5+b1_amd64.deb
Package name packagekit-command-not-found
Package version 1.1.12
Package release 5+b1
Package architecture amd64
Package type deb
Category misc
Homepage https://www.freedesktop.org/software/PackageKit/
License -
Maintainer Matthias Klumpp <mak@debian.org>
Download size 30.89 KB
Installed size 78.00 KB

Alternatives

Package Version Architecture Repository
packagekit-command-not-found_1.1.12-5+b1_i386.deb 1.1.12 i386 Debian Main
packagekit-command-not-found - - -

Requires

Name Value
libc6 >= 2.7
libglib2.0-0 >= 2.46
libpackagekit-glib2-18 >= 1.1.9
packagekit = 1.1.12-5+b1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package packagekit-command-not-found_1.1.12-5+b1_amd64.deb
Source Package packagekit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install packagekit-command-not-found deb package:
    # sudo apt-get install packagekit-command-not-found

Files

Path
/etc/PackageKit/CommandNotFound.conf
/etc/profile.d/PackageKit.sh
/usr/lib/packagekit/pk-command-not-found
/usr/share/doc/packagekit-command-not-found/changelog.Debian.amd64.gz
/usr/share/doc/packagekit-command-not-found/changelog.Debian.gz
/usr/share/doc/packagekit-command-not-found/copyright

Changelog

2019-03-02 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-5) unstable; urgency=medium
* Fix FTBFS on !amd64 architectures by removing the
GTK+2 plugin properly.
2019-03-02 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-4) unstable; urgency=medium
* Add aptcc-frontend-locking.patch
- This implements APT frontend locking, which prevents other programs
from stealing the dpkg lock in race conditions where apt(cc) has to
release the lock in order to run dpkg.
2019-03-01 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-3) unstable; urgency=medium
* Do not ship the GTK+2 plugin (Closes: #922118)
- Unfortunately we still need to build-depend on GTK+2 to
enable the GTK plugin build.
2019-02-26 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-2) unstable; urgency=medium
[ Matthias Klumpp ]
* Remove Ubuntu-specific patch series, handle vendor config by
conditionally installing it in d/rules (Closes: #915352)
* Add no-distupgrade.patch:
- Disable GetDistroUpgrades() completely, it was partially
disabled before but still caused problems.
* Add keep-ref-on-transaction-while-doing-polkit-call.patch
- Avoids some log spam
[ Andrew Hayzen ]
* Add aptcc-use-correct-return-type-in-function.patch:
- Fix function return type, which resolves packagekitd crash
when gnome-software launches, causing gnome-software to hang
(Closes: #917812, #922236)
2018-12-22 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.12-1) unstable; urgency=medium
* New upstream version: 1.1.12
- Applied aptcc patches carried in Debian
- common: Handle quoted strings in /etc/os-release
- offline update: Fix translations to show up
* Drop aptcc patches: Applied upstream
2018-10-15 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.11-1) unstable; urgency=medium
* New upstream version: 1.1.11
* Never restart packagekitd via systemd after an upgrade of the daemon
* Add aptcc-always-do-multiarch-lookups.patch
- Always check multi-arch paths for .list files, as dpkg always adds the
architecture, even on non-multiarch systems.
* Add aptcc-update-section-mappings.patch
- Updates aptcc section mappings (Closes: #880484)
* Bump standards version: No changes needed
* Mark packagekit-docs as MA-foreign
2018-04-23 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.10-1) unstable; urgency=high
* New upstream release: 1.1.10
- This release fixes CVE-2018-1106 (Closes: #896703)
- aptcc: Not all downloads have to be packages
- aptcc: Return multiple packages when using '|' operator
- aptcc: Simplify search methods
* Bump standards version: No changes needed
* Update Vcs-* URLs to point to Salsa
* Use auth_admin instead of auth_admin_keep as default authorization
for downgrades and package removals.
2018-03-12 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.9-1) unstable; urgency=medium
* New upstream version: 1.1.9
* Drop patches: Applied upstream
* Adjust for dh compat level 11
* Update symbols file
* d/watch: Use https URL
* d/rules: Drop obsolete dh modules
2017-09-24 - Matthias Klumpp <mak@debian.org>
packagekit (1.1.7-1) unstable; urgency=medium
[ Matthias Klumpp ]
* New upstream version: 1.1.7
* Drop all patches: Applied upstream
* Add aptcc-fix-mimetype-search.patch: Don't fail when searching for mimetypes
- See LP: #1719077
* Bump standards and dh version
* Fail on missing files
* Add missing build-dependency on libappstream-dev
[ Iain Lane ]
* Always rebuild gtk-doc documentation

See Also

Package Description
packagekit-docs_1.1.12-5_all.deb Documentation for PackageKit
packagekit-gtk3-module_1.1.12-5+b1_amd64.deb Install fonts automatically using PackageKit
packagekit-tools_1.1.12-5+b1_amd64.deb Provides PackageKit command-line tools
packagekit_1.1.12-5+b1_amd64.deb Provides a package management service
packagesearch_2.7.11_amd64.deb GUI for searching packages and viewing package information
packaging-dev_0.8_all.deb convenient tools to develop packages
packaging-tutorial_0.24_all.deb introduction to Debian packaging
packer_1.3.4+dfsg-4+b1_amd64.deb tool for creating machine images for multiple platforms
packeth_1.6.5-2+b2_amd64.deb Ethernet packet generator
packit_1.6.1-2_amd64.deb network packet generator and capture tool
packup_0.6-3_amd64.deb CUDF solver based on pseudo-Boolean constraints
pacman4console_1.3-1+b4_amd64.deb ncurses-based pacman game
pacman_10-17.2+b2_amd64.deb Chase Monsters in a Labyrinth
paco_0.10-1.1_all.deb Transitional package to pull in porg
pacpl_6.1.0-1_all.deb multi-purpose audio converter/ripper/tagger script
Advertisement
Advertisement