ocaml-libs_3.12.0.1_all.deb


Advertisement

Description

ocaml-libs - OCaml core libraries (metapackage)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename ocaml-libs_3.12.0.1_all.deb
Package name ocaml-libs
Package version 3.12.0.1
Package release -
Package architecture all
Package type deb
Category devel::lang:ocaml devel::library implemented-in::ocaml ocaml role::devel-lib role::metapackage
Homepage -
License -
Maintainer Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Download size 4.14 KB
Installed size 4.00 KB

Alternatives

Package Version Architecture Repository
ocaml-libs_3.12.0.1_all.deb 3.12.0.1 all Debian Main
ocaml-libs - - -

Requires

Name Value
libextlib-ocaml-dev -
liblablgtk2-ocaml-dev -
libocamlnet-ocaml-dev -
libpcre-ocaml-dev -
libpxp-ocaml-dev -
libzip-ocaml-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ocaml-libs_3.12.0.1_all.deb
Source Package meta-ocaml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ocaml-libs deb package:
    # sudo apt-get install ocaml-libs

Files

Path
/usr/share/doc/ocaml-libs/changelog.gz
/usr/share/doc/ocaml-libs/copyright

Changelog

2011-10-08 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.12.0.1) unstable; urgency=low
* fix vcs-svn field to point just above the debian/ dir
* major overhaul of Depends/Recommends/Suggests relationships, "toning down"
dependencies so that installation of ocaml-core is more flexible to
changes (Closes: #500959) 
* debian/control
- bump Standards-Version to 3.9.2 (no changes)
- bump debhelper deps and compatibilitiy to 8
- add missing ${misc:Depends}
* debian/rules: convert to minimal dh style
* remove myself from Uploaders
2007-09-18 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.10.0.1) unstable; urgency=low
[Julien Cristau]
* Remove inactive people from the Uploaders field.
[Ralf Treinen]
* Added dependency on cmigrep and ocamlmakefile
* Minor modification to long description (closes: #416872)
[Stefano Zacchiroli]
* bump debhelper dep and compatibility level to 5
* debian/control
- remove dep on netclient (now shipped by ocamlnet)
- remove dep on ocamldbi (not very user/active)
- add dep on camlp4 and camlp4-extra (now shipped separately)
2006-06-16 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.09.2.0) unstable; urgency=low
* new release with version number in sync with the latest ocaml
* debian/control
- bumped standards version to 3.7.2 (no changes needed)
- set debhelper as a Build-Depends instead of a Build-Depends-Indep
(as required by policy)
- better caseness in descriptions
* debian/copyright
- updated FSF address
- new URL where to found the source code of this meta package
2004-08-05 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.08.0.2) unstable; urgency=low
* debian/control
- added otags to ocaml-core deps
2004-08-05 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.08.0.1) unstable; urgency=medium
* debian/control
- bumped standards version to 3.6.1.1
- removed lablgtk from ocaml-libs deps
(which still contains lablgtk2)
- removed libnums-ocaml-dev from ocaml-libs deps
(no longer needed since ocaml 3.08)
- added ocamldbi to ocaml-libs deps
2004-06-05 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.07.4) unstable; urgency=low
* debian/control
- ocaml-core: replaced dependency on fort with dependency on
libounit-ocaml-dev since the latter is definitely in a better
shape as a regression testing framework
2004-04-12 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.07.3) unstable; urgency=low
* debian/control
- removed dependency on cryptokit from ocaml-libs (crytpokit is not
really a fundamantal library and a package on which it depends is
actually heavily bugged)
2004-03-23 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.07.2) unstable; urgency=low
* debian/control
- s/ocaml-native-compilers/ocaml-best-compilers/
2004-03-15 - Stefano Zacchiroli <zack@debian.org>
meta-ocaml (3.07.1) unstable; urgency=low
* debian/control
- completely rewritten dependencies, now we start to have a lot of
ocaml libraries and it's time to keep only most important
libraries as dependencies of these metapackages
- bumped Standards-Version to 3.6.1.0
- rewritten Description fields
- set Maintainer to debian ocaml maintainers
- set Uploaders to the usual 5 d-o-m DDs + John Goerzon our latest
fellow d-o-m DD
* debian/compat
- use this file instead of DH_COMPAT
* debian/*README.Debian
- removed useless README.Debian files
2003-09-28 - Sven Luther <luther@debian.org>
meta-ocaml (3.06.3.1) unstable; urgency=high
* Removed ocamltk from ocaml-libs since ocaml no more provides it, and
no other package in the archive knows about it anyway.
* NMU upload since this need to happen quickly, it is blocking
ocaml 3.06-21 and we need to make place for the 3.07 packages.

See Also

Package Description
ocaml-melt_1.4.0-2+b1_amd64.deb LaTeX with OCaml (tools)
ocaml-mingw-w64-i686_4.01.0~20140328-1+b3_amd64.deb OCaml cross-compiler based on mingw -- 32 bit compiler
ocaml-mingw-w64-x86-64_4.01.0~20140328-1+b3_amd64.deb OCaml cross-compiler based on mingw -- 64 bit compiler
ocaml-mingw-w64_4.01.0~20140328-1+b3_amd64.deb OCaml cross-compiler based on mingw -- Meta-package
ocaml-mode_4.05.0-11_all.deb major mode for editing Objective Caml in Emacs
ocaml-nox_4.05.0-11_amd64.deb ML implementation with a class-based object system (no X)
ocaml-obuild_0.1.10-3_amd64.deb simple package build system for OCaml
ocaml-qtest_2.9-2_amd64.deb Inline (Unit) Tests for OCaml (Executable)
ocaml-source_4.05.0-11_all.deb Sources for Objective Caml
ocaml-tools_20120103-5_all.deb tools for OCaml developers
ocaml-ulex08_0.8-10+b9_amd64.deb OCaml lexer generator with Unicode support - CamlP5 version
ocaml-ulex_1.1-3+b1_amd64.deb OCaml lexer generator with Unicode support
ocaml_4.05.0-11_amd64.deb ML language implementation with a class-based object system
ocamlbuild_0.11.0-3_amd64.deb Build tool for building OCaml library and programs
ocamldsort_0.16.0-5+b1_amd64.deb dependency sorter for OCaml source files
Advertisement
Advertisement