ncompress_4.2.4.5-4_amd64.deb


Advertisement

Description

ncompress - original Lempel-Ziv compress/uncompress programs

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename ncompress_4.2.4.5-4_amd64.deb
Package name ncompress
Package version 4.2.4.5
Package release 4
Package architecture amd64
Package type deb
Category implemented-in::c interface::commandline role::program scope::utility use::compressing utils
Homepage https://github.com/vapier/ncompress
License -
Maintainer Kenneth J. Pronovici <pronovic@debian.org>
Download size 27.13 KB
Installed size 59.00 KB

Alternatives

Package Version Architecture Repository
ncompress_4.2.4.5-4_i386.deb 4.2.4.5 i386 Debian Main
ncompress - - -

Requires

Name Value
libc6 >= 2.14

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ncompress_4.2.4.5-4_amd64.deb
Source Package ncompress

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ncompress deb package:
    # sudo apt-get install ncompress

Files

Path
/usr/bin/compress
/usr/bin/uncompress.real
/usr/share/doc/ncompress/Acknowleds
/usr/share/doc/ncompress/README.Debian.gz
/usr/share/doc/ncompress/README.md.gz
/usr/share/doc/ncompress/changelog.Debian.gz
/usr/share/doc/ncompress/changelog.gz
/usr/share/doc/ncompress/copyright
/usr/share/man/man1/compress.1.gz
/usr/share/man/man1/uncompress.real.1.gz

Changelog

2019-08-10 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.5-4) unstable; urgency=medium
* Bump standards version to 4.4.0.1 (no packaging changes).
* Build-Depend on debhelper-compat (= 12) and remove debian/compat.
2019-02-03 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.5-3) unstable; urgency=medium
* Incorporate package cleanup from Guillem Jover in guillem:pu/cleanups.
- In debian/rules, use $(MAKE) rather than make to support parallel builds
- In debian/rules, use buildtools.mk instead of setting vars manually
- In debian/rules, no longer require root to build the package
- In debian/control, split Depends/Build-Depends onto multiple lines
- In debian/control, remove obsolete dpkg-dev and move to latest debhelper
2019-01-12 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.5-2) unstable; urgency=medium
* Fix regression so soft links can be uncompressed again (fixes: #918836).
- Add new autopkgtest debian/tests/softlink to catch regressions
- Add new patch debian/patches/fix-softlinks.patch to remove -DLSTAT
2019-01-05 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.5-1) unstable; urgency=medium
* New upstream release.
* Bump standards version to 4.3.0.0 (no packaging changes).
* Fix doc install in debian/rules to use README.md instead of README.
* Use 'make compress' rather than explicit $(CC) build in debian/rules.
* Run the new upstream test suite as part of the Debian build process.
* Refresh debian/patches/uncompress-real.patch to reflect upstream changes.
* Refresh debian/patches/remove-zcat.patch to reflect upstream changes.
* Remove debian/patches/code-typos.patch because upstream contains fix.
* Remove debian/patches/code-warnings.patch because upstream contains fix.
* Revert some reproducible build changes obviated by upstream improvements.
- Remove reproducible.patch, because upstream removed COMPILE_DATE usage
- Remove NCOMPRESS_VERSION in debian/rules, which was used by the patch
2018-10-20 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.4-23) unstable; urgency=medium
* Make testing improvements, including contributions from Ondřej Nový:
- Use AUTOPKGTEST_ vars instead of ADT_ in test suite
2018-09-16 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.4-22) unstable; urgency=medium
* Bump standards version to 4.2.1.0 (no packaging changes).
* Convert to correct https copyright file URI.
2018-08-07 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.4-21) unstable; urgency=medium
* Bump standards version to 4.2.0.1 (no packaging changes).
2018-01-03 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.4-20) unstable; urgency=medium
* Convert Debian packaging from Subversion to Git.
* Bump standards version to 4.1.3.0 (no packaging changes).
2017-11-12 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.4-19) unstable; urgency=medium
* Remove "Testsuite: autopkgtest" from debian/control per Lintian warning.
* Bump standards version to 4.1.1.0 (no packaging changes)
2017-09-19 - Kenneth J. Pronovici <pronovic@debian.org>
ncompress (4.2.4.4-18) unstable; urgency=medium
* Fix build process to work when cross-building (closes: #876108).
- Initial patch contributed by Helmut Grohne <helmut@subdivi.de>
- Update debian/rules to use a triplet-prefixed compiler
- Update debian/rules to honor DEB_BUILD_OPTIONS=nocheck

See Also

Package Description
ncrack_0.7+debian-1_amd64.deb High-speed network authentication cracking tool
ncurses-base_6.1+20190803-1_all.deb basic terminal type definitions
ncurses-bin_6.1+20190803-1_amd64.deb terminal-related programs and man pages
ncurses-doc_6.1+20190803-1_all.deb developer's guide and documentation for ncurses
ncurses-examples_6.1+20190803-1_amd64.deb test programs and examples for ncurses
ncurses-hexedit_0.9.7+orig-7_amd64.deb Edit files/disks in hex, ASCII and EBCDIC
ncurses-term_6.1+20190803-1_all.deb additional terminal type definitions
ncview_2.1.8+ds-3+b1_amd64.deb X11 visual browser for NetCDF format files
nd_0.8.2-8+b1_amd64.deb small command line interface to WebDAV servers
ndctl_66-1_amd64.deb Utility for managing the nvdimm subsystem
ndiff_7.80+dfsg1-1_all.deb The Network Mapper - result compare utility
ndisc6_1.0.4-1_amd64.deb IPv6 diagnostic tools
ndisgtk_0.8.5-1+b1_amd64.deb graphical frontend for ndiswrapper (installation of Windows WiFi drivers)
ndiswrapper-dkms_1.60-8_all.deb Source for the ndiswrapper Linux kernel module (DKMS)
ndiswrapper-source_1.60-8_all.deb Source for the ndiswrapper Linux kernel module
Advertisement
Advertisement