mono-runtime-common_5.18.0.240+dfsg-3_amd64.deb


Advertisement

Description

mono-runtime-common - Mono runtime - common files

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename mono-runtime-common_5.18.0.240+dfsg-3_amd64.deb
Package name mono-runtime-common
Package version 5.18.0.240+dfsg
Package release 3
Package architecture amd64
Package type deb
Category cli-mono
Homepage http://www.mono-project.com/
License -
Maintainer Debian Mono Group <pkg-mono-group@lists.alioth.debian.org>
Download size 918.64 KB
Installed size 2.82 MB

Alternatives

Package Version Architecture Repository
mono-runtime-common_5.18.0.240+dfsg-3_i386.deb 5.18.0.240+dfsg i386 Debian Main
mono-runtime-common - - -

Requires

Name Value
binutils -
libc6 >= 2.16
mono-gac = 5.18.0.240+dfsg-3
zlib1g >= 1:1.1.4

Provides

Name Value
cli-runtime -
cli-virtual-machine -

Conflicts

Name Value
mono-1.0-runtime << 2.4
mono-2.0-runtime << 2.4
mono-common << 2.4
mono-jit << 2.4
mono-runtime << 3.2.1

Replaces

Name Value
libmono0 << 2.4
mono-common << 2.4
mono-jit << 2.4
mono-runtime << 3.2.1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package mono-runtime-common_5.18.0.240+dfsg-3_amd64.deb
Source Package mono

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mono-runtime-common deb package:
    # sudo apt-get install mono-runtime-common

Files

Path
/etc/mono/browscap.ini
/etc/mono/config
/etc/mono/2.0/DefaultWsdlHelpGenerator.aspx
/etc/mono/2.0/machine.config
/etc/mono/2.0/settings.map
/etc/mono/2.0/web.config
/etc/mono/2.0/Browsers/Compat.browser
/etc/mono/4.0/DefaultWsdlHelpGenerator.aspx
/etc/mono/4.0/machine.config
/etc/mono/4.0/settings.map
/etc/mono/4.0/web.config
/etc/mono/4.0/Browsers/Compat.browser
/etc/mono/4.5/DefaultWsdlHelpGenerator.aspx
/etc/mono/4.5/machine.config
/etc/mono/4.5/settings.map
/etc/mono/4.5/web.config
/etc/mono/4.5/Browsers/Compat.browser
/usr/lib/libMonoPosixHelper.so
/usr/lib/libMonoSupportW.so
/usr/lib/libmono-btls-shared.so
/usr/lib/libmono-system-native.so
/usr/lib/libmono-system-native.so.0
/usr/lib/libmono-system-native.so.0.0.0
/usr/share/applications/mono-runtime-common.desktop
/usr/share/applications/mono-runtime-terminal.desktop
/usr/share/doc/mono-runtime-common/NEWS.Debian.gz
/usr/share/doc/mono-runtime-common/NEWS.gz
/usr/share/doc/mono-runtime-common/README.Debian
/usr/share/doc/mono-runtime-common/README.md.gz
/usr/share/doc/mono-runtime-common/changelog.1.gz
/usr/share/doc/mono-runtime-common/changelog.Debian.gz
/usr/share/doc/mono-runtime-common/copyright
/usr/share/man/man1/cli-wrapper.1.gz
/usr/share/man/man1/mono.1.gz
/usr/share/man/man5/mono-config.5.gz
/usr/share/mono-2.0/mono/cil/cil-opcodes.xml
/usr/share/pixmaps/mono-runtime-common.png

Changelog

2019-04-16 - Jo Shields <joshield@microsoft.com>
mono (5.18.0.240+dfsg-3) unstable; urgency=high
[ Jo Shields ]
* [20a7dd0] Don't build docs on s390x, to work around a dumb issue
[ Neale Ferguson ]
* [3713407] Fix s390x Outarg_VT (#10632)
* Fix outarg_vt processing. Fixes #10549
* Cleanup unused bits and pieces
* Correct the handling of structures being retuned from a call
* Restore vtcopy code etc.
(Closes: #921232)
2019-01-26 - Jo Shields <directhex@apebox.org>
mono (5.18.0.240+dfsg-2) unstable; urgency=medium
* [fcb8084] Add missing libmono-system-native (Closes: #920531)
* [8b705cf] Don't call cert-sync if it doesn't exist (Closes: #902663)
* [0514d12] Try fixing kFreeBSD building
2019-01-18 - Jo Shields <joshield@microsoft.com>
mono (5.18.0.240+dfsg-1) unstable; urgency=medium
[ Jo Shields ]
* [c67387f] New upstream version 5.18.0.240+dfsg
* [7a3d16f] Add reference-assemblies-with-csc patch for v4.7.2
* [5d42c62] Reorder rules so it's possible to override CFLAGS/CXXFLAGS 
per-arch
* [c1147ec] Let's not worry about LLVM for now
* [d6ff03e] Don't override GCC to 5.5 on s390x
* [e0fb8de] Enable BTLS on ppc64el
* [c842d23] Use provided mono-api-diff.exe
* [f262b7e] Install v4.7.2 API
* [871c1b3] Refreshed symbols
* [89d55c3] Use langversion 7.2 for tests (7.3 needs Roslyn)
* [ae548db] Disallow directory traversal (Closes: CVE-2018-1002208)
* [de5aae0] Switch internal dh_clideps to use ikdasm
* [b518c84] Add v4.7.2 API to dh_clideps excludes
* [be0afd7] -fstack-protector-strong breaks s390x on PIC-default gcc. 
Remove it there. (Closes: #919371)
* [73b4472] Refreshed clilibs
[ Neale Ferguson ]
* [753ee8c] Fix s390x build broken by incorrect specification of the 
msgfi instuc… (#10026)
Fix s390x build broken by incorrect specification of the msgfi
instruction used in MUL_IMM type operations. The instruction had 
been encoded as its 32-bit counterpart (msfi).
In addition, the s390x microcode makes the 
mono_strength_reduction_division unnecessary so this can be bypassed.
The change to basic.make is just to avoid error messages when 
basic-profile-check.exe hasn't been built yet.
* [cb37e0b] Simplify retrieving TLS offset
* [fecfbf8] Cater for later glibc use of ucontext
* [cc78fc2] Missing include
2019-01-12 - Jo Shields <directhex@apebox.org>
mono (5.16.0.220+dfsg3-2) unstable; urgency=medium
* No-change rebuild (Closes: #919031)

See Also

Package Description
mono-runtime-sgen_5.18.0.240+dfsg-3_amd64.deb Mono runtime - SGen
mono-runtime_5.18.0.240+dfsg-3_amd64.deb Mono runtime - default version
mono-source_5.18.0.240+dfsg-3_all.deb Mono source code
mono-tools-devel_4.2-3_all.deb Various development tools for mono
mono-tools-gui_4.2-3_all.deb Various GUI tools for mono
mono-upnp-bin_0.1.2-2_all.deb client/server libraries for UPnP -- executables
mono-utils_5.18.0.240+dfsg-3_amd64.deb Mono utilities
mono-vbnc_4.0.1-3_all.deb Mono Visual Basic Compiler (VB.NET)
mono-xbuild_5.18.0.240+dfsg-3_all.deb MSBuild-compatible build system for Mono
mono-xsp4-base_4.2-2.1_all.deb base libraries for XSP 4.0
mono-xsp4_4.2-2.1_all.deb simple web server to run ASP.NET 4.0 applications
mono-xsp_4.2-2.1_all.deb simple web server to run ASP.NET applications - default version
monobristol_0.60.3-3_all.deb simple GUI for Bristol
monodoc-appindicator3-0.1-manual_12.10.0+git20151221-5_all.deb compiled XML documentation for Appindicator3#
monodoc-base_5.18.0.240+dfsg-3_all.deb shared MonoDoc binaries
Advertisement
Advertisement