modemmanager_1.10.0-1_amd64.deb


Advertisement

Description

modemmanager - D-Bus service for managing modems

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename modemmanager_1.10.0-1_amd64.deb
Package name modemmanager
Package version 1.10.0
Package release 1
Package architecture amd64
Package type deb
Category comm hardware::modem implemented-in::c interface::daemon role::program
Homepage https://www.freedesktop.org/wiki/Software/ModemManager/
License -
Maintainer Mathieu Trudel-Lapierre <mathieu.tl@gmail.com>
Download size 1.42 MB
Installed size 4.00 MB

Alternatives

Package Version Architecture Repository
modemmanager_1.10.0-1_i386.deb 1.10.0 i386 Debian Main
modemmanager - - -

Requires

Name Value
libc6 >= 2.14
libglib2.0-0 >= 2.36.0
libgudev-1.0-0 >= 147
libmbim-glib4 >= 1.18.0
libmbim-proxy -
libmm-glib0 >= 1.10.0
libpolkit-gobject-1-0 >= 0.99
libqmi-glib5 >= 1.22.0
libqmi-proxy -
libsystemd0 >= 209

Download

Type URL
Mirror ftp.br.debian.org
Binary Package modemmanager_1.10.0-1_amd64.deb
Source Package modemmanager

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install modemmanager deb package:
    # sudo apt-get install modemmanager

Files

Path
/etc/dbus-1/system.d/org.freedesktop.ModemManager1.conf
/lib/systemd/system/ModemManager.service
/lib/udev/rules.d/77-mm-cinterion-port-types.rules
/lib/udev/rules.d/77-mm-dell-port-types.rules
/lib/udev/rules.d/77-mm-ericsson-mbm.rules
/lib/udev/rules.d/77-mm-fibocom-port-types.rules
/lib/udev/rules.d/77-mm-haier-port-types.rules
/lib/udev/rules.d/77-mm-huawei-net-port-types.rules
/lib/udev/rules.d/77-mm-longcheer-port-types.rules
/lib/udev/rules.d/77-mm-mtk-port-types.rules
/lib/udev/rules.d/77-mm-nokia-port-types.rules
/lib/udev/rules.d/77-mm-pcmcia-device-blacklist.rules
/lib/udev/rules.d/77-mm-qdl-device-blacklist.rules
/lib/udev/rules.d/77-mm-sierra.rules
/lib/udev/rules.d/77-mm-simtech-port-types.rules
/lib/udev/rules.d/77-mm-telit-port-types.rules
/lib/udev/rules.d/77-mm-ublox-port-types.rules
/lib/udev/rules.d/77-mm-usb-device-blacklist.rules
/lib/udev/rules.d/77-mm-usb-serial-adapters-greylist.rules
/lib/udev/rules.d/77-mm-x22x-port-types.rules
/lib/udev/rules.d/77-mm-zte-port-types.rules
/lib/udev/rules.d/80-mm-candidate.rules
/usr/bin/mmcli
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-altair-lte.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-anydata.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-cinterion.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-dell.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-ericsson-mbm.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-fibocom.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-generic.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-haier.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-huawei.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-iridium.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-linktop.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-longcheer.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-motorola.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-mtk.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-nokia-icera.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-nokia.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-novatel-lte.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-novatel.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-option-hso.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-option.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-pantech.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-quectel.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-samsung.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-sierra-legacy.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-sierra.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-simtech.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-telit.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-thuraya.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-ublox.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-via.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-wavecom.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-x22x.so
/usr/lib/x86_64-linux-gnu/ModemManager/libmm-plugin-zte.so
/usr/sbin/ModemManager
/usr/share/bash-completion/completions/mmcli
/usr/share/dbus-1/system-services/org.freedesktop.ModemManager1.service
/usr/share/doc/modemmanager/AUTHORS
/usr/share/doc/modemmanager/NEWS.gz
/usr/share/doc/modemmanager/README
/usr/share/doc/modemmanager/changelog.Debian.gz
/usr/share/doc/modemmanager/changelog.gz
/usr/share/doc/modemmanager/copyright
/usr/share/icons/hicolor/22x22/apps/ModemManager.png
/usr/share/locale/cs/LC_MESSAGES/ModemManager.mo
/usr/share/locale/de/LC_MESSAGES/ModemManager.mo
/usr/share/locale/fr/LC_MESSAGES/ModemManager.mo
/usr/share/locale/fur/LC_MESSAGES/ModemManager.mo
/usr/share/locale/hu/LC_MESSAGES/ModemManager.mo
/usr/share/locale/id/LC_MESSAGES/ModemManager.mo
/usr/share/locale/it/LC_MESSAGES/ModemManager.mo
/usr/share/locale/pl/LC_MESSAGES/ModemManager.mo
/usr/share/locale/pt_BR/LC_MESSAGES/ModemManager.mo
/usr/share/locale/sk/LC_MESSAGES/ModemManager.mo
/usr/share/locale/sv/LC_MESSAGES/ModemManager.mo
/usr/share/locale/tr/LC_MESSAGES/ModemManager.mo
/usr/share/locale/uk/LC_MESSAGES/ModemManager.mo
/usr/share/man/man1/mmcli.1.gz
/usr/share/man/man8/ModemManager.8.gz
/usr/share/polkit-1/actions/org.freedesktop.ModemManager1.policy

Changelog

2019-02-05 - Till Kamppeter <till.kamppeter@gmail.com>
modemmanager (1.10.0-1) unstable; urgency=medium
* New upstream release
* debian/control: Update build dependencies as now libmbim >= 1.18.0 and
libqmi >= 1.22.0 are required.
* debian/libmm-glib0.symbols: update symbols for new release.
2018-10-04 - Mathieu Trudel-Lapierre <mathieu.tl@gmail.com>
modemmanager (1.8.2-1) unstable; urgency=medium
* New upstream version 1.8.2. (Closes: #910013) (Closes: #900907)
* debian/modemmanager.postrm: don't unmask ModemManager on postrm; we were
unmasking because we're about to remove ModemManager anyway, and prerm did
its mask with --runtime which is supposed to not be persistent.
(Closes: #902260)
* debian/control: canonicalize Vcs-* URLs.
* debian/control: bump to Standard-Version: 4.2.1; no changes required.
2018-06-06 - Gianfranco Costamagna <locutusofborg@debian.org>
modemmanager (1.7.990-1ubuntu1) cosmic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Pass --enable-more-warnings so we build without -Werror. Patch
m4/compiler_warnings.m4 to allow this.
2018-03-01 - Mathieu Trudel-Lapierre <mathieu.tl@gmail.com>
modemmanager (1.7.990-1) unstable; urgency=medium
* New upstream version 1.7.990.
* debian/control: Bump libqmi-glib-dev and libmbim-glib-dev Depends to new
required versions (libmbim > 1.16, libqmi > 1.20) for this release.
* Update Maintainer field for my 'real' address. (Closes: #884617)
* debian/control: Update Vcs-* fields: moved project to salsa.d.o.
* debian/control: Bump to Standards-Version 4.1.3.
* debian/copyright:
- Fix Format: URL to use https.
- Drop extra stanza for libwmc; it really is only GPL2, not GPL2+.
* debian/rules: set DPKG_GENSYMBOLS_CHECK_LEVEL=4; more verbose when there
are added/changed symbols.
* debian/libmm-glib0.symbols: update symbols for new release.
* debian/patches/default_strict_probing_policy.patch: set the filtering
policy for probing to 'strict' by default: this will avoid probing devices
that are not modems, and potentially interfering with RNGs, braille, etc.
(Closes: #683839)
2018-04-24 - Iain Lane <iain@orangesquash.org.uk>
modemmanager (1.6.8-2ubuntu1) bionic; urgency=medium
* Pass --enable-more-warnings so we build without -Werror. Patch
m4/compiler_warnings.m4 to allow this.
2017-10-21 - Michael Biebl <biebl@debian.org>
modemmanager (1.6.8-2) unstable; urgency=medium
* Remove myself from Uploaders and re-instate Mathieu Trudel-Lapierre as
Maintainer.
2017-06-17 - Michael Biebl <biebl@debian.org>
modemmanager (1.6.8-1) unstable; urgency=medium
* New upstream version 1.6.8
* Drop obsolete Breaks and Replaces from pre-jessie.
* Move D-Bus interface files into modemmanager-dev package
2016-11-16 - Michael Biebl <biebl@debian.org>
modemmanager (1.6.4-1) unstable; urgency=medium
* New upstream release.
* Drop overrides for dh_systemd_start and dh_installinit.
Starting with compat level 10, --restart-after-upgrade is the default.
* Drop obsolete maintainer scripts code.
2016-09-17 - Michael Biebl <biebl@debian.org>
modemmanager (1.6.2-1) unstable; urgency=medium
* New upstream release.
* Bump debhelper compat level to 10.
2016-07-28 - Michael Biebl <biebl@debian.org>
modemmanager (1.6.0-1) unstable; urgency=medium
* New upstream release.

See Also

Package Description
modestmaps-js-doc_3.3.6+ds2-1_all.deb display and interaction library for tile-based maps - docs
modplug-tools_0.5.3-3_amd64.deb Modplug playing console tools
modsecurity-crs_3.1.0-1_all.deb OWASP ModSecurity Core Rule Set
module-assistant_0.11.10_all.deb tool to make module package creation easier
moka-icon-theme_5.3.6-1_all.deb Tango-esque desktop icon set called Moka
mokomaze_0.7.1-1_amd64.deb Ball in labyrinth game for the OpenMoko FreeRunner
mokutil_0.3.0+1538710437.fb6250f-1_amd64.deb tools for manipulating machine owner keys
molds_0.3.1-1+b7_amd64.deb Semi-empirical electronic structure and molecular dynamics
molly-guard_0.7.1_all.deb protects machines from accidental shutdowns/reboots
mom_0.5.12-1_all.deb Dynamically manage system resources on virtualization hosts
mon-client_1.2.0-2_all.deb modules for interfacing with the mon package
mon-contrib_1.0+dfsg-4_amd64.deb contributed tools, monitors and alert for mon
mon_1.3.3-3_amd64.deb monitor hosts/services/whatever and alert about problems
mona_1.4-17-1+b1_amd64.deb theorem prover based on automata
monajat-applet_4.1-2_all.deb Islamic supplications tray applet
Advertisement
Advertisement