microcom_2017.03.0-2_amd64.deb


Advertisement

Description

microcom - minimalistic terminal program

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename microcom_2017.03.0-2_amd64.deb
Package name microcom
Package version 2017.03.0
Package release 2
Package architecture amd64
Package type deb
Category comm hardware::modem implemented-in::c interface::text-mode role::program
Homepage -
License -
Maintainer Uwe Kleine-König <ukleinek@debian.org>
Download size 17.01 KB
Installed size 50.00 KB

Alternatives

Package Version Architecture Repository
microcom_2017.03.0-2_i386.deb 2017.03.0 i386 Debian Main
microcom_2014.02.0-0ukl1_i386.deb 2014.02.0 i386 RT-Preempt Main
microcom_2014.02.0-0ukl1_amd64.deb 2014.02.0 amd64 RT-Preempt Main
microcom_2014.02.0-0ukl1_i386.deb 2014.02.0 i386 RT-Preempt Contrib
microcom_2014.02.0-0ukl1_amd64.deb 2014.02.0 amd64 RT-Preempt Contrib
microcom_2014.02.0-0ukl1_i386.deb 2014.02.0 i386 RT-Preempt Nonfree
microcom_2014.02.0-0ukl1_amd64.deb 2014.02.0 amd64 RT-Preempt Nonfree
microcom - - -

Requires

Name Value
libc6 >= 2.15
libreadline7 >= 6.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package microcom_2017.03.0-2_amd64.deb
Source Package microcom

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install microcom deb package:
    # sudo apt-get install microcom

Files

Path
/usr/bin/microcom
/usr/share/doc/microcom/changelog.Debian.gz
/usr/share/doc/microcom/copyright
/usr/share/man/man1/microcom.1.gz

Changelog

2018-03-08 - Uwe Kleine-König <ukleinek@debian.org>
microcom (2017.03.0-2) unstable; urgency=medium
* Simplify debian/watch
There are now provides signatures for the compressed archive which allows
to use pgpmode=auto.
2018-03-07 - Uwe Kleine-König <ukleinek@debian.org>
microcom (2017.03.0-1) unstable; urgency=medium
* Update debian/watch to find new upstream releases.
* New upstream release
* Update VCS-* to provide confidentiality.
* Standards-Version: 4.1.3
2016-01-09 - Uwe Kleine-König <ukleinek@debian.org>
microcom (2016.01.0-1) unstable; urgency=medium
* New upstream release
+ microcom now uses autotools.  It also autodetects the presence of
include files needed for CAN support. This allows using "any" instead of
"linux-any" as the build-target.
+ LFS fixes
* switch maintainer entry to debian.org address
2014-09-22 - Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
microcom (2014.09.0-1) unstable; urgency=medium
* New upstream release
+ Add IPv6 support to RFC2217 mode
* Standards-Version: 3.9.6 (no changes needed)
2014-02-23 - Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
microcom (2014.02.0-1) unstable; urgency=low
* Adopt package (Closes: #726551) - Thanks Alex!
* Standards-Version: 3.9.5 (no changes needed)
* New upstream release
+ Fix order of parameters to ld (Closes: #678303)
+ Add manpage (Closes: #698436)
+ Fix newline handling (Closes: #706931)
* Modernisation of packaging
+ Use source format 3.0 (quilt)
+ Simplify debian/rules using dh 7
+ Add debian/watch file
+ Convert to machine-readable copyright format 1.0
+ Add Vcs-Git URLs
2013-10-30 - Alexander Reichle-Schmehl <tolimar@debian.org>
microcom (2012.06.0-3) unstable; urgency=low
* Orphan package
* Bump standards to 3.9.4 (no changes needed)
2012-06-15 - Alexander Reichle-Schmehl <tolimar@debian.org>
microcom (2012.06.0-2) unstable; urgency=low
* Make the package arch: linux-any, as the new upsteam release only
supports Linux so far: CAN support seems to be only available on
Linux and can currently not be disabled at compile time.
(Closes: #677641)
2012-06-14 - Alexander Reichle-Schmehl <tolimar@debian.org>
microcom (2012.06.0-1) unstable; urgency=low
[ The "Oh god, it is bein used" release ]
* New upstream release
* Really fix upstream URL
2012-06-14 - Alexander Reichle-Schmehl <tolimar@debian.org>
microcom (2012.02.20-1) unstable; urgency=low
* New upstream release
+ Add libreadline6-dev to Build-Depends
+ Add new option to manpage
* Fix upstream URL in debian/control (Closes: #631604)
* Bump Standards Version to 3.9.3 (no changes necessary)
* Build with hardening buildflags
+ Add dpkg-dev (>= 1.16.1~) to Build-Depends
* Fix typo in manpage found by lintian
2009-06-13 - Alexander Reichle-Schmehl <tolimar@debian.org>
microcom (2009.6-1) unstable; urgency=low
* Initial release (Closes: #532975)

See Also

Package Description
microdc2_0.15.6-4+b1_amd64.deb command-line based Direct Connect client
microhope_4.4.4+dfsg-4_amd64.deb hardware & software framework to learn microcontrollers
micropolis-data_0.0.20071228-9_all.deb real-time city management simulator - data
micropolis_0.0.20071228-9_amd64.deb real-time city management simulator
midge_0.2.41-2.1_all.deb A text to MIDI program
midicsv_1.1+dfsg.1-1+b1_amd64.deb translate MIDI file to CSV
mididings-doc_0~20120419~ds0-6_all.deb mididings Documentation
mididings_0~20120419~ds0-6_all.deb MIDI router and processor based on Python
midish_1.0.4-1.1+b3_amd64.deb shell-like MIDI sequencer/filter
midisnoop_0.1.2~repack0-7+b1_amd64.deb MIDI monitor and prober
midori_7.0-2_amd64.deb fast, lightweight graphical web browser
migemo-el_1.2+gh0.20150404-7_all.deb transitional dummy package: elpa-migemo
mighttpd2_3.4.3-2_amd64.deb classical web server on WAI/warp
migrationtools_47-8_all.deb Migration scripts for LDAP
mikmod_3.2.8-2_amd64.deb Portable tracked music player
Advertisement
Advertisement