mbuffer_20190127+ds1-1_amd64.deb


Advertisement

Description

mbuffer - tool for buffering data streams

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename mbuffer_20190127+ds1-1_amd64.deb
Package name mbuffer
Package version 20190127+ds1
Package release 1
Package architecture amd64
Package type deb
Category admin::backup role::program utils
Homepage http://www.maier-komor.de/mbuffer.html
License -
Maintainer Peter Pentchev <roam@debian.org>
Download size 57.97 KB
Installed size 168.00 KB

Alternatives

Package Version Architecture Repository
mbuffer_20190127+ds1-1_i386.deb 20190127+ds1 i386 Debian Main
mbuffer - - -

Requires

Name Value
libc6 >= 2.17
libgcrypt20 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package mbuffer_20190127+ds1-1_amd64.deb
Source Package mbuffer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install mbuffer deb package:
    # sudo apt-get install mbuffer

Files

Path
/etc/mbuffer.rc
/usr/bin/mbuffer
/usr/lib/x86_64-linux-gnu/mbuffer/have-af
/usr/lib/x86_64-linux-gnu/mbuffer/idev.so
/usr/lib/x86_64-linux-gnu/mbuffer/tapetest.so
/usr/share/doc/mbuffer/NEWS.gz
/usr/share/doc/mbuffer/README
/usr/share/doc/mbuffer/changelog.Debian.gz
/usr/share/doc/mbuffer/copyright
/usr/share/man/man1/mbuffer.1.gz

Changelog

2019-02-20 - Peter Pentchev <roam@debian.org>
mbuffer (20190127+ds1-1) unstable; urgency=medium
* Add a trivial git-buildpackage config file.
* New upstream version, refresh the patches.
2019-01-23 - Peter Pentchev <roam@debian.org>
mbuffer (20190119+ds1-1) unstable; urgency=medium
* New upstream version, refresh the patches.
2019-01-14 - Peter Pentchev <roam@debian.org>
mbuffer (20190113+ds1-1) unstable; urgency=medium
* New upstream version:
- update the copyright years
- drop the network-no-getaddrinfo patch, integrated upstream
- refresh the patches
2019-01-08 - Peter Pentchev <roam@debian.org>
mbuffer (20181119+ds1-1) unstable; urgency=medium
* Bring up to compliance with Debian Policy 4.3.0: install the upstream
release notes (ChangeLog) as NEWS and not changelog.
* Drop the Lintian overrides related to B-D: debhelper-compat -
Lintian 2.5.98 no longer emits these warnings and errors.
* Fix another typographical error.
* Bump the debhelper compatibility level to 12 with no changes.
* Add the year 2019 to my debian/* copyright notice.
* Move away from git-dpm.
* Add the network-no-getaddrinfo patch to fix two problems in
the case when getaddrinfo(3) is not available:
- fix the parsing of the "-I host:port" command-line option
- use %s, not %d, for string arguments to printf()
* Do not modify an autogenerated file in the typos patch.
* New upstream version, refresh the typos patch.
2018-07-22 - Peter Pentchev <roam@debian.org>
mbuffer (20180625+ds1-1) unstable; urgency=medium
* Declare compliance with Debian Policy 4.1.5 with no changes.
* Add a trivial autopkgtest running adequate on the installed package.
* New upstream version:
- change the build dependency from libmhash-dev to libmhash2, since
the library is loaded at runtime now, no header files needed
- add the libmhash-so-version patch to look for libmhash.so.2,
not libmhash.so, at runtime
- switch from libmhash to libgcrypt20; the latter seems to be
present on almost all recent Debian installations, pulled in by
gpgv or systemd
- add an explicit runtime dependency on libgcrypt20 since it will
no longer be pulled in by shlibs:Depends
2018-05-14 - Peter Pentchev <roam@debian.org>
mbuffer (20180505+ds1-1) unstable; urgency=medium
* Use my Debian e-mail address.
* New upstream version:
- fixes the hang on very short input.  Closes: #776445
- add two more fixups to the usr-tree test.
* Use the B-D: debhelper-compat (= 11) mechanism.
2018-04-13 - Peter Pentchev <roam@ringlet.net>
mbuffer (20180410+ds1-1) unstable; urgency=medium
* Declare compliance with Debian Policy 4.1.4 with no changes.
* New upstream version:
- drop the af-specific, cleanup-test-files, close-errno,
config-mbuffer, cppcheck, etcdir, and lfs-preload patches,
all accepted by the upstream author
- add some new fixes to the typos patch
- split the tapetest format string fix into its own patch
- add the internal-symbol patch to avoid defining a symbol with
a reserved name when _GNU_SOURCE is enough
- add another two "don't rebuild" fixups to the usr-tree test
* Repack the upstream tarball to exclude the Mercurial tag files.
2018-03-23 - Peter Pentchev <roam@ringlet.net>
mbuffer (20180318-2) unstable; urgency=medium
* Add the af-specific patch to fix the FTBFS on hosts which do not
have both IPv4 and IPv6 addresses.  Also, stash the new have-af
helper tool and use it in the binary package test.
* Now that we're running the tests at build time, fix a "FTBFS twice
in a row" problem by also invoking the testcleanup target.
* Rename the test-cleanup patch to test-conditional.
* Add the cleanup-test-files patch to remove mbuffer.md5 and idev.so.

See Also

Package Description
mbw_1.2.2-1+b1_amd64.deb memory bandwidth benchmark program
mc-data_4.8.22-1_all.deb Midnight Commander - a powerful file manager -- data files
mc_4.8.22-1_amd64.deb Midnight Commander - a powerful file manager
mcabber_1.1.0-1.1_amd64.deb small Jabber (XMPP) console client
mccs_1.1-8_amd64.deb multi-critera CUDF solver
mcl-doc_14-137+ds-3_all.deb documentation for mcl
mcl_14-137+ds-3_amd64.deb Markov Cluster algorithm
mcollective-client_2.12.1+dfsg-1_all.deb Marionette Collective clustering framework - clients
mcollective-common_2.12.1+dfsg-1_all.deb Marionette Collective clustering framework - common files
mcollective-doc_2.12.1+dfsg-1_all.deb Marionette Collective clustering framework - documentation
mcollective_2.12.1+dfsg-1_all.deb Marionette Collective clustering framework - server
mcomix_1.2.1-1.1_all.deb GTK+ image viewer for comic books
mcp-plugins_0.4.0-6_amd64.deb LADSPA plugins designed for Alsa Modular Synth
mcpp-doc_2.7.2-4_all.deb Alternative C/C++ preprocessor (manual)
mcpp_2.7.2-4+b2_amd64.deb Alternative C/C++ preprocessor
Advertisement
Advertisement