lzma-alone_9.22-2.1+b1_amd64.deb


Advertisement

Description

lzma-alone - Compression and decompression in the LZMA format - legacy utility

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename lzma-alone_9.22-2.1+b1_amd64.deb
Package name lzma-alone
Package version 9.22
Package release 2.1+b1
Package architecture amd64
Package type deb
Category role::program use::compressing utils
Homepage http://www.7-zip.org/sdk.html
License -
Maintainer Mohammed Adnène Trojette <adn+deb@diwi.org>
Download size 69.43 KB
Installed size 203.00 KB

Alternatives

Package Version Architecture Repository
lzma-alone_9.22-2.1_i386.deb 9.22 i386 Debian Main
lzma-alone - - -

Requires

Name Value
libc6 >= 2.14
libgcc1 >= 1:3.0
libstdc++6 >= 5

Conflicts

Name Value
lzma << 4.43-13

Replaces

Name Value
lzma << 4.43-13

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lzma-alone_9.22-2.1+b1_amd64.deb
Source Package lzma

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lzma-alone deb package:
    # sudo apt-get install lzma-alone

Files

Path
/usr/bin/lzma_alone
/usr/share/doc/lzma-alone/changelog.Debian.amd64.gz
/usr/share/doc/lzma-alone/changelog.Debian.gz
/usr/share/doc/lzma-alone/changelog.gz
/usr/share/doc/lzma-alone/copyright
/usr/share/man/man1/lzma_alone.1.gz

Changelog

2017-09-24 - Manuel A. Fernandez Montecelo <mafm@debian.org>
lzma (9.22-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix typo in description, thanks Pascal De Vuyst (Closes: #714875)
[ Helmut Grohne ]
* Fix FTCBFS: Let dh_auto_build pass cross flags. (Closes: #839857)
2012-01-08 - Mohammed Adnène Trojette <adn+deb@diwi.org>
lzma (9.22-2) unstable; urgency=low
* Upload to unstable.
* Previous upload removed lzma-source. (Closes: #651796)
* Prevent /dev/null removal while testing a file. (Closes: #550543)
2011-09-03 - Mohammed Adnène Trojette <adn+deb@diwi.org>
lzma (9.22-1) experimental; urgency=low
[ Mohammed Adnène Trojette ]
* New upstream release (Closes: #460501, #518365)
+ LZMA SDK is placed in the public domain since 4.62.
* Update debian/patches/02_lzmp.diff.
* Switch packaging under the terms of the BSD license.
* Switch to dpkg-source 3.0 (quilt) format
+ debian/control: Build-Depends
- drop quilt.
- bump debhelper dependency to 8.0.0.
* Bump Standards-Version to 3.9.2
* Drop lzma-source package. It doesn't work with current kernels and
SquashFS XZ is part of the standard kernel now. Patch courtesy of
Jonathan Nieder. (Closes: #470893, #553707, #466582)
* Update file list in lzma-dev. (Closes: #614417)
* Fix and improve descriptions. (Closes: #535776, #540469)
* Add deb-lzma script to convert a deb package to LZMA format. Script
courtesy of Roger Millan. (Closes: #536275)
* Add Jonathan Nieder as comaintainer.
[ Jonathan Nieder ]
* Bump debhelper compatibility to 7.
* Manage lzma, unlzma, and lzcat through the alternatives system.
Conflicts: xz-lzma (<< 5.1.1alpha+20110809-2). (Closes: #547802)
2008-06-16 - Mohammed Adnène Trojette <adn+deb@diwi.org>
lzma (4.43-14) unstable; urgency=low
* Bump Standards-Version to 3.8.0.
* Drop lzma-alone from Recommends.
* Don't build lzma-source when binary-indep target is not
called. (Closes: #486419)
2008-06-04 - Mohammed Adnène Trojette <adn+deb@diwi.org>
lzma (4.43-13) unstable; urgency=low
* Split lzma binary package into:
+ lzma-alone: with /usr/bin/lzma_alone. (Closes: #475111)
+ lzma (recommending lzma-alone): with the rest.
* No need for a quilt patch to add a manpage...
* Move development documentation to lzma-dev. (Closes: #475110)
2007-12-08 - Arnaud Fontaine <arnau@debian.org>
lzma (4.43-12) unstable; urgency=low
* Update sqlzma patch (needed for squashfs):
+ Backport sqlzma patch to LZMA SDK 4.43.
+ Update 04_sqlzma_h.diff.
2007-12-07 - Mohammed Adnène Trojette <adn+deb@diwi.org>
lzma (4.43-11) unstable; urgency=low
* Upload to unstable.
[ Arnaud Fontaine ]
* lzma-dev should be part of the Build-Depends only and not a dependency
inside the resulting kernel modules package.  Thanks to Michael
Prokop. (Closes: #452868)
* Support cross building. Thanks to Neil Williams for the patch.
(Closes: #451598)
* debian/control*:
+ Add Homepage field (dpkg supports it now).
+ Add Vcs-Git and Vcs-Browser field (dpkg support them now).
+ Update my email address to arnau@debian.org.
+ Update Standards-Version to 3.7.3. No changes needed.
[ Mohammed Adnène Trojette ]
* Don't ship /usr/share/doc/lzma/LGPL.txt.gz. (Closes: #453922)
* debian/copyright:
+ Include a copy of the CPL license. (Closes: #453924)
2007-10-18 - Arnaud Fontaine <arnaud@andesi.org>
lzma (4.43-10) experimental; urgency=low
* debian/control:
+ Add myself as Uploaders.
* debian/docs:
+ Remove useless LGPL.txt file because it is already provided by
Debian.
* Install history.txt as the changelog in /usr/share/doc/.
* Add support for squashfs. (Closes: #443844).
+ Add lzma-dev which contains headers and static libraries.
+ Add lzma-source which contains kernel modules needed for squashfs.
+ Add patch from sqlzma project.

See Also

Package Description
lzma-dev_9.22-2.1_all.deb Compression and decompression in the LZMA format - development files
lzma_9.22-2.1+b1_amd64.deb Compression and decompression in the LZMA format - command line utility
lzop_1.03-4+b1_amd64.deb fast compression program
m16c-flash_0.1-1.1+b2_amd64.deb Flash programmer for Renesas M16C and R8C microcontrollers
m17n-db_1.8.0-2_all.deb multilingual text processing library - database
m17n-docs_1.6.2-2_all.deb multilingual text processing library - documents
m17n-im-config_0.9.0-5_amd64.deb input method configuration library for m17n-lib - utility
m17n-lib-bin_1.8.0-2_amd64.deb multilingual text processing library - utilities
m17n-lib-mimx_1.8.0-2_amd64.deb multilingual text processing library - binary modules
m2crypto-doc_0.31.0-6_all.deb Python wrapper for the OpenSSL library (docs)
m2vrequantiser_1.1-3+b1_amd64.deb MPEG-2 streams requantization
m4-doc_1.4.18-2_all.deb Documentation for GNU m4
m4_1.4.18-2_amd64.deb macro processing language
mac-robber_1.02-7_amd64.deb collects data about allocated files in mounted filesystems
macchanger_1.7.0-5.4_amd64.deb utility for manipulating the MAC address of network interfaces
Advertisement
Advertisement