lua-mode_20151025-5_all.deb


Advertisement

Description

lua-mode - Emacs mode for editing Lua programs -- transitional package

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename lua-mode_20151025-5_all.deb
Package name lua-mode
Package version 20151025
Package release 5
Package architecture all
Package type deb
Category devel::lang:lua editors implemented-in::lisp role::plugin role::program suite::emacs use::editing
Homepage http://immerrr.github.com/lua-mode
License -
Maintainer Debian Emacs addons team <pkg-emacsen-addons@lists.alioth.debian.org>
Download size 4.21 KB
Installed size 11.00 KB

Alternatives

Package Version Architecture Repository
lua-mode_20151025-5_all.deb 20151025 all Debian Main
lua-mode - - -

Requires

Name Value
elpa-lua-mode -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package lua-mode_20151025-5_all.deb
Source Package lua-mode

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lua-mode deb package:
    # sudo apt-get install lua-mode

Files

Path
/usr/share/doc/lua-mode/changelog.Debian.gz
/usr/share/doc/lua-mode/copyright

Changelog

2019-08-25 - David Bremner <bremner@debian.org>
lua-mode (20151025-5) unstable; urgency=medium
* Team upload.
* Regenerate source package with quilt patches
2019-08-25 - David Bremner <bremner@debian.org>
lua-mode (20151025-4) unstable; urgency=medium
* Team upload.
* Rebuild with current dh-elpa
2017-12-14 - Hilko Bengen <bengen@debian.org>
lua-mode (20151025-3) unstable; urgency=medium
* Change tests to work with buttercup 1.9, thanks to buttercup author
Jorgen Schäfer for advice (Closes: #877398)
2017-08-02 - Hilko Bengen <bengen@debian.org>
lua-mode (20151025-2) unstable; urgency=medium
* Give package to pkg-emacsen-addons
* Modernize package: elpa, copyright, Standards-Version, Debhelper
compat level
2015-11-01 - Hilko Bengen <bengen@debian.org>
lua-mode (20151025-1) unstable; urgency=medium
* New upstream version
* Modernize package
- Debhelper 9
- Bump Standards-Version
- Add Vcs-* headers
- Mention lua5.3, luajit
- Drop patch
2015-01-16 - Hilko Bengen <bengen@debian.org>
lua-mode (20140514-2) unstable; urgency=medium
* Dropped emacs22 support (Closes: #775389)
2014-07-17 - Hilko Bengen <bengen@debian.org>
lua-mode (20140514-1) unstable; urgency=medium
* New upstream version
* Updated watch file from sepwatch
* Bumped Standards-Version
2014-06-04 - Hilko Bengen <bengen@debian.org>
lua-mode (20130419-4) unstable; urgency=medium
* Changed auto-mode-alist entry so startup file and lua-mode.el match
(Closes: #680697)
* Added patch to make lua-indent-level a safe local-variable (Closes:
#717431)
2013-08-06 - Hilko Bengen <bengen@debian.org>
lua-mode (20130419-3) unstable; urgency=low
* Don't build for emacs21, xemacs21 (Closes: #718826, #718827)
2013-08-05 - Hilko Bengen <bengen@debian.org>
lua-mode (20130419-2) unstable; urgency=low
* Fixed install file (Closes: #718811)

See Also

Package Description
lua-moses_2.1.0-1_all.deb Utility library for functional programming in Lua
lua-mpack_1.0.7-2_amd64.deb libmpack binding for the Lua language
lua-nginx-cookie_0.1.0-1_all.deb Pure Lua cookie parser for the nginx embedded Lua language
lua-nginx-dns_0.20-1_all.deb DNS resolver for the nginx embedded Lua language
lua-nginx-kafka_0.07-1_all.deb Pure Lua Kafka producer for the nginx embedded Lua language
lua-nginx-memcached_0.14-1_all.deb Pure Lua memcached client driver for the nginx embedded Lua language
lua-nginx-redis-connector_0.06-1_all.deb Connection utilities for lua-nginx-redis
lua-nginx-redis_0.27-1_all.deb Pure Lua redis client driver for the nginx embedded Lua language
lua-nginx-string_0.11-1_all.deb String utilities for the nginx embedded Lua language
lua-nginx-websocket_0.06-1_all.deb Lua websocket client driver for the nginx embedded Lua language
lua-nvim-dev_0.2.0-1-1_amd64.deb Lua client for Neovim
lua-nvim_0.2.0-1-1_amd64.deb Lua client for Neovim
lua-orbit_2.2.1+dfsg-1_all.deb MVC web framework for Lua
lua-penlight-dev_1.3.2-2_all.deb Collection of general purpose libraries for the Lua language
lua-penlight_1.3.2-2_all.deb Collection of general purpose libraries for the Lua language
Advertisement
Advertisement