libutf8proc2_2.4.0-1_amd64.deb


Advertisement

Description

libutf8proc2 - C library for processing UTF-8 Unicode data (shared library)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libutf8proc2_2.4.0-1_amd64.deb
Package name libutf8proc2
Package version 2.4.0
Package release 1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://github.com/JuliaStrings/utf8proc
License -
Maintainer Debian Julia Team <pkg-julia-devel@lists.alioth.debian.org>
Download size 52.23 KB
Installed size 323.00 KB

Alternatives

Package Version Architecture Repository
libutf8proc2_2.4.0-1_i386.deb 2.4.0 i386 Debian Main
libutf8proc2 - - -

Requires

Name Value
libc6 >= 2.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libutf8proc2_2.4.0-1_amd64.deb
Source Package utf8proc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libutf8proc2 deb package:
    # sudo apt-get install libutf8proc2

Files

Path
/usr/lib/x86_64-linux-gnu/libutf8proc.so.2
/usr/lib/x86_64-linux-gnu/libutf8proc.so.2.3.1
/usr/share/doc/libutf8proc2/README.md.gz
/usr/share/doc/libutf8proc2/changelog.Debian.gz
/usr/share/doc/libutf8proc2/changelog.gz
/usr/share/doc/libutf8proc2/copyright

Changelog

2019-08-21 - Mo Zhou <cdluminate@gmail.com>
utf8proc (2.4.0-1) unstable; urgency=medium
* New upstream version 2.4.0
* Bump Standards-Version to 4.4.0 (no change).
* Delete d/compat in favor of debhelper-compat (= 11).
* Update patches:
* Rebase use-unicode-data.patch
- Remove unicode-data-12.1.0pre1.patch
- Remove utf8proc-unicode-version.patch
2019-04-27 - Mo Zhou <cdluminate@gmail.com>
utf8proc (2.3.0-1) unstable; urgency=medium
* New upstream version 2.3.0 (Closes: #927941)
* Bump unicode-data requirement to (>= 12.1) && (<< 12.2).
* Refresh use-unicode-data.patch; Remove pass-hardening-flags.patch (merged).
* Patch: update utf8proc_data.c against unicode-data 12.1.0~pre1.
* Patch: update unicode-data version strings to 12.1.0
* Patch: upstream didn't bump minor version in build system and header.
* Install the newly-added pkgconfig file. (Closes: #927260)
* Add a new symbol.
2018-07-27 - Graham Inggs <ginggs@debian.org>
utf8proc (2.2.0-1) unstable; urgency=medium
* New upstream release
* Drop patches no longer needed, refresh remaining
* Update debian/libutf8proc2.symbols
* Update debian/copyright
* New patch pass-hardening-flags.patch
2018-07-09 - Graham Inggs <ginggs@debian.org>
utf8proc (2.1.1-1) unstable; urgency=medium
[ Peter Colberg ]
* Update Vcs-* fields for move to salsa.debian.org
[ Graham Inggs ]
* New upstream release (Closes: #902902)
* Update upstream URLs for move to JuliaStrings
* Refresh patches
* Drop symbols of generated const tables, see upstream PR #100
* Add Mo Zhou to uploaders
* Switch to debhelper 11
* Trim trailing whitespace from debian/changelog
* Drop unnecessary get-orig-source target from debian/rules
* Bump Standards-Version to 4.1.5
* Switch to unicode-data 11 (Closes: #903381)
* Regenerate utf8proc_data.c from unicode-data 11
* Skip failing grapheme break tests
2017-07-08 - Graham Inggs <ginggs@debian.org>
utf8proc (2.1.0-1) unstable; urgency=medium
* New upstream release
* Switch to unicode-data 10 (Closes: #867105)
* Regenerate utf8proc_data.c from unicode-data 10
* Update debian/libutf8proc2.symbols
* Switch to debhelper 10
* Enable all hardening flags
* Bump Standards-Version to 4.0.0
* Update copyright, use https
2016-07-30 - Peter Colberg <peter@colberg.org>
utf8proc (2.0.2-1) unstable; urgency=medium
* New upstream release
2016-07-16 - Peter Colberg <peter@colberg.org>
utf8proc (2.0.1-1) unstable; urgency=medium
* New upstream release (Closes: #829236)
* Refresh patch
* Bump SONAME to libutf8proc2
* Update debian/libutf8proc2.symbols
* Update Vcs-* fields to use https
* Enable bindnow hardening flag
* Bump Standards-Version to 3.9.8
* Add debian/gbp.conf for pristine-tar
* Build depend on unicode-data >= 9.0 and << 9.1 for tests
2015-11-06 - Peter Colberg <peter@colberg.org>
utf8proc (1.3.1-2) unstable; urgency=medium
* Relax build-depends version for unicode-data.
2015-11-01 - Peter Colberg <peter@colberg.org>
utf8proc (1.3.1-1) unstable; urgency=medium
* Initial release. (Closes: #803681)

See Also

Package Description
libutfcpp-dev_2.3.4-1+b1_amd64.deb UTF8-CPP: UTF-8 with C++ - dev
libutfcpp-doc_2.3.4-1_all.deb UTF8-CPP: UTF-8 with C++ - dev
libutil-freebsd-9_10.3~svn296373-10_amd64.deb FreeBSD utility library
libutil-freebsd-dev_10.3~svn296373-10_amd64.deb Development files for libutil-freebsd
libutop-ocaml-dev_1.19.3-2+b7_amd64.deb improved OCaml toplevel (development tools)
libutop-ocaml_1.19.3-2+b7_amd64.deb improved OCaml toplevel (runtime library)
libuu-dev_0.5.20-11_amd64.deb Library for de/encoding several popular file encodings - development
libuu0_0.5.20-11_amd64.deb Library for de/encoding several popular file encodings - runtime
libuuid-perl_0.28-1+b1_amd64.deb Perl extension for using UUID interfaces as defined in e2fsprogs
libuuid-tiny-perl_1.0400-2_all.deb pure Perl module to generate v1, v3, v4, and v5 UUIDs
libuuid-urandom-perl_0.001-1_all.deb Perl module to provide UUIDs based on /dev/urandom
libuuid1_2.34-0.1_amd64.deb Universally Unique ID library
libuuidm-ocaml-dev_0.9.6-1+b4_amd64.deb Universally unique identifiers for OCaml
libuutf-ocaml-dev_1.0.1-2+b1_amd64.deb Non-blocking streaming Unicode codec for OCaml (development files)
libuutf-ocaml-doc_1.0.1-2_all.deb Non-blocking streaming Unicode codec for OCaml (documentation)
Advertisement
Advertisement