libsprng2_2.0a-12+b1_amd64.deb


Advertisement

Description

libsprng2 - SPRNG Scalable Parallel RNG library -- library package

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libsprng2_2.0a-12+b1_amd64.deb
Package name libsprng2
Package version 2.0a
Package release 12+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://www.sprng.org/
License -
Maintainer Dirk Eddelbuettel <edd@debian.org>
Download size 75.57 KB
Installed size 153.00 KB

Alternatives

Package Version Architecture Repository
libsprng2_2.0a-12_i386.deb 2.0a i386 Debian Main
libsprng2 - - -

Requires

Name Value
libc6 >= 2.14
libgmp10 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libsprng2_2.0a-12+b1_amd64.deb
Source Package sprng

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsprng2 deb package:
    # sudo apt-get install libsprng2

Files

Path
/usr/lib/libsprng.so.2
/usr/lib/libsprng.so.2.0
/usr/share/doc/libsprng2/changelog.Debian.amd64.gz
/usr/share/doc/libsprng2/changelog.Debian.gz
/usr/share/doc/libsprng2/copyright

Changelog

2018-07-21 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-12) unstable; urgency=medium
* debian/*: Update a few files while moving package to salsa.debian.org
* debian/rules: Allow cross tools use by invoking build via dh_auto_build
(with thanks to Helmut Grohne) 			(Closes: #904142)
2017-07-21 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-11) unstable; urgency=medium
* Makefile: Minor pedantic issue addressed		(Closes: #865692)
2016-03-23 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-10) unstable; urgency=medium
* SRC/insertmenu: Remove a bashism (with thanks to Reiner Herrmann, and
this time do it directly rather than rely on patch system)
(Closes: #818762)
* debian/control: Remove quilt from Build-Depends
2016-03-20 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-9) unstable; urgency=low
* debian/control: Switch libsprng2 to Section: libs
* SRC/insertmenu: Remove a bashism (with thanks to Reiner Herrmann)
(Closes: #818762)
* debian/rules: Use dh_prep instead of dh_clean -p
* debian/rules: Add build-arch, build-indep targets
* debian/control: Add quilt to Build-Depends
* debian/control: Updated Standards-Version: to 3.9.6
2011-05-18 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-8) unstable; urgency=low
* debian/rules, SRC/make.GENERIC: Applied patch kindly supplied by
Konstantinos Margaritis to address a build regression on armhf systems
(Closes: #627254)
* debian/control: Removed article from beginning of Description: 
[lintian]
2011-04-16 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-7) unstable; urgency=low
* SRC/pmlcg/longlong.h: Applied patch kindly supplied by Aurelien Jarno
to address builds on mips/mipsel with recent gcc versions (>= 4.4)
(Closes: #623015)  
2011-03-06 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-6) unstable; urgency=low
* debian/control: Updated Build-Depends: to libgmp-dev
* debian/control: Updated Standards-Version: to 3.9.1
2009-02-18 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-5) unstable; urgency=low
* debian/control: Changed Section: of libsprng2-doc to 'doc' to satisfy
a Lintian warning and a wishlist bug report		(Closes: #515925)
* debian/control: Updated Standards-Version: to 3.8.0
* debian/copyright: Updated to newer format
2007-08-12 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-4) unstable; urgency=low
* debian/control: Changed use ${binary:Version} and ${source:Version} to 
allow for binNMUs. Thanks to Lior Kaplan for the patch   (Closes: #437501)
* debian/control: Set Depends: of -doc toe (>= ${source:Version}) [lintian]
* debian/control: Upgraded Standards-Version: to 3.7.2
* debian/compat: Created, set version to 5
* debian/control: Upgraded Build-Depends to debhelper (>= 5.0.0)
* debian/rules: Changed 'make realclean' invocation [lintian]
2005-07-17 - Dirk Eddelbuettel <edd@debian.org>
sprng (2.0a-3) unstable; urgency=low
* SRC/sprng/Makefile: Add $(GMPLIB) to libsprng build (Closes: #318050)
* SRC/{make.GENERIC: Add ${GMPDEF} to CFLAGS and FFLAGS
* debian/control: Added libgmp3-dev to Depends for libsprng2-dev 
(Closes: #318051)
* debian/control: Increase Standards-Version: to 3.6.2.1

See Also

Package Description
libsptk-dev_3.9-2_amd64.deb speech signal processing toolkit - development files
libspullara-cli-parser-java_1.1.3~git20170531-1_all.deb command line parsing for Java
libsql-abstract-limit-perl_0.14.1-5_all.deb portable LIMIT emulation
libsql-abstract-more-perl_1.33-1_all.deb extension of SQL::Abstract with more constructs and more flexible API
libsql-abstract-perl_1.86-1_all.deb module to generate SQL from Perl data structures
libsql-reservedwords-perl_0.8-2_all.deb Perl extension that indicates if words are reserved by SQL
libsql-splitstatement-perl_1.00020-3_all.deb Split any SQL code into atomic statements
libsql-statement-perl_1.412-1_all.deb module for parsing and processing SQL statements
libsql-tiny-perl_0.04-1_all.deb simple SQL-building library
libsql-tokenizer-perl_0.24-5_all.deb simple SQL tokenizer
libsql-translator-perl_0.11024-1_all.deb SQL translation library
libsqlcipher-dev_3.4.1-1+b13_amd64.deb SQLCipher development files
libsqlcipher0_3.4.1-1+b13_amd64.deb SQLCipher shared library
libsqlclient-dev_1.8.1-3+b1_amd64.deb SQL client library for GNUstep (development files)
libsqlclient1.8_1.8.1-3+b1_amd64.deb SQL client library for GNUstep (runtime library)
Advertisement
Advertisement