libsigrokcxx4_0.5.0-3_amd64.deb


Advertisement

Description

libsigrokcxx4 - sigrok hardware driver library - shared library

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: libsigrokcxx4
Package version: 0.5.0
Package release: 3
Package architecture: amd64
Package type: deb
Installed size: 695 B
Download size: 434.32 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: libsigrok

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libsigrokcxx4 deb package:
      # sudo apt-get install libsigrokcxx4

    Changelog

    2017-09-18 - Jonathan McDowell <noodles@earth.li> libsigrok (0.5.0-3) unstable; urgency=medium * Fix unit tests on i386 by casting floats to doubles. * Upload to unstable.

    2017-08-28 - Jonathan McDowell <noodles@earth.li> libsigrok (0.5.0-2) experimental; urgency=medium * Update debian/copyright.

    2017-08-15 - Jonathan McDowell <noodles@earth.li> libsigrok (0.5.0-1) experimental; urgency=medium * New upstream release. + The libsigrok2 package now becomes libsigrok4 (upstream SO name change). + Add build-dep on libieee1284-3-dev to enable hung-chang-dso-2100 driver + Add new C++ library, libsigrokcxx4. * Move to libftdi1-dev (Closes: #810376) * Add build-dep on check to enable unit tests * Remove old transitional libsigrok0-dev package. * Move maintenance to Debian Electronics Packaging Team (Closes: #852830) * Standards-Version: 4.0.1 (change priority to optional).

    2014-05-24 - Uwe Hermann <uwe@debian.org> libsigrok (0.3.0-1) unstable; urgency=medium * Acknowledge NMU, thanks David Prévot (Closes: #724126). * New upstream release. + Bump version of libusb-1.0-0-dev build-dep to >= 1.0.16. + Bump version of libzip-dev build-dep to >= 0.10. + Add build-dep on libserialport >= 0.1.0. + Drop build-deps on no longer used libudev and libasound. + The libsigrok1 package now becomes libsigrok2 (upstream SO name change). * Switch from cdbs to debhelper. * Add multiarch support: + Bump build-depend on debhelper (>= 9). + Add "Pre-Depends: ${misc:Pre-Depends}" to the lib package. + debian/compat: Bump version to 9. + Adapt the paths in *.install files. + Add "Multi-Arch: same" to the lib and -dev package. * Standards-Version: 3.9.5 (no changes required). * Use dh-autoreconf instead of autotools-dev in order to fix FTBFS on (e.g.) ppc64el (Closes: #744061). Thanks Logan Rosen <logan@ubuntu.com>! * Bring back accidentally missing udev rules file (Closes: #737766). Thanks Roland Hieber <rohieb@rohieb.name> for the report!

    2013-12-26 - David Prévot <taffit@debian.org> libsigrok (0.2.0-2.1) unstable; urgency=medium * Non-maintainer upload. * Add libasound2-dev as a build-dependency, and as a dependency to libsigrok-dev. Closes: #724126

    2013-08-26 - Uwe Hermann <uwe@debian.org> libsigrok (0.2.0-2) unstable; urgency=low * Fixed upload for 0.2.0-1 (which never left the NEW queue). * The upstream SONAME bumped to 1, so change the lib package name to libsigrok1. However, only use one libsigrok-dev always, i.e. don't encode the SONAME in the -dev package name (as per FTP Master recommendation). Since the old name was libsigrok0-dev, add a transitional package to nicely handle the transition.

    2013-05-28 - Uwe Hermann <uwe@debian.org> libsigrok (0.2.0-1) unstable; urgency=low * New upstream release. + Bump version of libglib2.0-dev build-dep to >= 2.32.0. + Bump version of libusb-1.0-0-dev build-dep to >= 1.0.9. + API and ABI changed, so change package name to libsigrok1*. * Standards-Version: 3.9.4 (no changes required). * debian/watch: Update to new download URLs. * debian/libsigrok1.docs: Add file (installs README.devices).

    2012-07-08 - Uwe Hermann <uwe@debian.org> libsigrok (0.1.1-1) unstable; urgency=low * New upstream release. * Drop zlib dependency, no longer needed upstream.

    2012-05-23 - Uwe Hermann <uwe@debian.org> libsigrok (0.1.0-2) unstable; urgency=low * libsigrok0-dev: Add missing dependencies on -dev libs.

    2012-04-21 - Uwe Hermann <uwe@debian.org> libsigrok (0.1.0-1) unstable; urgency=low * Initial release (Closes: #669070).

    Advertisement
    Advertisement