libservice-wrapper-jni_3.5.30-1+b1_amd64.deb


Advertisement

Description

libservice-wrapper-jni - Jar daemon wrapper JNI libraries

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libservice-wrapper-jni_3.5.30-1+b1_amd64.deb
Package name libservice-wrapper-jni
Package version 3.5.30
Package release 1+b1
Package architecture amd64
Package type deb
Category java role::shared-lib
Homepage http://wrapper.tanukisoftware.com
License -
Maintainer Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Download size 90.57 KB
Installed size 138.00 KB

Alternatives

Package Version Architecture Repository
libservice-wrapper-jni_3.5.30-1_i386.deb 3.5.30 i386 Debian Main
libservice-wrapper-jni - - -

Requires

Name Value
default-jre-headless -
java5-runtime-headless -
java6-runtime-headless -
java7-runtime-headless -
libc6 >= 2.14

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libservice-wrapper-jni_3.5.30-1+b1_amd64.deb
Source Package service-wrapper-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libservice-wrapper-jni deb package:
    # sudo apt-get install libservice-wrapper-jni

Files

Path
/usr/lib/jni/libwrapper.so
/usr/share/doc/libservice-wrapper-jni/changelog.Debian.amd64.gz
/usr/share/doc/libservice-wrapper-jni/changelog.Debian.gz
/usr/share/doc/libservice-wrapper-jni/changelog.gz
/usr/share/doc/libservice-wrapper-jni/copyright

Changelog

2016-12-19 - Emmanuel Bourg <ebourg@apache.org>
service-wrapper-java (3.5.30-1) unstable; urgency=medium
* Team upload.
* New upstream release
- Refreshed the patches
- License updated to Community Software License Agreement 1.3
* Standards-Version updated to 3.9.8
* Switch to debhelper level 10
* Use secure Vcs-* URLs
2015-08-31 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.26-3) unstable; urgency=medium
* Apply patch to fix FTBFS on ppc and adjust arch list.
Thank you to Matthias Klose for the patch.  (Closes: #797460)
2015-07-12 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.26-2) unstable; urgency=medium
* Modify architectures built for this package.
- drop sparc, kfreebsd-i386, and kfreebsd-amd64
- add ppc64el
2015-07-11 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.26-1) unstable; urgency=medium
* New upstream release.
* Update debian/copyright with version 1.2 of the
Tanuki Software, Ltd. Community Software License Agreement
* Add arm64 to list of architectures and add makefile to
0003-additional-makefiles.patch (Closes: #791951).
* Refresh patches for new upstream release.
* Bump Standards-Version to 3.9.6 (no changes).
2014-08-29 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.25-2) unstable; urgency=medium
* Correct typo in patch for kfreebsd-x86-32 makefile to resolve build
failure on kfreebsd.
2014-08-28 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.25-1) unstable; urgency=medium
[ Kill Your TV ]
* Team upload.  
* New upstream release. (Closes: #759565)
* debian/control
- add java7-runtime-headless as an alternate to satisfy the java
dependencies
- drop build dependency on hardening-wrapper as this package is now
obsolete.
- build depend on  libcunit1-ncurses-dev, libncurses5-dev
* hardening
- Add ldflags.patch to insert a LDFLAGS variable into the upstream
makefiles so that hardening LDFLAGS can be used in the build. As noted
above, hardening-wrapper is no longer used as it's obsolete.
- Update additional-makefiles.patch and kfreebsd-support.patch to add the
LDFLAGS variable
[ tony mancill ]
* Add a minimal get-orig-source target to debian/rules.
* Update Vcs- fields to use canonical URLs.
2014-04-16 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.22-3) unstable; urgency=low
* Correct bug number typo in previous upload.
* Add additional-makefiles.patch - see #730010
- s390x
- mips
- mipsel
- sparc
* Maintainer is now the Java Team.
* Change Vcs URLs from collab-maint to pkg-java.
2013-11-21 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.22-2) unstable; urgency=low
* Only build for upstram supported architectures. See: #730010
- amd64 armel armhf i386 ia64 kfreebsd-amd64 kfreebsd-i386 powerpc
* Add patch for bashisms in daemon.sh script.  (Closes: #690722)
2013-11-09 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.22-1) unstable; urgency=low
* New upstream release.  (Closes: #610374)
- Thanks to Kill Your TV <killyourtv@i2pmail.org> for updated packaging.
* debian/control
- Build-depend on debhelper >=9, default-jdk.
- Depend on -headless JDK, hardening-wrapper.
- Bump Standards-Version to 3.9.5 (no changes).
* debian/rules
- Enable build hardening.
- Tweak for new upstream release.
* Add javadocs in -doc package.
* Now allow any arch to be built.
* Separate preinst scripts for -jni and -java packages.
2013-03-24 - tony mancill <tmancill@debian.org>
service-wrapper-java (3.5.3+repack-1) UNRELEASED; urgency=low
* Team upload.
* Acknowledge NMU - thank you to Michael Gilbert (Closes: #702790)
* Add d/watch file.  Thank you to gregor herrmann.

See Also

Package Description
libservlet-api-java-doc_4.0.1-2_all.deb Java Servlet API (documentation)
libservlet-api-java_4.0.1-2_all.deb Java Servlet API
libservlet3.1-java_4.0.1-2_all.deb Java Servlet API 3.1 (transitional package)
libsession-storage-secure-perl_0.011-1_all.deb module implementing a secure way to encode session data
libsession-token-perl_1.503-1+b5_amd64.deb secure, efficient, simple random session token generation
libset-crontab-perl_1.03-1_all.deb Expand crontab-style integer lists
libset-infinite-perl_0.65-1_all.deb module for sets of intervals
libset-intervaltree-perl_0.12-1+b2_amd64.deb Perform range-based lookups on sets of ranges
libset-intspan-perl_1.19-1_all.deb module to manage sets of integers
libset-nestedgroups-perl_0.01-3_all.deb Simple implementation of nested groups
libset-object-perl_1.39-1+b2_amd64.deb collection of objects without duplications
libset-scalar-perl_1.29-2_all.deb Perl interface for operations on finite sets
libset-tiny-perl_0.04-1_all.deb module for simple sets of strings
libsexplib-ocaml-dev_113.33.03-3_amd64.deb automated conversions between OCaml-values and S-expressions (dev files)
libsexplib-ocaml_113.33.03-3_amd64.deb automated conversions between OCaml-values and S-expressions (runtime)
Advertisement
Advertisement