libselinux1_2.7-2_amd64.deb


Advertisement

Description

libselinux1 - SELinux runtime shared libraries

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: libselinux1
Package version: 2.7
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 193 B
Download size: 83.94 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

Alternatives

    Download

    Source package: libselinux

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libselinux1 deb package:
      # sudo apt-get install libselinux1

    Changelog

    2017-09-15 - Laurent Bigonville <bigon@debian.org> libselinux (2.7-2) unstable; urgency=medium [ Helmut Grohne ] * Fix FTCBFS: Add the host architecture to pkg-config (Closes: #875507) * Use profiles nopython and noruby rather than stage1. (Closes: #875573)

    2017-09-09 - Laurent Bigonville <bigon@debian.org> libselinux (2.7-1) unstable; urgency=medium * New upstream release - Bump libsepol1-dev build-dependency to >= 2.7 to match the release * Bump debhelper compatibility to 10 * Bump Standards-Version to 4.1.0 (no further changes) * debian/control: Remove Manoj from the uploader list and add myself instead. Thanks to him for all the work in the past. * Convert DEB_STAGE to DEB_BUILD_PROFILES (Closes: #869941)

    2017-06-21 - Laurent Bigonville <bigon@debian.org> libselinux (2.7~rc2-1) experimental; urgency=medium * Team upload. * New upstream release candidate (Closes: #864479, #863854) - debian/patches/: Drop all patches, applied upstream - Bump libsepol1-dev build-dependency to >= 2.7~ to match the release - debian/libselinux1.symbols: Adjust the .symbols file, selabel_subs_init is not exported anymore but was never part of the API in the first place * debian/watch: Add support for rc releases and use macros * debian/control: Bump Standards-Version to 4.0.0 (no further changes) * debian/ruby.mk: Fix the build of the ruby binding and link against libruby (Closes: #819200) * debian/python.mk: - Do not explicityly link the python binding against libpython, this is against the best practices in debian - Use pkg-config to determine the python include directories

    2016-11-06 - Laurent Bigonville <bigon@debian.org> libselinux (2.6-3) unstable; urgency=medium * Team upload. [ Christian Seiler ] * Add libselinux1-udeb (depended on by libmount1-udeb) (Closes: #835503)

    2016-11-06 - Laurent Bigonville <bigon@debian.org> libselinux (2.6-2) unstable; urgency=medium * Team upload. * Fix python binding under python3, some strings were represented as arrays of bytes instead of python strings

    2016-10-29 - Laurent Bigonville <bigon@debian.org> libselinux (2.6-1) unstable; urgency=medium * Team upload. * New upstream release - Bump libsepol1-dev build-dependency to >= 2.6 to match the release - Make the build reproducible (Closes: #825655) - Drop 0003-Avoid-mounting-proc-outside-of-selinux_init_load_pol.patch, merged upstream - debian/patches/fix-makefile-bugs.patch, debian/patches/fix-cross-compile.patch: Refreshed - debian/python.mk: Fix python wrapper build - debian/libselinux1.symbols: Adjust the .symbols files, myprintf and obj_class_compat were never part of the public API * debian/libselinux1.symbols: Add the Build-Depends-Package field * debian/gbp.conf: Rename git-buildpackage section to buildpackage

    2016-05-17 - Laurent Bigonville <bigon@debian.org> libselinux (2.5-3) unstable; urgency=medium * Team upload. * Do not try to mount /proc during the libselinux initialization, in some use cases /proc is not mounted at early boot and mounting/unmounting it later might cause race conditions. (Closes: #823184)

    2016-04-30 - Laurent Bigonville <bigon@debian.org> libselinux (2.5-2) unstable; urgency=medium * Team upload. * d/p/only-mount-procfs-necessary.patch: Only mount /proc if necessary (Closes: #822679)

    Advertisement
    Advertisement