librubberband-dev_1.8.1-7_amd64.deb


Advertisement

Description

librubberband-dev - audio time-stretching and pitch-shifting library (development files)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name librubberband-dev
Package version 1.8.1
Package release 7
Package architecture amd64
Package type deb
Installed size 539 B
Download size 94.02 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
librubberband-dev_1.8.1-7_i386.deb 1.8.1 i386 Debian Main
librubberband-dev - - -

Requires

Name Value
dpkg >= 1.17.5
dpkg >= 1.17.14
librubberband2 = 1.8.1-7

Download

Type URL
Binary Package librubberband-dev_1.8.1-7_amd64.deb
Source Package rubberband

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install librubberband-dev deb package:
    # sudo apt-get install librubberband-dev

Files

Path
/usr/include/rubberband/RubberBandStretcher.h
/usr/include/rubberband/rubberband-c.h
/usr/lib/x86_64-linux-gnu/librubberband.a
/usr/lib/x86_64-linux-gnu/librubberband.so
/usr/lib/x86_64-linux-gnu/pkgconfig/rubberband.pc
/usr/share/doc/librubberband-dev/changelog.Debian.gz
/usr/share/doc/librubberband-dev/changelog.gz
/usr/share/doc/librubberband-dev/copyright

Changelog

2016-12-24 - Jaromír Mikeš <mira.mikes@seznam.cz>
rubberband (1.8.1-7) unstable; urgency=medium
* Set dh/compat 10.
* Update copyright file.
* Sign tags.
* Bump Standards.
* Fix VCS fields.
* Add missing substitution variable.
* Append flags correctly.
2014-11-08 - Sebastian Ramacher <sramacher@debian.org>
rubberband (1.8.1-6) unstable; urgency=medium
* Team upload.
* Fix symlink to directory conversions. (Closes: #768270)
- debian/rubberband-{vamp,ladspa}.maintscript: call symlink_to_dir
correctly and rename files to the name expected by dh_installdeb.
- debian/preinst: removed. It was intended for rubberband-cli, but got
placed in librubberband2.
- debian/{librubberband-dev, rubberband-cli}.maintscript: handle symlink
to directory conversion.
- debian/control: Add necessary Pre-Depends on dpkg (>= 1.17.5) for
symlink_to_dir support in dpkg-maintscript-helper.
2014-02-26 - Jaromír Mikeš <mira.mikes@seznam.cz>
rubberband (1.8.1-5) unstable; urgency=low
* Added maintscript files (Closes: #736298).
* Bump Standards.
2013-08-25 - Jaromír Mikeš <mira.mikes@seznam.cz>
rubberband (1.8.1-4) unstable; urgency=low
* Added preinst script (Closes: #720154)
2013-06-05 - Jaromír Mikeš <mira.mikes@seznam.cz>
rubberband (1.8.1-3) unstable; urgency=low
* Fix build on armel 2nd attempt.
2013-06-05 - Jaromír Mikeš <mira.mikes@seznam.cz>
rubberband (1.8.1-2) unstable; urgency=low
* Added patch to fix build on armel.
2013-01-15 - Alessio Treglia <alessio@debian.org>
rubberband (1.8.1-1) unstable; urgency=low
* Team upload.
[ Alessio Treglia ]
* New upstream release.
* Fix missing VCS fields.
* Don't sign tags.
* Set compression to bz2.
* Fix debian/copyright.
* Bump Standards.
[ Jaromír Mikeš ]
* Removed spell-fixing patch, applied upstream.
* Refreshed multiarch patch.
2012-09-24 - Jaromír Mikeš <mira.mikes@seznam.cz>
rubberband (1.7.0-1) unstable; urgency=low
[ Jaromír Mikeš ]
* New upstream release
(Closes: #627318)(Closes: #685831).
* Adopt package (Closes: #688623).
* Bump Standards.
* Set priority optional.
* Switch to short dh format 3.0
* Remove duplicating section fields.
* Set compat/dh 9 to fix hardening.
* Fix description.
* Added misc:Depends for librubberband-dev package.
* Update copyright file.
* Introduce multiarch support.
* Added patch fixing spelling.
* Fix watch file.
[ Alessio Treglia ]
* debian/patches/02-fix_multiarch.patch:
- Let pkg-config file be ready for multi-arch as well.
2012-05-27 - gregor herrmann <gregoa@debian.org>
rubberband (1.3-1.3) unstable; urgency=low
* Non-maintainer upload.
[ Cyril Brulebois ]
* Fix FTBFS with gcc 4.7 by fixing missing <unistd.h> include
(Closes: #667362).
2011-11-01 - Mike O'Connor <stew@debian.org>
rubberband (1.3-1.2) unstable; urgency=low
* Non-maintainer upload.
* include <cstddef> in RubberBandStretcher.h (Closes: #625012)

See Also

Package Description
librubberband2_1.8.1-7_amd64.deb audio time-stretching and pitch-shifting library
libruby2.5_2.5.1-6+b1_amd64.deb Libraries necessary to run Ruby 2.5
libruby_2.5.1_all.deb Libraries necessary to run Ruby
librudecgi-dev_5.0.0-1.1+b2_amd64.deb C++ parser library for CGI applications - development libraries
librudecgi5_5.0.0-1.1+b2_amd64.deb C++ parser library for CGI applications - runtime
libruli-bin_0.33-1.1+b2_amd64.deb Library for easily querying DNS SRV records - sample programs
libruli4-dev_0.33-1.1+b2_amd64.deb Library for easily querying DNS SRV records - development files
libruli4_0.33-1.1+b2_amd64.deb Library for easily querying DNS SRV records
librun-parts-perl_0.09-2_all.deb Offers run-parts' functionality in Perl
librunapp-perl_0.13-2_all.deb generic module to run web-applications
librunning-commentary-perl_0.000005-1_all.deb Perl module to call system() with tracking messages
librust-adler32-dev_1.0.3-1_amd64.deb Minimal Adler32 implementation for Rust - Rust source code
librust-aho-corasick-dev_0.6.8-1_amd64.deb Fast multiple substring searching with finite state machines - Rust source code
librust-ansi-term-dev_0.11.0-1_amd64.deb ANSI terminal colours and styles (bold, underline) - Rust source code
librust-ar-dev_0.6.0-1_amd64.deb Encoding/decoding Unix archive files - Rust source code
Advertisement
Advertisement