libreadline-gplv2-dev_5.2+dfsg-3+b2_amd64.deb


Advertisement

Description

libreadline-gplv2-dev - GNU readline and history libraries, development files

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libreadline-gplv2-dev
Package version 5.2+dfsg
Package release 3+b2
Package architecture amd64
Package type deb
Installed size 664 B
Download size 122.43 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libreadline-gplv2-dev_5.2+dfsg-3+b2_i386.deb 5.2+dfsg i386 Debian Main
libreadline-gplv2-dev - - -

Requires

Name Value
libreadline5 = 5.2+dfsg-3+b2
libtinfo-dev -

Conflicts

Name Value
libreadline-dev -
libreadline5-dev -
libreadline6-dev -

Replaces

Name Value
libreadline5-dev -

Download

Type URL
Binary Package libreadline-gplv2-dev_5.2+dfsg-3+b2_amd64.deb
Source Package readline5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libreadline-gplv2-dev deb package:
    # sudo apt-get install libreadline-gplv2-dev

Files

Path
/usr/include/readline/chardefs.h
/usr/include/readline/history.h
/usr/include/readline/keymaps.h
/usr/include/readline/readline.h
/usr/include/readline/rlconf.h
/usr/include/readline/rlstdc.h
/usr/include/readline/rltypedefs.h
/usr/include/readline/tilde.h
/usr/lib/x86_64-linux-gnu/libhistory.a
/usr/lib/x86_64-linux-gnu/libhistory.so
/usr/lib/x86_64-linux-gnu/libreadline.a
/usr/lib/x86_64-linux-gnu/libreadline.so
/usr/share/doc/libreadline-gplv2-dev
/usr/share/doc/libreadline5/examples/Makefile
/usr/share/doc/libreadline5/examples/excallback.c
/usr/share/doc/libreadline5/examples/fileman.c
/usr/share/doc/libreadline5/examples/histexamp.c
/usr/share/doc/libreadline5/examples/manexamp.c
/usr/share/doc/libreadline5/examples/rl-fgets.c
/usr/share/doc/libreadline5/examples/rl.c
/usr/share/doc/libreadline5/examples/rlcat.c
/usr/share/doc/libreadline5/examples/rlptytest.c
/usr/share/doc/libreadline5/examples/rltest.c
/usr/share/doc/libreadline5/examples/rlversion.c

Changelog

2015-05-27 - Helmut Grohne <helmut@subdivi.de>
readline5 (5.2+dfsg-3) unstable; urgency=medium
* QA upload.
* Enable hardening build flags.
* Remove unused multilib packages.
* Use architecture qualified compiler. Closes: #784669.
* Refer to GPL-2 instead of GPL{-3,} in copyright as the sole purpose of
this package is being licensed under GPL-2.
* Declare source format 1.0.
* Remove install-info from obsolete maintscripts and install-info
dependency to comply with Debian policy 12.2.
* Verified compliance with Debian policy 3.9.6.
2013-04-27 - Florian Schlichting <fsfs@debian.org>
readline5 (5.2+dfsg-2) unstable; urgency=low
* QA upload.
* Fix multiarch bug, again; the +dfsg suffix broke the previous fix.
Closes: #670028.
2012-12-30 - David Prévot <taffit@debian.org>
readline5 (5.2+dfsg-1) unstable; urgency=low
* QA upload.
* Remove unused and non DFSG-compliant files from source:
doc/{history,rlman,rluserman,readline}.{dvi,html,info,pdf,ps,texi}.
history and readline thus removed from /usr/share/info/ in
libreadline-gplv2-dev. Closes: #695790.
2012-09-18 - Matthias Klose <doko@debian.org>
readline5 (5.2-12) unstable; urgency=low
[ Florian Schlichting ]
* libreadline-gplv2-dev: explicitly conflict against libreadline6-dev.
Closes: #670111.
* libreadline-gplv2-dev: substitute build- and architecture-dependant paths
in examples/Makefile with their actual, arch-indep value.
Closes: #658850, #670028.
[ Matthias Klose ]
* Orphan the package.
2011-10-04 - Matthias Klose <doko@debian.org>
readline5 (5.2-11) unstable; urgency=low
* Do not link against any libncurses* library, just against libtinfo.
* libreadline-gplv2-dev: Depend on libtinfo-dev instead of libncurses5-dev.
2011-08-22 - Matthias Klose <doko@debian.org>
readline5 (5.2-10) unstable; urgency=low
* Add multi-arch support (Riku Voipio). Closes: #638851.
2011-07-09 - Matthias Klose <doko@debian.org>
readline5 (5.2-9) unstable; urgency=low
* libreadline-gplv2-dev: Stop providing libreadline5-dev.
2011-04-23 - Matthias Klose <doko@debian.org>
readline5 (5.2-8) unstable; urgency=low
* Rename libreadline5-dev to libradline-gplv2-dev. Some packages
still need readline5 for license compatibility, others should
convert to readline6.
* Fix some lintian warnings.
2009-11-02 - Matthias Klose <doko@debian.org>
readline5 (5.2-7) unstable; urgency=low
* libreadline5-dev: Stop providing libreadline-dev.
* libreadline5-dbg: Add libc6 dependencies to satisfy pedantic views
on the policy. Closes: #553251.
2009-08-24 - Matthias Klose <doko@debian.org>
readline5 (5.2-6) unstable; urgency=low
* Set priority of packages to extra (readline6 is the preferred choice).
* Don't build rlfe and readline-common anymore, now built by readline6.

See Also

Package Description
libreadline-java-doc_0.8.0.1+dfsg-9_all.deb API docs for readline/editline wrappers for Java
libreadline-java_0.8.0.1+dfsg-9_amd64.deb GNU readline and BSD editline wrappers for Java
libreadline5_5.2+dfsg-3+b2_amd64.deb GNU readline and history libraries, run-time libraries
libreadline7_7.0-5_amd64.deb GNU readline and history libraries, run-time libraries
libreadonly-perl_2.050-1_all.deb facility for creating read-only scalars, arrays and hashes
libreadonly-xs-perl_1.05-1+b6_amd64.deb faster Readonly implementation
libreadosm-dev_1.1.0+dfsg-3_amd64.deb simple library to parse OpenStreetMap files - headers
libreadosm-doc_1.1.0+dfsg-3_all.deb simple library to parse OpenStreetMap files - documentation
libreadosm1_1.1.0+dfsg-3_amd64.deb simple library to parse OpenStreetMap files
librec-dev_1.7-2_amd64.deb recutils development files
librec1_1.7-2_amd64.deb library for accessing recfiles programmatically
librecad-data_2.1.3-1.1_all.deb Computer-aided design (CAD) system -- shared files
librecad_2.1.3-1.1_amd64.deb Computer-aided design (CAD) system
librecode-dev_3.6-23_amd64.deb Development package for librecode0
librecode0_3.6-23_amd64.deb Shared library on which recode is based
Advertisement
Advertisement