librarian-dev_0.8.1-6+b1_amd64.deb


Advertisement

Description

librarian-dev - Documentation meta-data library (header files)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name librarian-dev
Package version 0.8.1
Package release 6+b1
Package architecture amd64
Package type deb
Installed size 114 B
Download size 39.84 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
librarian-dev_0.8.1-6+b1_i386.deb 0.8.1 i386 Debian Main
librarian-dev - - -

Requires

Name Value
librarian0 = 0.8.1-6+b1

Download

Type URL
Binary Package librarian-dev_0.8.1-6+b1_amd64.deb
Source Package rarian

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install librarian-dev deb package:
    # sudo apt-get install librarian-dev

Files

Path
/usr/include/rarian/rarian-info.h
/usr/include/rarian/rarian-main.h
/usr/include/rarian/rarian-man.h
/usr/include/rarian/rarian-reg-utils.h
/usr/include/rarian/rarian.h
/usr/lib/librarian.so
/usr/lib/pkgconfig/rarian.pc
/usr/share/doc/librarian-dev/NEWS.gz
/usr/share/doc/librarian-dev/README.gz
/usr/share/doc/librarian-dev/TODO
/usr/share/doc/librarian-dev/changelog.Debian.amd64.gz
/usr/share/doc/librarian-dev/changelog.Debian.gz
/usr/share/doc/librarian-dev/changelog.gz
/usr/share/doc/librarian-dev/copyright
/usr/share/help/rarian.document
/usr/share/librarian/manual/help-spec-0.2.xml
/usr/share/librarian/manual/index.xhtml
/usr/share/librarian/manual/rar-lib.xhtml
/usr/share/librarian/manual/rar-mdf.xhtml
/usr/share/librarian/manual/rar-skcompat.xhtml

Changelog

2014-09-03 - Michael Biebl <biebl@debian.org>
rarian (0.8.1-6) unstable; urgency=low
[ Josselin Mouette ]
* Update repository URL.
[ Colin Watson ]
* Use dh-autoreconf to update libtool macros for new ports. This also
requires fixing an m4 syntax error in configure.ac and removing the
nonexistent "dist-gzip" Automake option. Closes: #732588
[ Michael Biebl ]
* Switch the Maintainer to pkg-gnome-maintainers@lists.alioth.debian.org.
* Use canonical Vcs-* URLs.
* Override lintian error about embedding the tinyxml library. This would
lead to an ftp-master autoreject otherwise. While this is not an ideal
solution, porting to the tinyxml system library is non-trivial due to
changes in the API.
2010-07-04 - Josselin Mouette <joss@debian.org>
rarian (0.8.1-5) unstable; urgency=low
* Switch to 3.0 source format.
* 03_language.patch: new patch. Make librarian obey to LC_MESSAGES.
Closes: #588060.
* Fix a spelling error in description.
2010-03-03 - Tommi Vainikainen <thv+debian@iki.fi>
rarian (0.8.1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Clean-up old scrollkeeper's XML catalog so that rarian-compat can
register its own catalog. Closes: #532271.
2009-08-27 - Josselin Mouette <joss@debian.org>
rarian (0.8.1-4) unstable; urgency=low
* Build a dummy scrollkeeper package to facilitate upgrades.
* Small improvements in short descriptions.
2009-07-02 - Emilio Pozuelo Monfort <pochu@ubuntu.com>
rarian (0.8.1-3) unstable; urgency=low
* debian/patches/02_crash_no_extension.patch: Patch by Loïc Minier to
fix a crash when opening files without dots in their filename.
Closes: #535433.
* debian/rules: Reorder includes.
* debian/control.in: Wrap depends.
* Standards-Version is 3.8.2, no changes needed.
* Add Vcs-* fields.
* debian/control.in: Inherit the Section from the source stanza where
it's duplicated.
* debian/librarian-dev.install: Install the rarian.document file.
Change taken from Ubuntu.
2009-04-07 - Josselin Mouette <joss@debian.org>
rarian (0.8.1-2) unstable; urgency=low
* debian/*.dtd: ship the DTDs currently in the scrollkeeper package to 
ensure full compatibility.
* debian/catalog.xml, debian/rarian-compat.xmlcatalogs: same for the 
catalog.
* Call dh_installxmlcatalogs, build-depend on xml-core.
2008-09-02 - Josselin Mouette <joss@debian.org>
rarian (0.8.1-1) unstable; urgency=low
* New upstream bugfix release.
+ Fixes crash when loading an unknown info URI. Closes: #495092.
* 01_info_shortnames.patch: patch from JHM Dassen (Ray), modified a 
bit. Allow to specify only the prefix of an info page (e.g. gcc for 
gcc-4.3). Closes: #462332.
* Standards version is 3.8.0, no changes.
* Update homepage and copyright to the new URL.
2008-08-08 - Frederic Peters <fpeters@debian.org>
rarian (0.8.0-2) unstable; urgency=low
* debian/librarian-dev.install, debian/rarian-compat.install:
+ ship rarian-sk-cl.xml and scrollkeeper_cl.xml in rarian-compat, as they
are required and only used by rarian-compat tools.  (closes: #494358)
* debian/control{.in}: add docbook-xml as a rarian-compat dependency.
(closes: #494359)
2008-03-14 - Sebastian Dröge <slomo@debian.org>
rarian (0.8.0-1) unstable; urgency=low
[ Loic Minier ]
* Cleanup whitespace.
[ Sebastian Dröge ]
* New upstream stable release:
+ debian/copyright:
- Updated, taken from the Ubuntu package.
+ debian/control.in:
- Update Standards-Version to 3.7.3, no additional changes needed.
- Move homepage to the Homepage field.
- Let librarian0 conflict with yelp << 2.21, taken from the Ubuntu
package.
+ debian/rules:
- Update shlibs to >= 0.8.0 because of new API.
2007-09-13 - Frederic Peters <fpeters@debian.org>
rarian (0.6.0-1) unstable; urgency=low
* New upstream release.
* First upload to Debian.
* debian/control{,.in}: removed duplicated Uploaders: field.

See Also

Package Description
librarian-puppet-simple_0.0.5-3_all.deb simple version of librarian-puppet with most of its commands
librarian-puppet_3.0.0-1_all.deb bundler for your puppet modules
librarian0_0.8.1-6+b1_amd64.deb Documentation meta-data library (library package)
libraspell-ruby1.8_1.3-1_all.deb Transitional package for raspell
libraspell-ruby1.9.1_1.3-1_all.deb Transitional package for raspell
libraspell-ruby_1.3-1_all.deb Transitional package for raspell
librasqal3-dev_0.9.32-1+b1_amd64.deb Rasqal RDF query library development libraries and headers
librasqal3-doc_0.9.32-1_all.deb Documentation for the Rasqal RDF Query library
librasqal3_0.9.32-1+b1_amd64.deb Rasqal RDF query library
librasterlite2-1_1.1.0~beta0+really1.0.0~rc0+devel1-1_amd64.deb library for huge raster coverages using a SpatiaLite DBMS
librasterlite2-dev_1.1.0~beta0+really1.0.0~rc0+devel1-1_amd64.deb library for huge raster coverages using a SpatiaLite DBMS - headers
libratbag-common_0.9-5_all.deb configuration library for gaming mice - common files
libratbag-dev_0.9-5_amd64.deb configuration library for gaming mice - development files
libratbag-doc_0.9-5_all.deb configuration library for gaming mice - documentation
libratbag-tools_0.9-5_amd64.deb configuration tools for gaming mice
Advertisement
Advertisement