libpycaml-ocaml_0.82-15+b1_amd64.deb


Advertisement

Description

libpycaml-ocaml - OCaml bindings to embed Python interpreter (runtime)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package name libpycaml-ocaml
Package version 0.82
Package release 15+b1
Package architecture amd64
Package type deb
Installed size 62 B
Download size 13.66 KB
Official Mirror ftp.br.debian.org
Description -

Alternatives

Package Version Architecture Repository
libpycaml-ocaml_0.82-15+b1_i386.deb 0.82 i386 Debian Main
libpycaml-ocaml - - -

Requires

Name Value
libc6 >= 2.14
libpython2.7 >= 2.7
ocaml-base-nox-4.05.0 -

Provides

Name Value
libpycaml-ocaml-uf206 -

Replaces

Name Value
pycaml << 0.82-12~

Download

Type URL
Binary Package libpycaml-ocaml_0.82-15+b1_amd64.deb
Source Package pycaml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpycaml-ocaml deb package:
    # sudo apt-get install libpycaml-ocaml

Files

Path
/usr/lib/ocaml/stublibs/dllpycaml_stubs.so
/usr/share/doc/libpycaml-ocaml/NEWS.Debian.gz
/usr/share/doc/libpycaml-ocaml/changelog.Debian.amd64.gz
/usr/share/doc/libpycaml-ocaml/changelog.Debian.gz
/usr/share/doc/libpycaml-ocaml/copyright

Changelog

2017-08-08 - Stéphane Glondu <glondu@debian.org>
pycaml (0.82-15) unstable; urgency=low
[ Sylvain Le Gall ]
* Remove Sylvain Le Gall from uploaders (Closes: #869325)
[ Stéphane Glondu ]
* Bump debhelper compat to 10
* Switch debian/copyright to format 1.0
* Update Vcs-*
* Bump Standards-Version to 4.0.1
* Remove debian/pycompat
2015-08-22 - Matthias Klose <doko@debian.org>
pycaml (0.82-14.1) unstable; urgency=medium
* Non-maintainer upload.
* Build using dh-python. Closes: #786238.
2011-07-02 - Stéphane Glondu <glondu@debian.org>
pycaml (0.82-14) unstable; urgency=low
[ Stéphane Glondu ]
* Bump Standards-Version to 3.9.2
[ Barry Warsaw ]
* PyEval_CallObject became a macro in Python 2.7, so it needs a wrapper
to compile properly (LP: #688862, Closes: #632329)
2010-06-21 - Stéphane Glondu <glondu@debian.org>
pycaml (0.82-13) unstable; urgency=low
* Add versioned Conflicts to pycaml (Closes: #586656)
2010-06-19 - Stéphane Glondu <glondu@debian.org>
pycaml (0.82-12) unstable; urgency=low
* New binary packages libpycaml-ocaml{,-dev} (Closes: #586276)
- remove pycaml, and make libpycaml-ocaml-dev provide it
* Bump Standards-Version to 3.8.4 (no changes)
2009-11-03 - Stéphane Glondu <glondu@debian.org>
pycaml (0.82-11) unstable; urgency=low
* Switch dh-ocaml 0.9
* Switch to 3.0 (quilt)
* debian/control:
- update my e-mail address and remove DMUA
- move to section ocaml
- update Standards-Version to 3.8.3
2009-06-07 - Stephane Glondu <steph@glondu.net>
pycaml (0.82-10) unstable; urgency=low
[ Stephane Glondu ]
* Add myself to Uploaders and DM-Upload-Allowed
* Use quilt instead of dpatch:
- split wrap_pycall.dpatch into Wrap-Py_-calls and
Removal-of-PyRange_New
- remove changes to upstream Makefile
- add README.source
* Update Wrap-Py_-calls.patch to wrap also PyImport_ImportModuleEx,
which became a macro in Python 2.6 (Closes: #531806)
* Various improvements (Closes: #482917):
- install library files to a subdirectory of `ocamlc -where`
- add META file and suggestion to ocaml-findlib
- document these changes in NEWS
* Modernize packaging:
- add Homepage field to debian/control
- simplify debian/rules with use of dh
- update Standards-Version to 3.8.1
[ Sylvain Le Gall ]
* Update debian/copyright to
http://wiki.debian.org/Proposals/CopyrightFormat
2009-03-05 - Samuel Mimram <smimram@debian.org>
pycaml (0.82-9) unstable; urgency=low
[ Stephane Glondu ]
* Fix dependencies and location of dllpycaml_stubs.so (thanks to
Michael Bienia).
[ Samuel Mimram ]
* Rebuild with OCaml 3.11.
* Switch packaging to git.
* Use dh-ocaml.
* Update compat to 7.
* Update standards version to 3.8.0.
* Remove useless lintian override.
2008-05-23 - Sylvain Le Gall <gildor@debian.org>
pycaml (0.82-8) unstable; urgency=low
[ Stefano Zacchiroli ]
* fix vcs-svn field to point just above the debian/ dir
[ Sylvain Le Gall ]
* Use dpatch
* Apply provided patches to wrap Py_* function call, thanks to
Christopher L. Conway (Closes: #477010)
* Update to python 2.5
* Rebuild for ocaml 3.10.2
* Add myself to uploaders
2007-09-08 - Samuel Mimram <smimram@debian.org>
pycaml (0.82-7) unstable; urgency=low
* Rebuild with OCaml 3.10.

See Also

Package Description
libpynac-dev_0.7.19-2_amd64.deb Engine for symbolic geometric calculus for Python (development files)
libpynac15_0.7.12-2+b2_amd64.deb Engine for symbolic geometric calculus for Python
libpynac17_0.7.19-2_amd64.deb Engine for symbolic geometric calculus for Python
libpyside-dev_1.2.2+source1-3_amd64.deb Python bindings for Qt 4 (development files)
libpyside-py3-1.2_1.2.2+source1-3_amd64.deb Python3 bindings for Qt 4 (base files)
libpyside1.2_1.2.2+source1-3_amd64.deb Python bindings for Qt 4 (base files)
libpyside2-5.11_5.11.0-3_amd64.deb Python 2 bindings for Qt5 (base files)
libpyside2-dev_5.11.0-3_amd64.deb Python bindings for Qt5 (development files)
libpyside2-py3-5.11_5.11.0-3_amd64.deb Python 3 bindings for Qt5 (base files)
libpythia8-dev_8.1.86-1.2_amd64.deb PYTHIA event generator of high energy physics - development files
libpythia8v5_8.1.86-1.2_amd64.deb PYTHIA event generator of high energy physics
libpython-all-dev_2.7.15-3_amd64.deb package depending on all supported Python2 development packages
libpython-dev_2.7.15-3_amd64.deb header files and a static library for Python2
libpython-stdlib_2.7.15-3_amd64.deb interactive high-level object-oriented language (Python2)
libpython2-dev_2.7.15-3_amd64.deb header files and a static library for Python2
Advertisement
Advertisement