libpstoedit-dev_3.74-1+b1_amd64.deb


Advertisement

Description

libpstoedit-dev - PostScript to editable vector graphics library (development files)

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libpstoedit-dev_3.74-1+b1_amd64.deb
Package name libpstoedit-dev
Package version 3.74
Package release 1+b1
Package architecture amd64
Package type deb
Category devel::library implemented-in::c++ libdevel role::devel-lib
Homepage http://www.pstoedit.net/
License -
Maintainer Barak A. Pearlmutter <bap@debian.org>
Download size 67.82 KB
Installed size 200.00 KB

Alternatives

Package Version Architecture Repository
libpstoedit-dev_3.74-1_i386.deb 3.74 i386 Debian Main
libpstoedit-dev - - -

Requires

Name Value
libmagick++-dev -
libplot-dev >= 2.4.1-14
libpstoedit0c2a = 3.74-1+b1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libpstoedit-dev_3.74-1+b1_amd64.deb
Source Package pstoedit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpstoedit-dev deb package:
    # sudo apt-get install libpstoedit-dev

Files

Path
/usr/include/pstoedit/base64writer.h
/usr/include/pstoedit/cppcomp.h
/usr/include/pstoedit/drvbase.h
/usr/include/pstoedit/drvfuncs.h
/usr/include/pstoedit/genericints.h
/usr/include/pstoedit/miscutil.h
/usr/include/pstoedit/ordlist.h
/usr/include/pstoedit/papersizes.h
/usr/include/pstoedit/poptions.h
/usr/include/pstoedit/psimage.h
/usr/include/pstoedit/pstoedit.h
/usr/include/pstoedit/pstoeditoptions.h
/usr/include/pstoedit/pstoeditoutputlib.h
/usr/include/pstoedit/pstoedll.h
/usr/lib/x86_64-linux-gnu/libpstoedit.so
/usr/lib/x86_64-linux-gnu/pkgconfig/pstoedit.pc
/usr/lib/x86_64-linux-gnu/pstoedit/libp2edrvlplot.la
/usr/lib/x86_64-linux-gnu/pstoedit/libp2edrvmagick++.la
/usr/lib/x86_64-linux-gnu/pstoedit/libp2edrvpptx.la
/usr/lib/x86_64-linux-gnu/pstoedit/libp2edrvstd.la
/usr/lib/x86_64-linux-gnu/pstoedit/libp2edrvwmf.la
/usr/share/aclocal/pstoedit.m4
/usr/share/doc/libpstoedit-dev/README.Debian
/usr/share/doc/libpstoedit-dev/changelog.Debian.amd64.gz
/usr/share/doc/libpstoedit-dev/changelog.Debian.gz
/usr/share/doc/libpstoedit-dev/changelog.gz
/usr/share/doc/libpstoedit-dev/changelog.html.gz
/usr/share/doc/libpstoedit-dev/copyright
/usr/share/doc/libpstoedit-dev/readme.install.gz
/usr/share/doc/libpstoedit-dev/readme.txt.gz

Changelog

2019-06-05 - Barak A. Pearlmutter <bap@debian.org>
pstoedit (3.74-1) unstable; urgency=medium
* new upstream version
* bump policy version
* bump debhelper version
2018-06-04 - Barak A. Pearlmutter <bap@debian.org>
pstoedit (3.73-1) unstable; urgency=medium
* new upstream version
2018-05-20 - Barak A. Pearlmutter <bap@debian.org>
pstoedit (3.72-1) unstable; urgency=medium
* new upstream version
* forward port quilt patches; most have been upstreamed
* debian/watch file version 4
* update debian/rules per upstream mods
2018-04-16 - Barak A. Pearlmutter <bap@debian.org>
pstoedit (3.71-1) unstable; urgency=medium
* swizzle packaging repo to salsa
* new upstream version (closes: #880650)
* patch 05-fix-plugin-loading no longer necessary
* bump policy
* bump to debhelper 11
* push cleaning list from debian/rules into debian/clean
* patch around removal of . from latex2man search path
* install examples and
* install PDF format documentation
2017-08-29 - Barak A. Pearlmutter <bap@debian.org>
pstoedit (3.70-5) unstable; urgency=medium
* restrict use of libEMF to architectures upon which it is available
2017-01-26 - Barak A. Pearlmutter <bap@debian.org>
pstoedit (3.70-4) unstable; urgency=medium
* require an identical support library version
* bump to debhelper 10
* build with libgd
* build with libEMF
2016-10-11 - Barak A. Pearlmutter <bap@debian.org>
pstoedit (3.70-3) unstable; urgency=medium
* Enable pptx support via simple build dependency on libzip-dev,
see https://bugs.launchpad.net/ubuntu/+source/pstoedit/+bug/1411907
2016-10-06 - Barak A. Pearlmutter <bap@debian.org>
pstoedit (3.70-2) unstable; urgency=medium
* Adopt package (closes: #812753).
* As the library has no reverse dependencies, i.e., is only used
internally, I agree with the previous maintainer that there is no need
for a GCC-5 library transition. This logic (closes: #791247).
* Migrate patches to modern gbp pq import/export format.
* Patch spelling.
* Patch update autotools.
2016-05-09 - James Cowgill <jcowgill@debian.org>
pstoedit (3.70-1.1) unstable; urgency=medium
* Non-maintainer upload.
[ Peter Michael Green ]
* Disable broken if-check in plugin load code so that plugins can be
successfully loaded from PSTOEDITLIBDIR. (Closes: #813316)
2016-01-22 - Roland Stigge <stigge@antcom.de>
pstoedit (3.70-1) unstable; urgency=medium
* New upstream release
- Doesn't contain external references with privacy and copyright
concerns anymore (Closes: #777305)
* debian/control: Standards-Version: 3.9.6

See Also

Package Description
libpstoedit0c2a_3.74-1+b1_amd64.deb PostScript to editable vector graphics library (runtime files)
libpstreams-dev_1.0.1-2_all.deb C++ iostream interface to POSIX process I/O
libpsurface-dev_2.0.0-2+b1_amd64.deb piecewise linear bijections between triangulated surfaces -- development files
libpsurface0v5_2.0.0-2+b1_amd64.deb piecewise linear bijections between triangulated surfaces -- shared library
libpsych-java_3.1.0-1_all.deb ruby-psych Java extension
libptexenc-dev_2019.20190605.51237-3_amd64.deb TeX Live: ptex encoding library (development part)
libptexenc1_2019.20190605.51237-3_amd64.deb TeX Live: pTeX encoding library
libpth-dev_2.0.7-22_amd64.deb GNU Portable Threads (development)
libpth20_2.0.7-22_amd64.deb GNU Portable Threads
libpthread-stubs0-dev_0.4-1_amd64.deb pthread stubs not provided by native libc, development files
libpthread-workqueue-dev_0.9.1-1_amd64.deb thread pool library (development files)
libpthread-workqueue0_0.9.1-1_amd64.deb thread pool library
libptmap-ocaml-dev_2.0.4-2_amd64.deb Maps over integers implemented as Patricia trees (Development package)
libptmap-ocaml-doc_2.0.4-2_all.deb Documentation for ocaml-ptmap
libptmap-ocaml_2.0.4-2_amd64.deb Maps over integers implemented as Patricia trees (Runtime library)
Advertisement
Advertisement