libplexus-containers1.5-java_1.7.1-5_all.deb


Advertisement

Description

libplexus-containers1.5-java - Plexus IoC Container core with companion tools

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: libplexus-containers1.5-java
Package version: 1.7.1
Package release: 5
Package architecture: all
Package type: deb
Installed size: 14 B
Download size: 4.12 KB
Official Mirror: ftp.br.debian.org
Description: unavailable.

    Download

    Source package: plexus-containers1.5

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libplexus-containers1.5-java deb package:
      # sudo apt-get install libplexus-containers1.5-java

    Changelog

    2017-09-18 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.7.1-5) unstable; urgency=medium * Team upload. * Depend on libxbean-reflect-java instead of libxbean-java * Standards-Version updated to 4.1.0 * Documented the upstream bug for 03-reproducible-metadata.patch

    2017-07-30 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.7.1-4) unstable; urgency=medium * Team upload. * Depend on libmaven3-core-java instead of libmaven2-core-java

    2017-06-30 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.7.1-3) unstable; urgency=medium * Team upload. * Fixed the compatibility with qdox 2.0~M5

    2017-06-23 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.7.1-2) unstable; urgency=medium * Team upload. * Added a symlink for plexus-component-annotations-1.5-1.6.jar in /usr/share/java to work around a gradle issue (see #865499) * Standards-Version updated to 4.0.0

    2017-06-19 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.7.1-1) unstable; urgency=medium * Team upload. * Upload to unstable

    2017-05-22 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.7.1-1~exp2) experimental; urgency=medium * Team upload. * Ensure that libplexus-component-metadata-java pulls the same version of libplexus-container-default1.5-java

    2017-05-18 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.7.1-1~exp1) experimental; urgency=medium * New upstream release - Refreshed the patches - Depend on libjdom2-java instead of libjdom1-java * Updated the URL of the project homepage * Switch to debhelper level 10

    2016-09-27 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.6-3) unstable; urgency=medium * Team upload. * Depend on libasm-java (>= 5.0) instead of libasm4-java * Standards-Version updated to 3.9.8 * Use a secure Vcs-Git URL

    2016-02-12 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.6-2) unstable; urgency=medium * Team upload. * Build with maven-debian-helper * Sort the components in the components.xml files generated by the metadata plugin. This should improve the reproducibility of the packages affected by the random_order_in_plexus_comonents_xml issue. * Moved the artifact to distinct packages to optimize the dependencies * No longer build plexus-component-javadoc (never used) * Removed the unused -doc package * Depend on libqdox2-java instead of libqdox-java * Updated Standards-Version to 3.9.7 (no changes) * Updated the URL of the project homepage

    2015-11-19 - Emmanuel Bourg <ebourg@apache.org> plexus-containers1.5 (1.6-1) unstable; urgency=medium * Team upload. * New upstream release - Removed 01-classworlds-compatibility.patch (fixed upstream) - Depend on asm4 instead of asm3 (Closes: #800862) - Build depend on junit4 instead of junit - Reverted the update to qdox 2 (not yet in Debian) * Improved the reproducibility: - Set the locale and disable the timestamps when generating the javadoc * debian/watch: Track the release tags on GitHub * Updated Standards-Version to 3.9.6 (no changes)

    Advertisement
    Advertisement