libnatpmp1_20150609-7+b1_amd64.deb


Advertisement

Description

libnatpmp1 - portable and fully compliant implementation of NAT-PMP

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libnatpmp1_20150609-7+b1_amd64.deb
Package name libnatpmp1
Package version 20150609
Package release 7+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage http://miniupnp.free.fr/libnatpmp.html
License -
Maintainer Thomas Goirand <zigo@debian.org>
Download size 9.24 KB
Installed size 32.00 KB

Alternatives

Package Version Architecture Repository
libnatpmp1_20150609-7+b1_i386.deb 20150609 i386 Debian Main
libnatpmp1 - - -

Requires

Name Value
libc6 >= 2.7

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libnatpmp1_20150609-7+b1_amd64.deb
Source Package libnatpmp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libnatpmp1 deb package:
    # sudo apt-get install libnatpmp1

Files

Path
/usr/lib/x86_64-linux-gnu/libnatpmp.so.1
/usr/share/doc/libnatpmp1/changelog.Debian.amd64.gz
/usr/share/doc/libnatpmp1/changelog.Debian.gz
/usr/share/doc/libnatpmp1/changelog.gz
/usr/share/doc/libnatpmp1/copyright

Changelog

2019-01-29 - Yangfl <mmyangfl@gmail.com>
libnatpmp (20150609-7) unstable; urgency=medium
* Fix symlink overwrites of doc directories (Closes: #905200).
* Mark Multi-Arch same for libnatpmp1.
2019-01-07 - Yangfl <mmyangfl@gmail.com>
libnatpmp (20150609-6) unstable; urgency=medium
[ Helmut Grohne ]
* Fix FTCBFS: multiarchify python Build-Depends. (Closes: #913150)
[ Yangfl ]
* Bump Standards-Version to 4.3.0.
* Bump debhelper compat to 12.
2018-08-16 - Yangfl <mmyangfl@gmail.com>
libnatpmp (20150609-5) unstable; urgency=medium
* Fix symlink overwrites of doc directories (Closes: #905200).
* Bump Standards-Version to 4.2.0.
2018-05-23 - Yangfl <mmyangfl@gmail.com>
libnatpmp (20150609-4) unstable; urgency=medium
* Move library to multiarch path.
* Make Homepage field more accurate.
2018-04-21 - Yangfl <mmyangfl@gmail.com>
libnatpmp (20150609-3) unstable; urgency=medium
* Mark Replaces and Breaks natpmp-utils for natpmpc (Closes: #894249).
* Mark Multi-Arch same for libnatpmp-dev and python3-libnatpmp.
* Disable hurd-any due to lack of rt_msghdr and RTM_*.
* Bump Standards-Version to 4.1.4.
2018-03-26 - Thomas Goirand <zigo@debian.org>
libnatpmp (20150609-2) unstable; urgency=medium
* Uploading to unstable.
2018-02-01 - Thomas Goirand <zigo@debian.org>
libnatpmp (20150609-1) experimental; urgency=medium
[ Yangfl ]
* New upstream release.
* Add Python 3 module.
* Rename natpmp-utils to natpmpc.
[ Thomas Goirand ]
* Updated VCS URLs to point to Salsa.
* Ran wrap-and-sort -bast.
* Added a debian/gbp.conf.
2011-08-24 - Thomas Goirand <zigo@debian.org>
libnatpmp (20110808-3) unstable; urgency=low
[ Thomas Goirand ]
* Moves the natpmpc inside a new natpmp-utils package (Closes: #639084).
* Removes Debian specific natpmpc.1, since upstream integrated it in his
upstream tarball.
[ Stanislav Maslovski ]
* debian/control:
- no need to build-depend/depend on python: python module is not built
- corrected libnatpmp1 dependencies
- corrected libnatpmp-dev dependencies
- natpmp-utils replaces older libnatpmp binaries
- linatpmp1 suggests natpmp-utils
* debian/rules:
- do not move files by hand, use dh_install
- install docs and changelogs only once
* new files:
- natpmp-utils.install, natpmp-utils.manpages,
libnatpmp-dev.install, libnatpmp1.install
* removed files:
- libnatpmp1.shibls (not needed; autogenerated by dh_makeshlibs),
manpages
2011-08-22 - Thomas Goirand <zigo@debian.org>
libnatpmp (20110808-2) unstable; urgency=low
* Removes the Provides: libnatpmp0 (Closes: #638828).
2011-08-09 - Thomas Goirand <zigo@debian.org>
libnatpmp (20110808-1) unstable; urgency=low
* New upstream version 20110808, now building on kFreeBSD (Closes: #636786).
* libnatpmp-dev doesn't recommends minissdpd anymore (Closes: #630334).

See Also

Package Description
libnautilus-extension-dev_3.34.1-1_amd64.deb libraries for nautilus components - development version
libnautilus-extension1a_3.34.1-1_amd64.deb libraries for nautilus components - runtime version
libnauty2-dev_2.6r10+ds-1_amd64.deb library for graph automorphisms -- development package
libnauty2_2.6r10+ds-1_amd64.deb library for graph automorphisms -- library package
libnav-msgs-dev_1.12.7-1_amd64.deb Messages relating to Robot OS nav, C/C++ interface
libnb-absolutelayout-java_10.0-3_all.deb Java LayoutManager to allow placement in absolute positions
libnb-apisupport3-java_10.0-3_all.deb Common NetBeans Platform Development Related Libraries for NetBeans
libnb-ide14-java_10.0-3_all.deb Common Integrated Development Environment Libraries for NetBeans
libnb-java5-java_10.0-3_all.deb Common Java Related Libraries for NetBeans
libnb-javaparser-java_9+2018-1_all.deb Parser for the Java language which is good for use in tools
libnb-org-openide-modules-java_10.0-2_all.deb Utility classes for modules from the NetBeans Platform
libnb-org-openide-util-java_10.0-2_all.deb Utility classes from the NetBeans Platform
libnb-org-openide-util-lookup-java_10.0-2_all.deb Utility lookup classes from the NetBeans Platform
libnb-platform-devel-java_10.0-2_all.deb Build harness for NetBeans Platform
libnb-platform18-java_10.0-2_all.deb NetBeans Platform for building rich desktop applications in Java
Advertisement
Advertisement