libmpdclient2_2.16-1+b1_amd64.deb


Advertisement

Description

libmpdclient2 - client library for the Music Player Daemon

Property Value
Distribution Debian Sid
Repository Debian Main amd64
Package filename libmpdclient2_2.16-1+b1_amd64.deb
Package name libmpdclient2
Package version 2.16
Package release 1+b1
Package architecture amd64
Package type deb
Category libs role::shared-lib
Homepage https://www.musicpd.org/libs/libmpdclient/
License -
Maintainer mpd maintainers <pkg-mpd-maintainers@lists.alioth.debian.org>
Download size 41.29 KB
Installed size 145.00 KB

Alternatives

Package Version Architecture Repository
libmpdclient2_2.16-1_i386.deb 2.16 i386 Debian Main
libmpdclient2 - - -

Requires

Name Value
libc6 >= 2.28

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmpdclient2_2.16-1+b1_amd64.deb
Source Package libmpdclient

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmpdclient2 deb package:
    # sudo apt-get install libmpdclient2

Files

Path
/usr/lib/x86_64-linux-gnu/libmpdclient.so.2
/usr/lib/x86_64-linux-gnu/libmpdclient.so.2.16
/usr/share/doc/libmpdclient2/AUTHORS
/usr/share/doc/libmpdclient2/changelog.Debian.amd64.gz
/usr/share/doc/libmpdclient2/changelog.Debian.gz
/usr/share/doc/libmpdclient2/changelog.gz
/usr/share/doc/libmpdclient2/copyright

Changelog

2019-01-05 - Florian Schlichting <fsfs@debian.org>
libmpdclient (2.16-1) unstable; urgency=medium
[ Geoffroy Youri Berret ]
* update d/watch and enable pgpmode
* Switch to source format 3.0 (quilt)
[ Florian Schlichting ]
* Import new upstream version 2.16 (Closes: #900513)
[ Geoffroy Youri Berret ]
* Update d/control:
+ debhelper-compat to 12
+ Standards-Version to 4.3.0
+ new Homepage
+ no more -dbg package
* Drop obsolete lintian override
* Update symbols
* Switch to short-form debian/rules
* Upstream no longer builds a static library
* Refactored copyright (dep-5 machine-interpretable format)
[ Florian Schlichting ]
* Takeover for the mpd-team (Closes: #916729)
* Make d/rules even shorter, keep installing NEWS and AUTHORS as before
* Run build-time tests
* Properly transition to dbgsym package
2017-10-22 - Sebastian Harl <tokkee@debian.org>
libmpdclient (2.11-1) unstable; urgency=medium
[ Helmut Grohne ]
* Pass a multiarch --libdir to ./configure (Closes: #871412).
[ Sebastian Harl ]
* New upstream version.
* Update standards version to 4.1.1:
- Update to debhelper compat version 10.
- Remove build-dep on autotools-dev which has been subsumed by DH 10.
- Use priority "optional" in place of deprecated "extra".
- Override embedded-javascript-library lintian warning: doc embeds
jquery.js which is a modified version from Doxygen.
2013-11-23 - Sebastian Harl <tokkee@debian.org>
libmpdclient (2.9-1) unstable; urgency=low
* New upstream release (Closes: #671094).
* debian/libmpdclient-dev.install:
- Install the vapi file.
* debian/libmpdclient2.symbols:
- Updated for new upstream version.
* debian/rules:
- Split build target into build-arch and build-indep.
- Use dpkg-buildflags to get CPPFLAGS and CFLAGS.
- Use dh_autotools-dev* to update config.{sub,guess}; thanks to Matthias
Klose for reporting and suggesting this (Closes: #727416).
* debian/control:
- Updated standards-version to 3.9.4.
2010-07-29 - Sebastian Harl <tokkee@debian.org>
libmpdclient (2.3-1) unstable; urgency=low
* New upstream release.
- Do not try to install GIF files from doc/api/html/ if none are available
(doxygen no longer creates any GIF files since version 1.7 or so)
(Closes: #590397).
* debian/control:
- Updated standards-version to 3.9.1 -- no changes.
* debian/libmpdclient2.symbols:
- Updated for 2.3.
2010-06-09 - Sebastian Harl <tokkee@debian.org>
libmpdclient (2.2-1) unstable; urgency=low
* New upstream release.
* debian/libmpdclient2.symbols:
- Updated for 2.2.
* debian/control:
- Updated to standards-version 3.8.4 -- no changes.
- Let all packages depend on ${misc:Depends}, as suggested by debhelper.
* debian/rules:
- Let dh_makeshlibs create a dependency on libmpdclient2 >= 2.2, which is
required since new functionality has been added.
2009-12-27 - Sebastian Harl <tokkee@debian.org>
libmpdclient (2.1-1) unstable; urgency=low
* New upstream release.
* debian/libmpdclient2.symbols:
- Updated for 2.1.
* debian/rules:
- Run 'make check' unless the nocheck option has been specified in
DEB_BUILD_OPTIONS.
2009-10-22 - Sebastian Harl <tokkee@debian.org>
libmpdclient (2.0-1) unstable; urgency=low
* Initial release (Closes: #549646).

See Also

Package Description
libmpdec-dev_2.4.2-2_amd64.deb library for decimal floating point arithmetic (development files)
libmpdec-doc_2.4.2-2_all.deb library for decimal floating point arithmetic (documentation)
libmpdec2_2.4.2-2_amd64.deb library for decimal floating point arithmetic (runtime library)
libmpeg2-4-dev_0.5.1-8+b1_amd64.deb libmpeg2 development libraries and headers
libmpeg2-4_0.5.1-8+b1_amd64.deb MPEG1 and MPEG2 video decoder library
libmpeg2encpp-2.1-0_2.1.0+debian-6_amd64.deb MJPEG capture/editing/replay and MPEG encoding toolset (library)
libmpeg3-2_1.8.dfsg-2.1+b1_amd64.deb MPEG streams decoding library
libmpeg3-dev_1.8.dfsg-2.1+b1_amd64.deb Headers and static libraries for libMPEG3
libmpfi-dev-common_1.5.3+ds-3_all.deb multiple precision floating-point interval computation library -- headers
libmpfi-dev_1.5.3+ds-3_amd64.deb multiple precision floating-point interval computation library -- libdev
libmpfi-doc_1.5.3+ds-3_all.deb multiple precision floating-point interval computation library -- doc
libmpfi0_1.5.3+ds-3_amd64.deb multiple precision floating-point interval computation library -- lib
libmpfr-dev_4.0.2-1_amd64.deb multiple precision floating-point computation developers tools
libmpfr-doc_4.0.2-1_all.deb multiple precision floating-point computation documentation
libmpfr6_4.0.2-1_amd64.deb multiple precision floating-point computation
Advertisement
Advertisement