libmono-cecil-cil-dev - library to generate and inspect CIL assemblies

Distribution: Debian Sid
Repository: Debian Main amd64
Package name: libmono-cecil-cil-dev
Package version: 0.9.5+dfsg
Package release: 5
Package architecture: all
Package type: deb
Installed size: 15 B
Download size: 5.35 KB
Official Mirror:
Description: unavailable.



  • libmono-cecil0.3-cil
  • libmono-cecil0.4-cil
  • libmono-cecil0.5-cil


  • libmono-cecil0.3-cil
  • libmono-cecil0.4-cil
  • libmono-cecil0.5-cil


    Source package: cecil

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmono-cecil-cil-dev deb package:
      # sudo apt-get install libmono-cecil-cil-dev


    2016-11-07 - Jo Shields <> cecil (0.9.5+dfsg-5) unstable; urgency=medium * [2bb85b2] Avoid depending on strict Mono version due to dh_clideps error (Closes: #841615)

    2015-12-15 - Jo Shields <> cecil (0.9.5+dfsg-4) unstable; urgency=medium * [328ec4f] Force 4.5 framework for build

    2015-11-10 - Jo Shields <> cecil (0.9.5+dfsg-3) unstable; urgency=medium * No-change rebuild for CLR 4.5 transition

    2012-01-18 - Iain Lane <> cecil (0.9.5+dfsg-2) unstable; urgency=low * No-change rebuild for CLR 4.0 transition

    2011-08-07 - Iain Lane <> cecil (0.9.5+dfsg-1) experimental; urgency=low [ Iain Lane ] * [411dc78] Update to use my d.o email address * [74bedaf] Disable clilibs; this is an unstable library apps grow unnecessary depends otherwise * [5288c1f] Mangle debian version in watch file to take care of repacking. Also update watch file to look at new github location for tarballs * [8f7110f] Relax version restriction on cli-common-dev; anything from 0.8 will do [ Jo Shields ] * [e846eb8] Imported Upstream version 0.9.5+dfsg * [3017d96] Bump build dependencies, as we're building for Mono 2.10 now. * [27c2cff] Set to DebSrc 3.0, so we can apply patches via Quilt. * [d0447b3] Update build to use XBuild, not manual compiler invocation. * [08d2b92] Patch to avoid building tests (which rely on NUnit 2.4) * [fa5a033] Update install file to include all new assemblies and locations. * [43bd1e2] Since upstream no longer ships a pcfile, add our own. * [942ead4] Don't try to ship a Changelog when none exists. * [ba8232d] Erase obj/ folders in clean rule. * [090af34] Exclude modulerefs on Windowsy libraries.

    2011-05-28 - Iain Lane <> cecil (0.6+svn148654-2) unstable; urgency=low * [ca3fb1b] Sign library with mono signing key * [12bfdca] Standards-Version → 3.9.2, no changes required

    2010-01-06 - Iain Lane <> cecil (0.6+svn148654-1) unstable; urgency=low * debian/control: Move to git and update Vcs-* metadata * New upstream SVN snapshot, needed for db4o * Package as unstable as the library is not considered by upstream to be API or ABI stable. Consumers must now copy the library. * debian/control, debian/rules, debian/patches: Disable patchsys as this was only used to change assembly version which is now not necessary. * debian/rules, debian/mono.snk.uue: No need to sign now, not necessary for unstable libs. * debian/rules: Modify pcfile munging to use new assembly dir * debian/changelog, debian/clean, debian/ Update dh7isation * debian/control: Change build-depends on packages provided by `mono' source package to mono-devel (>= 2.4.3) as this provides all we need. * debian/control: Add myself to Uploaders, remove MIA people.

    2009-11-06 - Jo Shields <> cecil (0.6-3) unstable; urgency=low * debian/rules, debian/control: + Use mono-csc from mono-devel * debian/control: + No-change bumpo to Standards 3.8.3 + Change section to cli-mono * debian/control, debian/libmono-cecil-cil-dev.install: + Add new -dev package for better handling of ABI changes * debian/rules, debian/install, debian/installcligac: + CLI Policy 0.7 install location

    2009-02-25 - David Paleino <> cecil (0.6-2) unstable; urgency=low * debian/rules, debian/control: + updated for Mono 2.0 transition * debian/control: + added Homepage field, dropped from long description + debhelper dependency bumped to >= 7 + added ${misc:Depends} dependency + Standards-Version bumped to 3.8.0: - debian/README.source added + added Vcs-* fields * debian/compat bumped to 7 * debian/rules: + updated: using dh7-style + added get-orig-source target * debian/patches/: + 01_assembly-version.dpatch: added description * debian/watch added